Solved

TREE or Server can not be found after Upgrading on XPSP2

Posted on 2006-06-09
7
544 Views
Last Modified: 2008-02-01
Hello,
i am using a Novell Netware 6 on the server and recently upgrade all the computer clients from Windows XP to Windows XP SP2.
The Novell Netware client version running on the desktop machines is v4.91 SP2.
Novell client installation was done with the option IP only. The firewall has been disabled in Windows XP.
The problem is that after starting the Windows it take around 5-10 minutes to login. The message displayed is "TREE or Server can not be found"
Sometimes i have to restart the client pc 7-8 times and wait each time up to 6-10 minutes to login.
On the Novell knowledge base advice to upgrade the Netware client which was not useful.
Any ideea on how to troubleshoot ?
0
Comment
Question by:djmagicb
7 Comments
 
LVL 30

Expert Comment

by:pgm554
ID: 16872040
Did you do a custom install?
No NMAS?
If you installed NMAS on the client piece,it can bog things down.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 16873010
Did you have the 4.91 client already installed prior to updating to XP SP2?

Have you applied any post-4.91SP2 patches to the client?  There are several, enough to make an update-pack.

Go to http://support.novell.com/cgi-bin/search/searchtid.cgi?/2973629.htm

You may want to go to http://support.novell.com/filefinder/month/index.html and look for any new client patches that may refer to your problem, as well

As pgm554 said, if you have NMAS installed and don't use NMAS login methods, it can slow things down considerably, but you would've noticed slow logins prior to XPSP2 if you had it installed, too.  Just for kicks, uninstall NMAS (if you don't use it) and set "use NMAS" to "no" in the client32 properties, advanced login tab.

There are other things XPSP2 has going against it besides the firewall, too.  Check all of your services and make sure nothing you don't need is enabled.

Also, in Windows Explorer, Tools, Folder Options, View tab, make sure "automatically search for network files and printers" is off, as well as "simple file sharing."

Also, regarding the XP firewall, don't just turn it "off" in the Security Center.  Disable the firewall service in the Services control panel.
0
 
LVL 5

Accepted Solution

by:
floyd99 earned 500 total points
ID: 16891968
time it...  after the login screen appears,  is it somewhere close to 5 minutes before you can log in?

if so,  i had exactly this issue at one of my 7 sites.  it only occured at one site and only on some PC's.  I spent a whole weekend trying to debug it and i tried absolutely everything.

finally, this fixed it;   go into the novell client properties, advanced settings, and near the top you'll see bad address cache timeout.  Set it to zero.  reboot.    You'll notice it was set to 300 seconds, and this equates to 5 minutes.

see if that helps.
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 35

Expert Comment

by:ShineOn
ID: 16892119
Good  call, floyd99.  Had the same issue when I started using wireless with 802.1x WPA-1 - somehow the NetWare servers got into bad address cache and those PC's experienced the tree/server not found thing, and setting it to zero fixed it.
0
 
LVL 5

Expert Comment

by:floyd99
ID: 16892168
i'll never forget about that setting.. because I spent 2 full days at a site an hour and a half drive away at a coastal town in the middle of nowhere trying to fix it before classes on the monday...  I tried so many things. What was weird is it only happened on the PC's that had been recently re-imaged with a newer ghost image.   What caused the server to be placed in the bad cache I still don't know, but we've pushed out a reg setting to disable it on every PC across the network.... don't even know (or care) what the bad cache does.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 16892180
It's supposed to speed things up - non-responding IP addresses don't get retried while they're in the cache.

There's a similar setting for bad server name cache that it also might help to disable.
0
 

Author Comment

by:djmagicb
ID: 16893216
Thanks guys. it works perfectly
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
GroupWise attachment 9 524
Novell Linux file blocking 8 444
Novell OES Admin password not recognised 8 381
Netware file transfer to a quad-core PC locks up 5 615
Fine Tune your automatic Updates for Ubuntu / Debian
We need a new way to communicate time sensitive or critical info.   The best part of my role at xMatters is visiting our clients all over the world to learn about how they operate their businesses, share insights that xMatters has gleaned across…
Concerto provides fully managed cloud services and the expertise to provide an easy and reliable route to the cloud. Our best-in-class solutions help you address the toughest IT challenges, find new efficiencies and deliver the best application expe…
Delivering innovative fully-managed cloud services for mission-critical applications requires expertise in multiple areas plus vision and commitment. Meet a few of the people behind the quality services of Concerto.

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now