Solved

XP Professional Remote Desktop connectivity issue affecting multiple machines. Connection was ended because of a network error

Posted on 2006-06-09
6
3,298 Views
Last Modified: 2013-11-21
Halo..

We have several model Dell systems with several different images at our company. Many of the systems that were previously able to be controlled by other XP Pro systems using RDC, are now receiving the error.
"REMOTE DESKTOP DISCONNECTED
The connection was ended because of a network error. Please try connecting to the remote computer again."
Here are some system details and troubleshooting steps that have already been done without success. ALSO, two of the systems corrected themselves somehow over several weeks(users called and asked what I did to fix it, that's how I know). These systems are usually always on in order to receive updates.

-All referenced systems are XP Professional Sp1a w/o ICF enabled, and have all worked at one time.
-These systems are part of an Active directory, and the problem does not care whether you are on the same LAN segment or not.
-All problematic systems have the ability to control other systems, but cannot be controlled.
-Reimaging the systems with known working images takes about 20 minutes and DOES NOT solve the issue.
-Reimaging the systems with different names that are newly added to the AD doesn't work.
-Reimaging the systems with even newer names on different LAN segments than they were originally on doesn't work.
-3389 is listening
-MSlicensing key was deleted, but never came back even after launching RDC.
-I used a different version of MSTSC.exe that allows you to remote into yourself for testing, and that error comes up "The terminal server has ended the connection"
-Terminal services is running
-Nbtstat -RR
-Gpupdate -Force
-looked for the GlobalPolicy folder in system32, but it wasn't there to delete.
-Different profiles were used, without conflicting permissions, all tested accounts were part of the administrator's group as well as remote desktop users group. tests were done with all different combos of this.
-Imported MSLicensing key from a working system, and no go.
-Expensive Microsoft tech support does not know that you cannot RDC into yourself using XP RDC and all subsequent suggestions were of even less help, because they did not take into consideration the above details.

The ONLY system i was given full control of that had all of the reimaging done, was from a user who pimarily uses Macs, and her issue was resolved, and I am not sure what caused this to work and not the reimaging, but by installing XP from scratch, and I tested that RDC worked after being in workgroup, added to domain, and tested after each software installation, and the user is as happy as can be. My issue is that the main PC user's on this campus don't all have the luxury of giving me their PC for this "possible" fix to be applied, and I don't have the time if it turns out that the majority of the 1,500+ users here run into this issue, especially since we use the images on new systems and they work fine. The one thing I am thinking of that may make this an AD issue or some sort of DHCP/DNS/WINS cache thing, is that when I rebuilt the system from scratch, it had not been on the network for about 4 hours versus being reloaded and popped back on within 20 minutes, and maybe something kept the MAC address and corresponding information.  All I know is that the other wonderful departments (server and networking) won't touch this because they are lazy and/or really think this is a desktop issue.

Thanks in advance for ANY additional input on this. this is my first post and the impetus for joining you guys here, I hope to return the favor one day!
0
Comment
Question by:SeniorSystemsEngineer
  • 3
6 Comments
 
LVL 1

Expert Comment

by:zerosoma
Comment Utility
need to know more about these affected machines

what do they all have in common?

0
 

Author Comment

by:SeniorSystemsEngineer
Comment Utility
Common Components
-All are XP Professional Sp1a, with current MS patches
-This problem for many of these users has been going on for quite some time(months), but many are just getting around to reporting it, despite MS updates and other Group Policy updates and other patches that have been rolled out.
-Mcafee 7.1(troubleshot with it uninstalled)
-Landesk(troubleshot with it uninstalled)
-Webroot Spysweeper(troubleshot with it uninstalled)
-IE 6
-Office XP
-Acrobat Reader 7
-Winzip

Differences

-Problem systems span entirely different LAN segments, and buildings for that matter.
-Group specific software for different groups containing problem systems can range from programming software, to in house apps, to different versions of java, visio, project, and in house apps. Some problem systems simply have the base load as stated in the common components list above and just use them for email and surfing.

One thing I thought I added in my initial description that I saw wasn't there, was that I had a fe wof the users shut their systems down over the weekend to see if that would reset something on the network, but it did not fix anything.

Thanks!
0
 

Author Comment

by:SeniorSystemsEngineer
Comment Utility
UPDATE:

-I made an image of one of the troubled systems and performed the following on it. Removed several pieces of software to make the image leaner to speed up restores in case I need to dump another copy of it somewhere else. After each software uninstall I tested connecting to the system via RDC with the same error.

-Installed XP Sp2 with the same error(yes I made sure ICF was off and all that good stuff).

-Finally, even though in theory it doesn't make any sense, I ran SYSPREP with the mini-setup on the system. After running that and having the system come up in a workgroup I was successful at connecting to the system via RDC!! YAY!!
I then added the system to the domain and was also again successful connecting to the system via RDC.

This doesn't make sense considering that the images that we use here cross several platforms and work fine on hundres of machines. Also in theory this shouldn't make a difference because once the system is added to the domain, it should get a new SID. I am going to try this on one of the systems that is having trouble that are in production right now and will provide a follow up as to whether using SYSPREP will be the solution to this issue or not.

Thanks again for the overwhelming support with this issue, even though it has only been 10 days since posting!
0
 

Author Comment

by:SeniorSystemsEngineer
Comment Utility
UPDATE UPDATE:

General Sysprepping with the minisetup fixes this problem. I just did that on a production system and have several left to go. Write down the TCP/IP settings as well as the system name since sysprep, even with the appropriate switches and script files handy, most likely will erase those settings. Also have the XP CDKey handy since it MAY ask you for it. Other than that, it should keep all other permissions/group settings. I also backed up the ETC directory because I feel safer doing that since some of the hosts files are quite long.

I wish I could give myself 500 points.
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
Comment Utility
PAQ / Refund
ee ai construct, community support moderator
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now