Solved

Dos Bios Upgrade: "This system does not support flash memory"

Posted on 2006-06-10
15
1,655 Views
Last Modified: 2009-12-16
This ought to be a quickie answer.

I wanted to upgrade / flash the bios of a gateway model 510x.  I obtained the updates from gateway's homepage for this model. I double-checked that the existing bios matched the type - it did. I made sure I booted to dos using a win98 boot disk, like they said. But when I then ran the iflash.exe file (from a second floppy), it said:
"This system does not support flash memory"

Luckily there was a slightly older update that ran from windows.

But what causes this error, for future reference? (remember, I double-checked that it was right for this PC)
0
Comment
Question by:dgrrr
  • 6
  • 5
  • 4
15 Comments
 
LVL 32

Accepted Solution

by:
_ earned 30 total points
ID: 16879705
I don't know for sure, but it might be an  I/O problem with DOS on "fast" systems.

I just had a similar problem with a K7S5A running a 750 Duron.
Made a clean bootdisk (W98) with the flash program and bios file. It keep spitting Errors at me.
Changing out floppies and cables (several) made no difference.

But if I booted from the floppy, and ran the files from the hard drive, it was smooth as silk. : /
0
 
LVL 38

Assisted Solution

by:BillDL
BillDL earned 30 total points
ID: 16879738
Are you talking about the FX510 model, ie the one with the Intel (Cortez) 945G Motherboard?

It is usually recommended that for BIOS updates you boot to a floppy that loads the bare minimum rather than a Win98 boot floppy that creates a temporary RamDrive and loads memory managers and other drivers.
Formatting a floppy and ticking the "copy system files" option from within Win98 creates a pretty clean boot floppy also, but it's better to delete DRVSPACE.BIN from it for BIOS upgrading.

Alternatively, you'll see 3 download links against the "Driver Free Disk For BIOS Flashing" near the top of this page:
http://www.bootdisk.com/
Just double-click http://www.abitfaq.it/Files/drdflash.exe with a blank floppy in the drive and it will make a clean boot floppy based on DrDOS containing autoexec.bat, command.com, ibmbio.com, and ibmdos.com.

Test it first by copying a test *.exe file to it and adding a new line to execute it in autoexec.bat.
A good test  .exe file would be something that just displays the syntax when run without any parameters like PKZIP.EXE from this package:
http://www.bootdisk.com/tennessee/pkzip204.exe (self extractor)
or even FDISK.EXE (from which you can escape back to the A:\> Prompt again), or EDIT.COM.
The idea is that you are just making sure that an .exe can be run from autoexec.bat, and you can then add your BIOS file and flash utility to the disk and change autoexec.bat to run it, or just run it manually.

I'm not saying with any certainty that loaded drivers, etc caused the error message, but it is possible.  I would have expected the error message "This BIOS cannot be reflashed because of installed memory managers" had that been the main reason but, as you will have experienced many times before, error messages can be misleading.
0
 
LVL 38

Expert Comment

by:BillDL
ID: 16879746
Incidentally, here are the common command line options that can be used at the command line with iFlash.exe (depending on the version):

/h -  Help (this text)
/q  - Quiet mode; errors only, and no prompts
/qb - Quiet mode; No beeps

Standard options:

/r - Force reboot after update
/@ - Use override file
/f - Force CMOS defaults next POST
/d - Verbose debugging output
/c - Clear ESCD (Extended System Configuration Data) next POST
/p pathname  - Program FLASH device with contents of 'pathname'.
/pu pathname - Program User Binary area with contents of 'pathname'.
/v pathname  - Verify current FLASH with contents of 'pathname'.
/sX pathname - Save resident FLASH area to 'pathname' (or 'vvvv'BIOS),
  X = { 'B'IOS, 'L'anguage, 'U'ser, or 'R'ecovery } area.
/x pathname  - eXamine FLASH header of 'pathname'.

Special Operations:

/v pathname  - Verify current flash with contents of 'pathname.'
/x pathname  - eXamine flash header of 'pathname'.
/sX pathname - Save resident flash area to 'pathname' (or 'vvvv'BIOS)
  X = { 'B'IOS, 'L'anguage, 'U'ser, 'R'ecovery } area.
/ae - Erase OEM CMOS Defaults.
/ac - Copy Custom CMOS Defaults into the OEM CMOS Defaults.
/af - Force OEM CMOS Defaults next POST.
/ag pathname  - Get OEM CMOS Defaults to 'pathname'.
/as pathname  - Set OEM CMOS Defaults with contents of 'pathname'.
/ew pathname  - Write BMI settings with contents of 'pathname'.
/er pathname  - Retrieve BMI settings to 'pathname'.
0
 

Author Comment

by:dgrrr
ID: 16882642
coral47:
I tried running the files from HD, no help, in my case


BillDL:

the model # is simply:
Gateway 510X
altho there is an H on the far right, e.g.
Gateway 510X                 H
dunnow what that extra letter means.


FYI, I tried creating the "Driver Free Disk For BIOS Flashing" on two different PCs, with two different diskettes, with three different copies of "drdflash.exe". IN all cases, the writing process to to about 60% and then said:
Disk error on track 50, head 0. error in reading.  
0
 
LVL 38

Expert Comment

by:BillDL
ID: 16883869
Looks like it's a Media Center computer available in 3 different versions:

510 X Media Center Computer R0 - 2800436
http://support.gateway.com/s/PC/510Series/2800436/2800436nv.shtml
510 X Media Center Computer R1 - 2900036
http://support.gateway.com/s/PC/510Series/2900036/2900036nv.shtml
510 X Media Center Computer R2 - 2900322
http://support.gateway.com/s/PC/510Series/2900322/2900322nv.shtml

The Gateway site is pretty hard to find what you want, and I struggled to find any downloads for them apart from the manuals.
0
 
LVL 32

Expert Comment

by:_
ID: 16891573
>> Disk error on track 50, head 0. error in reading <<

I still don't know why the flash programs are stalling.
I have been playing with mine, and it will not even throw errors now. Starts to read the file on the floppy, then stops dead.   : (

Other .EXE files work fine after booting from the same boot disk. And if I change to the hard drive, the flash file runs great.
0
 
LVL 38

Expert Comment

by:BillDL
ID: 16897854
You could try making a basic Win98 DOS boot floppy by ticking the "copy system files" option when formatting a new floppy.  Delete DRVSPACE.BIN and just leave command.com, io.sys, and msdos.sys.  That will boot cleanly and the BIOS update from that floppy might work.  I can only assume that the disk error is caused by the way that downloaded boot floppy maker file writes the disk.
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Author Comment

by:dgrrr
ID: 16898832
Sorry guys, I had to return the computer to the owner today. Should I award the pts based on coral47's progress?

thx

(as always, I take note of all advice for future ref!)
0
 

Author Comment

by:dgrrr
ID: 16898837
PS - BillDL -- that procedure you describe, making a basic Win98 Dos boot floppy -- is that in the contect of windows 98? I assume it's not from WinXP, which has diff options (e.g. format / "create an MS-DOS startup disk")
0
 
LVL 38

Expert Comment

by:BillDL
ID: 16899677
Yes, thanks for correcting that dgrr.  I forgot when I was when I posted.  Yes, that option in Windows XP doesn't create an ideal clean boot floppy for these purposes.  All it does is add legacy DOS files (a mix of Win98 and ME files as far as I can see) to make a floppy that loads drivers.  If available, it would have been better making the boot floppy on a Win98 computer, but that's all academic now that the PC has been returned to the owner.

Points are entirely up to you, but I agree that coral47's suggestions were very constructive and were definitely going somewhere.  I'm quite sure he would have figured it out in the end. Good call - points to coral47 (that's if you agree :-)
0
 
LVL 32

Expert Comment

by:_
ID: 16899718
Bill: Sorry. Forgot to say that is how I am making the clean boot disks.  : /

Tryed it on a newer version K7S5A I needed to flash anyway, same thing. It flat refuses to work from the floppy, but works like a charm when run from the hard drive after booting from the floppy.
I did several updates (in order). Even a couple of the "over clocking bios's" somebody wrote, went on without a hitch. Just not from the floppy.
This is the first time I have had trouble running from a floppy. The last one I did was a 750MHz SlotA (SD-11) which is also a 100MHz FSB.   : /


>> Should I award the pts based on ... <<   I would ask C.S. to PAQ/Refund, 'cause I am just guessing.   : )

Yes, that is the W9x procedure for making a clean DOS disk.
0
 
LVL 32

Expert Comment

by:_
ID: 16899732
Hahaha. Snuck one in on me while I was typing.
0
 
LVL 38

Expert Comment

by:BillDL
ID: 16902956
coral47 :-)
Thank you, dgrr
0
 
LVL 32

Expert Comment

by:_
ID: 16908675
Thank you much.    : )

Now I have a new problem. The onboard LAN setting keeps disappearing from the bios on the newer mobo.   : /
It must have a wanky chip.
0
 

Author Comment

by:dgrrr
ID: 16928744
I actually have that issue on one of my PCs -- certain bios settings keep disappearing (e.g. "numlock=off").
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How can this article save you time AND money?  In just a few minutes you may discover something you didn't know existed that is easy enough for you to fix yourself!
No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now