rndc: connect failed: connection refused

dear,

i have stopped the named and then i got this error message
ndc: connect failed: connection refused

then when i start it, it does not give any error message, but i can not find the named service in the list of services using ps -ef | grep named

what shall I to stop the named correctly then be able to start it

here is my named.conf file

/etc# cat named.conf
# Use with the following in named.conf, adjusting the allow list as needed:
include "/etc/rndc.key";
 
controls {
        inet 127.0.0.1 port 953
                allow { 127.0.0.1; } keys { "rndc-key"; };
};
 
options {
        directory "/";
        dump-file "dump/named_dump.db";
       
        // Don't reveal BIND version
        version "";
 
        allow-transfer { 127.0.0.1; };
        allow-recursion { 127.0.0.1; 10.0.0.0/8; };
};
 
// Root cache
//
zone "." { type hint; file "standard/root.hint"; };
 
// Standard zones
//
zone "localhost" { type master; file "standard/localhost"; };
zone "127.in-addr.arpa" { type master; file "standard/loopback"; };
 
// malibu Zones
//
zone "malibu.lan" { type forward; forwarders { 10.1.10.13; 10.1.10.14; }; };
zone "10.in-addr.arpa" { type forward; forwarders { 10.1.10.13; 10.1.10.14; }; };
zone "erqon.malibu.com" IN {
        type master;
        file "zone/erpprod.zone";
        allow-update { none; };
};
zone "58.1.10.in-addr.arpa" {
        type master;
        file "zone/10.1.58.zone";
        allow-update { none; };
};

my zones are there and correct,
the service was working, and there were no changes, just after stopping, it cannot start again
malibusaAsked:
Who is Participating?
 
giltjrConnect With a Mentor Commented:
Yep, var is full.
I don't know of an easy way, but typically everything logs to /var/log.  So  I would start by going into /var/log and issuing the command:  

     ls -l | more

and see what is taking up the space.  
0
 
malibusaAuthor Commented:
the named.pid file is located in here
/var/named/var/run/named.pid

and i have deleted it but still, it did not solve the problem
0
 
malibusaAuthor Commented:
if i run the command using the down line, it works, but for sure i do not want use root to run it

/usr/local/sbin/named -u root -t /var/namedroot

so if i put named instead of root, it does not work
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
giltjrCommented:
Do you see any errors in /var/log/messages?  Assuming this is where syslogd writes to.
0
 
malibusaAuthor Commented:
dear,

it seems for me the logging is off,

see the syslog.conf file, down, and let me know which file to see for the needed log

#ident  "@(#)syslog.conf        1.5     98/12/14 SMI"   /* SunOS 5.0 */
#
# Copyright (c) 1991-1998 by Sun Microsystems, Inc.
# All rights reserved.
#
# syslog configuration file.
#
# This file is processed by m4 so be careful to quote (`') names
# that match m4 reserved words.  Also, within ifdef's, arguments
# containing commas must be quoted.
#
*.err;kern.notice;auth.notice                   /dev/sysmsg
*.err;kern.debug;daemon.notice;mail.crit        /var/adm/messages
 
*.alert;kern.err;daemon.err                     operator
*.alert                                         root
 
*.emerg                                         *
 
# if a non-loghost machine chooses to have authentication messages
# sent to the loghost machine, un-comment out the following line:
#auth.notice                    ifdef(`LOGHOST', /var/log/authlog, @loghost)
 
mail.debug                      ifdef(`LOGHOST', /var/log/syslog, @loghost)
 
#
# non-loghost machines will use the following lines to cause "user"
# log messages to be logged locally.
#
ifdef(`LOGHOST', ,
user.err                                        /dev/sysmsg
user.err                                        /var/adm/messages
user.alert                                      `root, operator'
user.emerg                                      *
)
# FJSVmadm : This is setting of the Machine Administration.
# FJSVmadm : Don't delete the following lines.
# FJSVmadm : Because the message cannot be observed.
*.err;kern.debug;daemon.notice          /var/opt/FJSVmadm/evh/evh_pipe
#*.err;kern.debug;auth.notice           /var/opt/FJSVragt/fifo/slg
0
 
malibusaAuthor Commented:
this is from /var/adm/messages

Jun 12 10:05:42 lxserver named[22613]: [ID 873579 daemon.notice] stopping command channel on 127.0.0.1#953
Jun 12 10:05:43 lxserver named[22613]: [ID 873579 daemon.notice] exiting
Jun 12 10:05:48 lxserver named[23648]: [ID 873579 daemon.notice] starting BIND 9.2.3 -u named -t /var/named
Jun 12 10:05:48 lxserver named[23648]: [ID 873579 daemon.notice] command channel listening on 127.0.0.1#953
Jun 12 13:05:48 lxserver ufs: [ID 845546 kern.notice] NOTICE: alloc: /var: file system full
Jun 12 10:05:48 lxserver named[23648]: [ID 873579 daemon.crit] fflush() to pid file '/var/run/named.pid' failed
Jun 12 10:05:48 lxserver named[23648]: [ID 873579 daemon.crit] exiting (due to early fatal error)
Jun 12 10:06:44 lxserver named[23654]: [ID 873579 daemon.notice] starting BIND 9.2.3 -u root -t /var/named
Jun 12 10:06:44 lxserver named[23654]: [ID 873579 daemon.notice] command channel listening on 127.0.0.1#953

i think its because of the space,
here is the space figure

/dev/dsk/c0t0d0s5    5164482 5143550       0   100%    /var

so /var directory is full Right?
okay, how to know which file is taking the space?

0
 
pablouruguayCommented:
try to free the /var in the /var/spool/mail maybe you have a big mailboxes
or in /var/tmp
 
check that and your bind start to work again ;)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.