Solved

ASP.NET Debug

Posted on 2006-06-11
6
431 Views
Last Modified: 2013-11-25
Hi experts:

Brief info:
1. ASP.NET Web project is on a remote server (with company LAN).
2. I am using Visual Studio.NET for devp

Problem:
When running project in debug mode, get following erroe:
Unable to start debugging on the web server. The project is not configured to be debugged.

Thank you in advance.
0
Comment
Question by:ourselves
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 12

Accepted Solution

by:
UnexplainedWays earned 64 total points
ID: 16882769
My guess is the web.config file.  When i first uploaded it to my server it told me about that error.

Might be something to do with <customErrors mode="Off"/>

And you might want to take a look @ this thread
http://www.experts-exchange.com/Programming/Programming_Languages/Dot_Net/ASP_DOT_NET/Q_21882539.html
They are kind of having the same issue, it's not solved yet but it might be before yours.
0
 
LVL 2

Assisted Solution

by:rraghvendra
rraghvendra earned 62 total points
ID: 16883288
Do following :
 1. Set customErrors mode="On" or "RemoteOnly"
 2. If u get any access deny then  add the appropriate user to the Debugger Users group, follow these steps on the Web server:

To add the appropriate user to the Debugger Users group, follow these steps on the Web server: 1. From the Windows Start menu, point to Programs, point to Administrative Tools, and then click Computer Management.
2. In the left pane, click to expand the Computer Management, System Tools, and Local Users and Groups nodes.
3. Click Groups, and then double-click Debugger Users.
4. In the Debugger Users Properties dialog box, click Add.  
5. In the Select Users or Groups dialog box, select the appropriate user, and then click OK.
6. Click OK to exit the Debugger Users Properties dialog box.
7. Close the Computer Management explorer.
0
 
LVL 4

Assisted Solution

by:indu_mk
indu_mk earned 62 total points
ID: 16883847
0
 
LVL 15

Assisted Solution

by:SnowFlake
SnowFlake earned 62 total points
ID: 16884737
to enable debugging you should have:

<configuration>
  <system.web>
     <compilation debug="true">

in your web config.

the customErrors only controls what is displayed when you have a server side error.

SnowFlake
0

Featured Post

Don't Cry: How Liquid Web is Ensuring Security

WannaCry is just the start. Read how Liquid Web is protecting itself and its customers against new threats.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
When it comes to security, close monitoring is a must. According to WhiteHat Security annual report, a substantial number of all web applications are vulnerable always. Monitis offers a new product - fully-featured Website security monitoring and pr…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question