Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Error Connecting to SAP R/3 from VB

Posted on 2006-06-12
4
584 Views
Last Modified: 2013-12-08
Hi,

I have a small VB application that connects to SAP R/3 and downloads information from the tables.
Im trying to connect to SAP GUI from VB but i get an error evrytime in doing so.~Tried using the application on my colleagues PC and it works but it doesnt work for me.

Hope you guys can help me with this as its been a whole week now and its a pain in arse.Tried Reinstalling SAP GUI as well but no use.
The version for sap GUI im using is 6.20.

Cheers
0
Comment
Question by:ammartahir1978
  • 2
4 Comments
 
LVL 5

Accepted Solution

by:
cryptosid earned 300 total points
ID: 16892064
0
 
LVL 3

Assisted Solution

by:Marcnus
Marcnus earned 200 total points
ID: 16898710
Hello,

I have had similiar problem and it was related with mapping sap ports into OS. It could be depends
on operation system you use. In MSWindows there are records in "services" file (path C:\WINDOWS\system32\drivers\etc) like:
sapdp00          3200/tcp
sapdp01          3201/tcp
sapdp02          3202/tcp
sapdp03          3203/tcp
....
Check if above is in your system. Disable all firewalls, anti virus and other security stuff on host.
Second thing is depending on communication you use. In rfc model you should have registered
program in SAP (SM59 and help.sap.come will be helpful) and that program assigned in your VB
app with SAP. If problem will stil persist please describe it much detailed eg. SAP configuration,
users and authorization, code you've written, I'll try to solve it.

Regards,
mw
0
 
LVL 5

Expert Comment

by:cryptosid
ID: 16900927
Hi,

Sorry i misread the question... can you post the error message.

Regards,
cryptosid
0
 

Author Comment

by:ammartahir1978
ID: 16901853
Hi guys thnx for your help but i got it sorted out.The problem was with the saplogon.ini file.
Cheers,
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Salesforce.com is a cloud-based customer relationship management (CRM) system. In this article, you will learn how to add and map custom lead and contact fields to your Salesforce instance.
Get to know the ins and outs of building a web-based ERP system for your enterprise. Development timeline, technology, and costs outlined.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question