Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How do I get DHCP-SERVER running for Cisco AS5300 Dialup clients ?

Posted on 2006-06-12
4
Medium Priority
?
1,095 Views
Last Modified: 2012-06-21
Dear Expert,

I am in charge of configuring a Cisco AS5300 for Dialup Internet Connectivity.
I am no expert in this, and my company has given me this project to set up.

So here it goes:

We have two E1s connected to the AS5300, and right after the AS5300 is the internet.
We have a radius server on our network that authenticates the dialup users.

Now my problem is the cisco dhcp-server. The cisco dhcp server does not attribute
the ip addresses I have configured the router for. I know there is a configuration
problem on my side I just don't know where. I copied the debug messages below
for reference.

In the cisco configuration, don't look at the "ip local pool" reference, I tried the connection
with async-bootp and ip attribution if fine but no gateway over ppp with async-bootp, so I
cannot use bootp. I ABSOLUTELY NEED TO USE DHCP-SERVER. PLEASE HELP ME.


--Snip Cisco--

nas_test#sh run
1w5d: %SYS-5-CONFIG_I: Configured from console by admin-local on vty0 (213.xxx.172.28)
Building configuration...

Current configuration : 3614 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname nas_test
!
logging console errors
aaa new-model
aaa authentication ppp ppp_auth_mth group radius
aaa authentication ppp ppp_auth_mth_local local
aaa authentication ppp free none
aaa authentication ppp test group radius
enable password 7 xxxxxxxxxxxxxxxxxxxxx
!
username testnbayle password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxx
username admin-local password 7 xxxxxxxxxxxxxxxxxxxxxxxxxx
spe 1/0 2/9
 firmware location flash:mica-modem-pw.2.7.2.2.bin
!
!
resource-pool disable
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
ip name-server 213.xxx.172.1
ip name-server 213.xxx.20.3
!
ip dhcp pool forfait_dhcp_pool
   network 213.xxx.175.0 255.255.255.224
   dns-server 213.xxx.172.1 213.xxx.20.3
   default-router 213.xxx.175.62
   lease infinite
!
ip dhcp pool free_dhcp_pool
   network 213.xxx.175.32 255.255.255.224
   dns-server 213.xxx.172.1 213.xxx.20.3
   default-router 213.xxx.175.62
!
ip dhcp-server 213.188.175.62
isdn switch-type primary-net5
mta receive maximum-recipients 0
!
controller E1 0
 clock source line primary
!
controller E1 1
 clock source line secondary 1
!
controller E1 2
 clock source line secondary 2
!
controller E1 3
 clock source line secondary 3
!
controller E1 4
 clock source line secondary 4
!
controller E1 5
 clock source line secondary 5
!
controller E1 6
 framing NO-CRC4
 clock source line secondary 7
 pri-group timeslots 1-31
!
controller E1 7
 framing NO-CRC4
 clock source line secondary 7
 pri-group timeslots 1-31
!
!
!
!
!
interface Loopback0
 ip address 213.xxx.175.62 255.255.255.224
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial1
 no ip address
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial2
 no ip address
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial3
 no ip address
 shutdown
 no fair-queue
 clockrate 2015232
!        
interface Serial6:15
 description Interface pour les free : vers 08605726xx
 no ip address
 encapsulation ppp
 isdn switch-type primary-net5
 isdn incoming-voice modem
!
interface Serial7:15
 description Interface pour les forfaits : vers 08685726xx
 no ip address
 encapsulation ppp
 isdn switch-type primary-net5
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 213.xxx.160.33 255.255.255.224
 duplex auto
 speed auto
!
interface Group-Async6
 description Interface pour les free : vers 08605726xx
 ip unnumbered Loopback0
 encapsulation ppp
 no ip mroute-cache
 async mode dedicated
 peer default ip address pool free_dhcp_pool
 ppp authentication chap ppp_auth_mth
 group-range 181 210
!
interface Group-Async7
 description Interface pour les forfaits : vers 08685726xx
 ip unnumbered Loopback0
 encapsulation ppp
 no ip mroute-cache
 async mode dedicated
 peer default ip address pool forfait_dhcp_pool
 ppp authentication chap ppp_auth_mth
 group-range 211 240
!
ip local pool pool_client_forfait 213.xxx.175.33 213.xxx.175.61
ip local pool pool_client_free 213.xxx.175.1 213.xxx.175.30
ip classless
ip route 0.0.0.0 0.0.0.0 213.xxx.160.62
no ip http server
!
snmp-server community public RO
!
radius-server host 213.xxx.172.7 auth-port 1645 acct-port 1646 non-standard
radius-server retransmit 3
radius-server attribute 44 include-in-access-req
radius-server key bijorvinson!
!
line con 0
line 1 180
line 181 210
 no exec  
 no flush-at-activation
 modem Dialin
 rotary 6
 autohangup
line 211 240
 no exec
 no flush-at-activation
 modem Dialin
 rotary 7
 autohangup
line aux 0
line vty 0 4
!
end

--End Cisco Conf--

-- Debug of a Dial up connection --
1w5d: %ISDN-6-CONNECT: Interface Serial6:26 is now connected to 590571015
1w5d: %LINK-3-UPDOWN: Interface Async191, changed state to up
1w5d: AAA/MEMORY: create_user (0x62206088) user='msvtest1@forfait' ruser='' port='Async191' rem_addr='590571015/0860572624' authen_type=CHAP service=PPP priv=1
1w5d: RADIUS: ustruct sharecount=1
1w5d: RADIUS: Initial Transmit Async191 id 64 213.xxx.172.7:1645, Access-Request, len 120
1w5d:         Attribute 4 6 D5BCAF3E
1w5d:         Attribute 5 6 000000BF
1w5d:         Attribute 61 6 00000000
1w5d:         Attribute 1 18 6D737674
1w5d:         Attribute 30 12 30383630
1w5d:         Attribute 31 11 35393035
1w5d:         Attribute 3 19 02FF49C8
1w5d:         Attribute 6 6 00000002
1w5d:         Attribute 7 6 00000001
1w5d:         Attribute 44 10 30303030
1w5d: RADIUS: Received from id 64 213.xxx.172.7:1645, Access-Accept, len 20
1w5d: As191 AAA/DISC: 1/"User Request"
1w5d: As191 AAA/DISC/EXT: 1020/"User Request"
1w5d: DHCP: look up prim DNS for As191 from any any ret: fail
1w5d: DHCP: look up prim NBNS for As191 from any any ret: fail
1w5d: DHCP: look up sec DNS for As191 from any any ret: fail
1w5d: DHCP: look up sec NBNS for As191 from any any ret: fail
1w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async191, changed state to up
1w5d: %ISDN-6-DISCONNECT: Interface Serial6:26  disconnected from 590571015 , call lasted 27 seconds
1w5d: Async191 AAA/DISC: 2/"Lost Carrier"
1w5d: Async191 AAA/DISC/EXT: 1011/"Lost Carrier"
1w5d: Async191 AAA/DISC: 2/"Lost Carrier"
1w5d: Async191 AAA/DISC/EXT: 1011/"Lost Carrier"
1w5d: %LINK-5-CHANGED: Interface Async191, changed state to reset
1w5d: Async191 AAA/DISC: 2/"Lost Carrier"
1w5d: Async191 AAA/DISC/EXT: 1011/"Lost Carrier"
1w5d: Async191 AAA/DISC: 2/"Lost Carrier"
1w5d: Async191 AAA/DISC/EXT: 1011/"Lost Carrier"
1w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async191, changed state to down
1w5d: AAA/MEMORY: free_user (0x62206088) user='msvtest1@forfait' ruser='' port='Async191' rem_addr='590571015/08605726xx' authen_type=CHAP service=PPP priv=1
1w5d: %LINK-3-UPDOWN: Interface Async191, changed state to down
1w5d: As191 AAA/DISC: 2/"Lost Carrier"
1w5d: As191 AAA/DISC/EXT: 1011/"Lost Carrier"
1w5d: As191 AAA/DISC: 2/"Lost Carrier"
1w5d: As191 AAA/DISC/EXT: 1011/"Lost Carrier"
-- Snip--
0
Comment
Question by:umoorjani
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 16889668
Try this:

interface Group-Async6
 no peer default ip address pool free_dhcp_pool
 peer default ip address dhcp
 ip unnumbered Loopback0

//--Use two different loopbacks
 
interface Loopback0
   ip address 213.xxx.175.1 255.255.255.224
 interface Loopback1
   ip address 213.xxx.175.33 255.255.255.224

interface Group-Async7
 ip unnumbered Loopback1
 peer default ip address dhcp


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16901525
Hello..... any comments?
0
 

Author Comment

by:umoorjani
ID: 16902816
I'm sorry, I was caught up with another issue @ the same time. I'm going test the propositions above right now,
I will let you know. Sorry for the delay.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question