Solved

SCO Openserver wont allow Telnet from public IP's?

Posted on 2006-06-12
4
569 Views
Last Modified: 2013-12-27
Guys,
Ive got a SCO openserver (3.2) that will allow access by telnet to anyone on the LAN but when I forward in telnet (temporary) from the firewall it rejects the connection attempts.  From the client it just times out. I presume the previous admin had this blocked for good reason, however we need to change it temporarily.  any help would be greatly appreciated. I am much more a windows admin then unix.
0
Comment
Question by:Poudrecomputer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 6

Expert Comment

by:dotENG
ID: 17040478
This is the OS/2 channel, you should post your question in:
http://www.experts-exchange.com/Operating_Systems/Unix/

Anyway, this looks like a firewall/routing/netmask problem.
Try running "netstat –rn" to get your network configuration.
0
 

Author Comment

by:Poudrecomputer
ID: 17043700
dotENG,
Yah i noticed i somehow posted to the wrong spot.. anyways... heres the results from hyperterm
---------------------------------------
netstat -rn
Routing tables
Destination           Gateway             Flags    Refs        Use      Interface
127.0.0.1             127.0.0.1             UH          3      262382        lo0
192.168               192.168.0.100      UC          1        0              net0
192.168.0.100      127.0.0.1            UGHS      163      833           lo0
224                     192.168.0.100      UCS         0        0              net0
root#
---------------------------------------

I appreciate any help! : )
0
 
LVL 6

Accepted Solution

by:
dotENG earned 500 total points
ID: 17046114
Most likely your netmask is incorrect, to be sure do a "cat /etc/tcp" and check for something that looks like NETMASK=255.255.0.0
If so, edit the /etc/tcp file to NETMASK=255.255.255.0 and add GATEWAY=IP_ADDRESS_OF_FIREWALL.

All this is correct if your network uses Class C netmask (254 addresses from 192.168.0.1 to 192.168.0.254), if your network uses Class B netmask (65534 addresses from 192.168.0.1 to 192.168.255.254) then don't change the mask.

I don't know if it's possible to restart networking in SCO like Linux (/etc/init.d/network restart), so if it's possible, restart the server.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Windows 10 is here and for most admins this means frustration and challenges getting that first working Windows 10 image. As in my previous sysprep articles, I've put together a simple help guide to get you through this process. The aim is to achiev…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question