Solved

Ftp permissions using vsftpd on FC4

Posted on 2006-06-12
16
2,954 Views
Last Modified: 2013-11-13
The permissions for a number of files ftped into our FC4 server are rwx------.   I know it is dangerous, but I want all files created by ftp to have read, write, execute.  I have changed local_umask=777 in /etc/vsftpd/vsftpd.conf and "service restart vsftpd".  But, I'm not getting files created with full permissions.  Any ideas?
0
Comment
Question by:shannon_adams
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 3
16 Comments
 
LVL 16

Expert Comment

by:xDamox
ID: 16892681
Hi,

Redhat remove the ability to have execute in the fire permissions for security reasons, rwx is no longer acceptable.
0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 16920121
try "local_umask=000" - umask is meant to subtract (i.e. remove) permission bits set, not to add the bits.
0
 
LVL 16

Expert Comment

by:xDamox
ID: 16920273
DonConsolio, You cant have a umask of rwx execute has been removed for security pursoses
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 15

Expert Comment

by:DonConsolio
ID: 16920807
for me (vsFTPd 2.0.3 on SUSE) this works:
-----------------------
local_umask=000
file_open_mode=0777
------------------------

Redhat may be different :-)
0
 
LVL 16

Expert Comment

by:xDamox
ID: 16920956
DonConsolio, you are able to get rwx on SuSE?
0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 16921298
"-rwxrwx---"  is what i got with local_umask=007 and file_open_mode=0777

SUSE 10.0 , vsftpd-2.0.3-6
0
 
LVL 16

Expert Comment

by:xDamox
ID: 16921437
Ok, thanks I didn't know SuSE allowed you to do this
0
 

Author Comment

by:shannon_adams
ID: 16921635
DonConsolio, I added the two lines to the /etc/vsftpd/vsftpd.conf file and restarted the service.  However I am getting -rw-rw-r-- when ftping files to the server.  I am almost positive I am running vsftp as the ftp server, but how can I be sure?
0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 16921749
$  telnet 127.0.0.1 ftp
and read the banner

or

rpm -qa | grep -i ftp

0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 16921758
type "quit<enter>" to leave the telnet session
0
 

Author Comment

by:shannon_adams
ID: 16921762
Here is what I see with the rpm command:
lftp-3.2.1-10_FC4  
ncftp-3.1.9-4.fc4  
ftp-0.17-26        
vsftpd-2.0.3-1    

Now, how can I tell which one is being used for ftp transfers?
0
 

Author Comment

by:shannon_adams
ID: 16921773
Okay, tried the telnet:
Connected to webserver (127.0.0.1).
Escape character is '^]'.          
220 (vsFTPd 2.0.3)                  
0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 16921802
> vsftpd-2.0.3-1    

> 220 (vsFTPd 2.0.3)                  


so you have vsftpd 2.0.3
0
 
LVL 15

Expert Comment

by:DonConsolio
ID: 16921898
do your SOURCE files havd 777 mode ?
0
 
LVL 15

Accepted Solution

by:
DonConsolio earned 250 total points
ID: 16922021
You might also want to check your SELinux settings

"Desktop" > "System Settings" > "Security Level"  >  "FTP" > "SELinux"
0
 
LVL 16

Expert Comment

by:xDamox
ID: 16924504
Fedora does not allow rwx files.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question