Solved

RPC over HTTP

Posted on 2006-06-13
7
406 Views
Last Modified: 2010-03-06
I am attempting to connect outside users to the exchange server using RCP over HTTP.  I can get it to work inside the office but not from the outside.  I checked the connection status in outlook at it was tcp/ip and I know that is not right.  Everything seems to be right according to the instructions I have found on microsoft.  I read on here that if an ssl cert popped up it would stop outlook in its tracks.  I turned off ssl for RPC and can now connect through http://server.domain.com/rpc with out the cert popping up.  Any help would be appreciated.
0
Comment
Question by:FedEquipAdmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 13

Accepted Solution

by:
eatmeimadanish earned 63 total points
ID: 16894807
http://www.msexchange.org/tutorials/Outlook_2003_Connect_Exchange_2003.html

and more links in case you need additional help;
http://www.msexchange.org/pages/search.asp?query=rpc+over+http

Check half way down, they have some articles about trouble shooting.

Most of the time the issue comes from not porting 443 correctly, or the internal servername was used and not the MX name of the mailserver.  Remember, when you are outside the domain, the servers are the MX DNS record, not the local one.
0
 
LVL 8

Expert Comment

by:Jejin Joseph
ID: 16895271
You should be able to access OWA from outside on the same URL for RPC/HTTP withought any prompts on SSL. Can you connect using RPC/HTTP from inside the network ? If yes then its go to do with your firewall configuration and port and IP mappings.
0
 

Author Comment

by:FedEquipAdmin
ID: 16896227
It connects inside the network but only through tcp/ip.
0
 
LVL 13

Expert Comment

by:eatmeimadanish
ID: 16896379
Then you have it setup wrong.  It must be using DNS to connect.
0
 
LVL 104

Assisted Solution

by:Sembee
Sembee earned 62 total points
ID: 16898161
If it is connecting inside on TCP/IP then it isn't working correctly. You cannot easily use the feature without SSL. It doesn't matter whether you remove or disable the requirement for SSL on the /rpc virtual directory it will still not work correctly.

Most of the problems with this feature are down to name resolution, certificate or registry settings.

Simon.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses
Course of the Month4 days, 11 hours left to enroll

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question