Exchange 2003 Setting up Smart Hosts for Mail Marshal

Hi All,

We have an exchange server 2003 running.  Im trying to setup Mail Marshal using Smart Hosts.  I have configured a separate machine running Mail Marshal and have configured the Exchange Server to forward messages to this Mail Marshal machine.    Mail Marshal is working for outgoing emails only, and when I check the incomming messages this is always 0.  

Within Exchange System Manager i've gone to, Servers\(servername)\Protocols\SMTP\Defualt SMTP Virtual Server and have typed in the name of the sever (Mail-Marshal).  This works fine for outgoing email and I can see the traffic through Mail Marshal Console.

Also I've gone to Exchange System Manager, \Connectors\Internet Mail SMTP Connector and selected "Forward all mail through this connector to the following smart host:) and put in the server name, but this does not seem to make any difference?)

Any ideas where im going wrong, which is stopping Mail-Marshal to recieving incoming email?

Many Thanks,


Martin
LVL 1
wayfarer1210Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
SembeeConnect With a Mentor Commented:
What are you expecting to happen?
All email, even internal to go via the Mail Marshall system?
If so, that isn't going to happen as Exchange doesn't support that in this version.

If you are expecting just outbound email going to external addresses to go to through the Mail Marshal box, then it should work. What did you set as bridge heads? Does the name you put in as a smart host resolve correctly?

Simon.
0
 
SembeeCommented:
You don't need to make any changes to the SMTP virtual server. So whatever you have done there, undo.
To use a smart host, the only thing that you need to do is configure the SMTP Connector. By using an SMTP Connector you will avoid screwing up the SMTP server.

Next. When you enter the server in to the connector, make sure that it is the FQDN, so mailmarshal.domain.com (or whatever yours is called).

Do outbound messages from Exchange sit in the queues?
When you mention outbound messages on the Mail Marshal box, do you mean outbound as in messages that your users have sent that are going to the internet, or messages that have come in from the Internet and are going out to the Exchange server?

Simon.
0
 
wayfarer1210Author Commented:
Hi,

I have removed the settings from the SMTP Virtual Server, and have entered mail-marshal.wts.poole under the Internet Mail SMTP Connector.  This doesnt appear to forward any traffic to the mail marshal server.  When I had used the SMTP Virtual Server this allowed outbound messages which were sent by our users to the internet so that worked fine then (But only for ougoing messages to the internet).  But when applying mail-marshal.wts.poole on just the Internet Mail Connector i dont even get this?

Hope this answers all your queries

Many thanks,


Martin


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.