Solved

Sendmail to allow only cron and forwarded mail

Posted on 2006-06-13
28
1,295 Views
Last Modified: 2013-12-17
I have a set of Solaris machines running Sendmail 8.13.6, and I would like to configure them to allow only cron mail and the ability to forward incoming mail to a list of aliases pointing to other machines.  None of my Solaris machines will contain any e-mail themselves, so a minimum configuration is desired.  If sendmail itself isn't needed, that would be acceptable.  Thanks!
0
Comment
Question by:1248841
  • 13
  • 11
  • 2
  • +1
28 Comments
 
LVL 38

Expert Comment

by:yuzh
ID: 16899064
You can use aliases  to make all the users email account ponit to your mail
server. you can do it locally or use (NIS, NIS+), please read the following docs:
http://www.kempston.net/solaris/configsendmail2.html

and the following sendmail FAQ and tips:
http://www.sendmail.org/faq/
http://www.akadia.com/services/sendmail_tips.html
http://www.sendmail.org/~ca/email/setup1.html  
   
   EE has a sendmail TA, for sendmail question, it is better to post it in:
   http://www.experts-exchange.com/Networking/Email_Groupware/Sendmail/

0
 

Author Comment

by:1248841
ID: 16902160
How do I get this question moved to the sendmail TA?  I don't want to have to assign more points.

I had already seen the links provided.  I didn't see answers to my question in them.

I don't have any problem assigning aliases, but I would like these Suns to only forward mail *to* those destinations, if possible.  Maintaining the list myself is acceptable due to its small and relatively static state.  Also, does cron mail need a sendmail daemon running?

Thanks!
0
 
LVL 27

Expert Comment

by:Nopius
ID: 17006266
1248841, I recommend you to enable sendmail only on 127.0.0.1 address.
To do it, leave the only line for DaemonPortOptions in /etc/mail/sendmail.cf:
O DaemonPortOptions=Name=MTA-v4, Family=inet, Addr=127.0.0.1

and restart sendmail.

Now you are able to use 'aliases' and .forward files, but you accept only connections from localhost.
So your cron reports will go right way and no external user will able to use your SMTP server (except it has a login access to it).
0
 

Author Comment

by:1248841
ID: 17009303
This is just what I needed regarding the cron mail - thanks!

However, as you'd expect, the machine won't accept incoming messages - is there a way to still allow it to forward incoming mail only to valid addresses pointing to aliases on other machines?  It would be ideal if I could also have it stop repeatedly attempting to send incoming messages to invalid usernames.

Thanks!
0
 
LVL 27

Expert Comment

by:Nopius
ID: 17014426
> is there a way to still allow it to forward incoming mail only to valid addresses pointing to aliases on other machines?

So, you like to accept incoming mail (not from cron) and forward to the other hosts?
- in that case you still need to have sendmail listening on external port, and configure appropriate RELAY domain.

Or you like to forward mail, produced by cron daemon?
- in that case everything should work, since aliases and .forward files are processed in usual order. If they are pointing to correct uesrs, mail will be forwarded. If not, mail will be rejected (unless you have LUSER_RELAY feature).

Please provide an example of what do you want to get.
0
 

Author Comment

by:1248841
ID: 17017682
I would still like to accept incoming mail to a list of valid users, all of whom are forwarded to other mail hosts.

I would like for the configuration to ignore invalid usernames.

I would also like to stop the constant error messages similar to the following in syslog:

Jun 30 00:55:12 my_mail_server sendmail[16169]: [ID 801593 mail.info] k5U4DtpI016106: to=<allcommunity@0451.com>, delay=00:41:17, xdelay=00:03:33, mailer=esmtp, pri=302609, relay=mail.0451.com. [202.97.230.81], dsn=4.0.0, stat=Deferred: Connection timed out with mail.0451.com.

I don't know why these messages continue to involve my mail server.  It's as if I'm relaying to bogus addresses, but I thought I prevented that in my sendmail config.

I'm not sure if this is starting to count as more than one problem :)

Thanks!
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17089509
Hi

I think you might want to consider using the access db for controlling this.  At connect time sendmail can check against a db to decide if it wants to talk or not.  Rules are simple:

localhost RELAY
i-dont-like-you.com REJECT
you-just-sendm-me-spam REJECT

and so on.

Depending on your setup you might be using it already, but without any rules in place. check for something like

FEATURE(`access_db',`hash -o /etc/mail/access.db')dnl

in you sendmail.mc file (likely in /etc or /etc/mail) or "Kaccess ...." in the resulting sendmail.cf.

See

http://blue-labs.org/howto/access_hints.php

K

0
 

Author Comment

by:1248841
ID: 17138089
The reject list doesn't work for me.  I have the following:

# cat /etc/mail/access
...
Connect:195.225.218.139         REJECT "Unauthorized access"
# grep Kaccess /etc/mail/sendmail.cf
Kaccess dbm -T<TMPF> /etc/mail/access

But I continue to get connections from that IP:
# grep 195.225.218 /var/adm/messages | tail -3
Jul 19 08:56:12 smash sendmail[18022]: [ID 801593 mail.info] k6JBKkhs017874: to=<philip@pistonheads.biz>, delay=01:35:26, xdelay=00:03:29, mailer=esmtp, pri=597106, relay=pistonheads.biz. [195.225.218.139], dsn=4.0.0, stat=Deferred: Connection timed out with pistonheads.biz.
Jul 19 09:01:39 smash sendmail[18108]: [ID 801593 mail.info] k6JBKkhs017874: to=<philip@pistonheads.biz>, delay=01:40:53, xdelay=00:03:29, mailer=esmtp, pri=687106, relay=pistonheads.biz. [195.225.218.139], dsn=4.0.0, stat=Deferred: Connection timed out with pistonheads.biz.
Jul 19 09:16:39 smash sendmail[18153]: [ID 801593 mail.info] k6JBKkhs017874: to=<philip@pistonheads.biz>, delay=01:55:53, xdelay=00:03:29, mailer=esmtp, pri=777106, relay=pistonheads.biz. [195.225.218.139], dsn=4.0.0, stat=Deferred: Connection timed out with pistonheads.biz.

Thanks!
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17138490
Hi

If I read it correctly, the log entries say that your machine (smash) tried to connect to port 25 on 195.225.218.139 to deliver a mail to philip@pistonheads.biz and it failed due a connection timneout.  

The access file controls who can connect to _your_ machine on port 25, not to whom you might want to connect to deliver mail.

Sorry, I've lost track of what, and where, the outstanding problem or problems lie.

The log entries also don't say where that mail was originally generated.  This might help find out that:

grep k6JBKkhs017874 /var/adm/messages

or you might well know already yourself.

K



0
 

Author Comment

by:1248841
ID: 17139741
I guess the main problem (other than constant email coming in to non-existent addresses) is this:

- The messages we're discussing that I can't seem to control.  It does appear that my machine is attempting to connect to all these other machines but I don't know why or how to stop it.  There is very little use on my mail server, so I suspect someone out there is using my mail server to do this.  I don't see any other IP address involved.

The 'grep k6JBKkhs017874 /var/adm/messages ' command doesn't reveal anything different - however, a 'cat /var/spool/mqueue/qfk6JBKkhs017874 reveals:"

smash# cat /var/spool/mqueue/qfk6JBKkhs017874
V8
T1153308046
K1153322828
N17
P1497106
I0/0/389535
MDeferred: Connection timed out with pistonheads.biz.
Frs
$_localhost
$r
$slocalhost
${daemon_flags}
${if_addr}128.175.74.247
SMAILER-DAEMON
MDeferred: Connection timed out with pistonheads.biz.
rRFC822; philip@pistonheads.biz
RPF:<philip@pistonheads.biz>
H?P?Return-Path: <g>
H??Received: from localhost (localhost)
        by smash.cms.udel.edu (8.13.7/8.13.7) id k6JBKkhs017874;
        Wed, 19 Jul 2006 07:20:46 -0400 (EDT)
H?D?Date: Wed, 19 Jul 2006 07:20:46 -0400 (EDT)
H?F?From: Mail Delivery Subsystem <MAILER-DAEMON>
H?x?Full-Name: Mail Delivery Subsystem
H?M?Message-Id: <200607191120.k6JBKkhs017874@smash.cms.udel.edu>
H??To: <philip@pistonheads.biz>
H??MIME-Version: 1.0
H??Content-Type: multipart/report; report-type=delivery-status;
        boundary="k6JBKkhs017874.1153308046/smash.cms.udel.edu"
H??Subject: Returned mail: see transcript for details
H??Auto-Submitted: auto-generated (failure)
.
smash#
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17144458
Hi

When you write:

> It does appear that my machine is attempting to connect
> to all these other machines but I don't know why or how to stop it

I (with respect) think you ask the wrong question.  If you want to stop the specific connection attempts to 195.225.218.139 = pistonheads.biz just add

127.0.0.1 pistonheads.biz

to your /etc/hosts (confirming that the hosts file is used in /etc/nsswitch.conf) and it'll try to connect to that IP address instead!!

However, this misses the point.  The specific mail you quote is a mailer-daemon mail trying to tell pistonheads.biz something, highly likely that it has tried and failed to send a mail to a local user on your system (likely because that user does not exist).  But we/you should work out how that mail got into your system in the first place, it should never have been accepted.  For that it would be helpful to see the file

/var/spool/mqueue/dfk6JBKkhs017874

K
0
 

Author Comment

by:1248841
ID: 17146841
You're right - I would imagine that in this case I should block 65.10.216.151.  But, as you said, it should never have been accepted.   Is it a matter of not accepting mail to bad usernames on my server or something else?

Thanks!!!


# more /var/spool/mqueue/dfk6K05UO3019507
This is a MIME-encapsulated message

--k6K05UO3019507.1153353930/smash.cms.udel.edu

The original message was received at Wed, 19 Jul 2006 20:05:28 -0400 (EDT)
from adsl-10-216-151.mia.bellsouth.net [65.10.216.151]

   ----- The following addresses had permanent fatal errors -----
<ster@newark.cms.udel.edu>
    (reason: 550 5.1.1 <ster@newark.cms.udel.edu>... User unknown)

   ----- Transcript of session follows -----
... while talking to newark.cms.udel.edu.:
>>> DATA
<<< 550 5.1.1 <ster@newark.cms.udel.edu>... User unknown
550 5.1.1 <ster@newark.cms.udel.edu>... User unknown
<<< 503 5.0.0 Need RCPT (recipient)

--k6K05UO3019507.1153353930/smash.cms.udel.edu
Content-Type: message/delivery-status

Reporting-MTA: dns; smash.cms.udel.edu
Received-From-MTA: DNS; adsl-10-216-151.mia.bellsouth.net
Arrival-Date: Wed, 19 Jul 2006 20:05:28 -0400 (EDT)

Final-Recipient: RFC822; ster@newark.cms.udel.edu
Action: failed
Status: 5.1.1
Remote-MTA: DNS; newark.cms.udel.edu
Diagnostic-Code: SMTP; 550 5.1.1 <ster@newark.cms.udel.edu>... User unknown
Last-Attempt-Date: Wed, 19 Jul 2006 20:05:30 -0400 (EDT)

--k6K05UO3019507.1153353930/smash.cms.udel.edu
Content-Type: message/rfc822

Return-Path: <john@pistonheads.biz>
Received: from friend (adsl-10-216-151.mia.bellsouth.net [65.10.216.151])
        by smash.cms.udel.edu (8.13.7/8.13.7) with ESMTP id k6K05OO3019505
        for <ster@newark.cms.udel.edu>; Wed, 19 Jul 2006 20:05:28 -0400 (EDT)
Message-ID: <000001c6ab90$30436000$0100007f@Sabrinam>
From: "Philip" <john@pistonheads.biz>
To: <ster@newark.cms.udel.edu>
Subject: Any med for your girl to be happy!
Date: Wed, 19 Jul 2006 20:05:20 +0100
MIME-Version: 1.0
Content-Type: multipart/related;
        type="multipart/alternative";
        boundary="------------ms030005050709030507010006"
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180

This is a multi-part message in MIME format.
....
the uuencoded attachment...
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17146979
Hi

Yep, this is where you can use the access db, but you will need a complete list of valid addresses.

Basically you need to reject everything, and only accept for a finite and fixed set of addresses.  You can manage that list of course.

I just tried, I cannot relay to anybody@anywhere via sm@sh, but I can send to anything_i_want@newark.cms......
and your server looks like it will accept it.  Then realise it cant do anything with it, and bounce it again.  Bad news for you.

The access file should look like

To:user1@yourdomain RELAY
To:user2@yourdomain RELAY
To:user3@yourdomain RELAY
To:user4@yourdomain RELAY
....
To:*@yourdomain.edu    550 I am not allowed to accept mail for that user

after changing the /etc/mail/access file you likely need to

makemap hash /etc/mail/access.db < /etc/mail/access

Kevin
0
Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

 
LVL 2

Expert Comment

by:pitoren
ID: 17146990
Hi

A further thought - be very careful here.  spend plenty of time making sure your list is full and complete before implementing it.

;-/

K
0
 

Author Comment

by:1248841
ID: 17148170
# cat /etc/mail/access.db
To:goodusername1@newark.cms.udel.edu RELAY
To:goodusername2@newark.cms.udel.edu RELAY
To:*@newark.cms.udel.edu        550 I am not allowed to accept mail for that user
#

Then:
# makemap dbm /etc/mail/access < /etc/mail/access.db

...and restart sendmail

But e-mails to badusername@newark.cms.udel.edu (or usernamenotinaccessfile@n) still go through, or attempt to.

E-mails to newark.cms are processed by smash, but I have the same access table on smash.

I think we're very close, however.

0
 
LVL 2

Expert Comment

by:pitoren
ID: 17152357
Hi

Sadly, I am not sure we are that close!

This means there is some other rule that is allowing anybody@m...

Is smash part of any kind of domain (NIS, NIS+, ....)

Does smash do any local delivery at all?

Did you use a .mc file to generate your sendmail.cf, if so can you post it?

If not, and you have used the default, vendor supplied sendmail config file, which distro/OS are you using and what, if any, changes have you made ?

What is fully-qualified domain name for smash?

Basically we now need to use sendmail debugging flags to find out how it handles mails.  This is where it gets complicated.

K
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17152690
Hi

Sorry, I got the syntax wrong for the access file.  Plus you need to check you also have the blacklist_recipients feature enabled in your sendmail.cf.

Easiest way to do that is

egrep 'access_db.m4|blacklist_recipient.m4' /etc/mail/sendmail.cf

You should see 2 comments lines, one for each feature.  If not you have to go back to the .mc file and regenrate a new cf file after adding the blacklist_recipient feature to the mc file.

Next change your access file to be something like

user1@yourdomain RELAY
user2@yourdomain RELAY
user3@yourdomain RELAY
....
yourdomain.edu    550 I am not allowed to accept mail for that user

Again be wary, the last line means reject everything to that domain that is not specifically allowed by a rule above it.

Then

makemap hash /etc/mail/access.db < /etc/mail/access

You can test by

mconnect localhost

and then issusing these commands

mail from: me
rcpt to: user1@yourdomain
< should say Recipient OK >
rcpt to: baduser@yourdomain
rset
quit

The mail to the baduser should get the 550 message you setup above.

K
0
 

Author Comment

by:1248841
ID: 17153457
> Is smash part of any kind of domain (NIS, NIS+, ....)

smash and newark are both part of the same NIS+ domain.  When the bad e-mails go to newark, they show up on smash's /var/spool/mqueue and write to smash's messages file.

> Does smash do any local delivery at all?

Yes

> Did you use a .mc file to generate your sendmail.cf, if so can you post it?

Yes, here it is:

divert(0)dnl
VERSIONID(`$Id: generic-solaris.mc,v 8.13 2001/06/27 21:46:30 gshapiro Exp $')
OSTYPE(solaris2)dnl
DOMAIN(generic)dnl
FEATURE(`access_db', `dbm -T<TMPF> /etc/mail/access')
FEATURE(`blacklist_recipients')
define(`LUSER_RELAY', `local:unknown')dnl
define(`confBAD_RCPT_THROTTLE',`1')dnl
dnl Add support for the mailertable
FEATURE(`mailertable', `dbm -o /etc/mail/mailertable')
FEATURE(`use_cw_file')
MASQUERADE_AS(`mail.cms.udel.edu')
MAILER(local)dnl
MAILER(smtp)dnl

I'm using Berkeley sendmail 8.13.7.  smash is at Solaris 9, newark at Solaris 10.

> What is fully-qualified domain name for smash?

smash.cms.udel.edu

> egrep 'access_db.m4|blacklist_recipient.m4' /etc/mail/sendmail.cf

> You should see 2 comments lines, one for each feature

I don't, and I'm not sure why:

smash# sh Build sendmail.cf
Using M4=/usr/ccs/bin/m4
rm -f sendmail.cf
/usr/ccs/bin/m4 ../m4/cf.m4 sendmail.mc > sendmail.cf || ( rm -f sendmail.cf && exit 1 )
echo "### sendmail.mc ###" >>sendmail.cf
sed -e 's/^/# /' sendmail.mc >>sendmail.cf
chmod 444 sendmail.cf

smash# egrep 'access_db.m4|blacklist_recipient.m4' /etc/mail/sendmail.cf
#####  $Id: access_db.m4,v 8.26 2004/06/24 18:10:02 ca Exp $  #####
smash#

Thanks!!!
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17153528
Just typo (missing s) on my part, try

egrep 'access_db.m4|blacklist_recipients.m4' /etc/mail/sendmail.cf

should show 2 lines.

I think you have all you need, try creating the access file as I posted in my second update.

But I am concerned about these options:

define(`LUSER_RELAY', `local:unknown')dnl
define(`confBAD_RCPT_THROTTLE',`1')dnl

section, as I dont know precisely what they do so they might interfere with the access file control mechanism.  I will try out on a test system.

K
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17153574
Hi

Aha,

define(`LUSER_RELAY', `local:unknown')dnl

is explained at

http://open.itworld.com/5040/nls_unixtossingemail050921/page_1.html

Does not look like it buys you much, the access control mechanism seems better to me.  Do you know why it is there?

K


0
 

Author Comment

by:1248841
ID: 17153621
It was probably put there way back when in attempt to fix this problem - should I remve it?
Thanks!
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17153671
Hi

I doubt it does any harm, but curiously it does not seem to have worked. Which is strange.

Leave it for now.  But does the access coontrol via the /etc/mail/access file now work as desired?

-->
Next change your access file to be something like

user1@yourdomain RELAY
user2@yourdomain RELAY
user3@yourdomain RELAY
....
yourdomain.edu    550 I am not allowed to accept mail for that user

Again be wary, the last line means reject everything to that domain that is not specifically allowed by a rule above it.

Then

makemap hash /etc/mail/access.db < /etc/mail/access

You can test by

mconnect localhost

and then issusing these commands

mail from: me
rcpt to: user1@yourdomain
< should say Recipient OK >
rcpt to: baduser@yourdomain
rset
quit

The mail to the baduser should get the 550 message you setup above.
-->

K
0
 

Author Comment

by:1248841
ID: 17154194
So far it's not working, as you see below (ster@newark is not valid).  A few questions:

1) Which of this should be on smash, and which part on newark?  So far it's all on smash.  But the problem appears to be newark.
2) Is the bottom part of my access file ok?
3) When I "load" my access file, I do:
smash# cd /etc/mail
smash# makemap dbm /etc/mail/access < /etc/mail/access
- incorrect?


Thanks!


smash# tail -3 /etc/mail/access
To:gooduname1@newark.cms.udel.edu RELAY
To:gooduname2@newark.cms.udel.edu RELAY
To:*@newark.cms.udel.edu        550 I am not allowed to accept mail for that user
smash#

smash# mconnect localhost
connecting to host localhost (127.0.0.1), port 25
connection open
220 smash.cms.udel.edu ESMTP Sendmail 8.13.7/8.13.7; Fri, 21 Jul 2006 10:19:39 -0400 (EDT)
Mail from: rokosz@udel.edu
250 2.1.0 rokosz@udel.edu... Sender ok
Rcpt to: ster@smash.cms.udel.edu
550 5.1.1 ster@smash.cms.udel.edu... User unknown
Rcpt to: ster@newark.cms.udel.edu
250 2.1.5 ster@newark.cms.udel.edu... Recipient ok
rset
250 2.0.0 Reset state
quit
221 2.0.0 smash.cms.udel.edu closing connection
smash#
0
 
LVL 2

Expert Comment

by:pitoren
ID: 17154307
Hi

Yes, but the access file syntax is wrong - access file does not allow wildcards like "*" and the "To:" is not required.  This was my mistake originally, but I corrected it a few posts ago.

Your access file _should_ look like

# tail -3 /etc/mail/access
gooduname1@newark.cms.udel.edu RELAY
gooduname2@newark.cms.udel.edu RELAY
newark.cms.udel.edu        550 I am not allowed to accept mail for that user
#

K


0
 
LVL 2

Expert Comment

by:pitoren
ID: 17154524
Hi

I think you need to read carefully, some subtle errors are being introduced.

I also checked, and the other setting does interfere.  Thus you should get rid of the config

----->
define(`LUSER_RELAY', `local:unknown')dnl
----->

from teh mc file and regenerate the sendmail.cf file

Fior me this cobination seems to do what you want

my mc file
-->
divert(0)dnl
VERSIONID(`@(#)sendmail.mc      1.11 (Sun) 06/21/04')
OSTYPE(`solaris8')dnl
DOMAIN(`solaris-generic')dnl
FEATURE(`access_db',`dbm -T<TMPF> /etc/mail/access.db')dnl
FEATURE(`blacklist_recipients')dnl
define(`confFALLBACK_SMARTHOST', `mailhost$?m.$m$.')dnl
MAILER(`local')dnl
MAILER(`smtp')dnl
-->

(you need to add your masquerading bits, mine is a 2 line edit from the supplied one with solaris 10)

my /etc/mail/access file
-->
jon@test1.int           RELAY
test1.int                550 Go away
bob@test2.int    RELAY
test2.int         550 Go away
-->

I generate the dbm files via

makemap dbm /etc/mail/access.db < /etc/mail/access

NB: Check that your access file is the correct format, hash or dbm, and that you are generating the right files consistent with the setting in sendmail.mc and sendmail.cf.  I have it set that

** /etc/mail/access is the (text) access file that I edit with vi/emacs/...

** /etc/mail/access.db.dir
      and
** /etc/mail/access.db.page

 are the dbm files that are generated by makemap command

Note that,  non-intuitively, the filename listed in the (my) sendmail configuration file  (/etc/mail/access.db) does not actually exist, it's merely the root/base of the 2 dbm files (.dir and .pag)

With this config I get

# mconnect localhost
connecting to host localhost (127.0.0.1), port 25
connection open
220 peach..... ESMTP Sendmail 8.13.6+Sun/8.13.6; Fri, 21 Jul 2006 16:58:24 +0200 (CEST)
mail from: me
250 2.1.0 me... Sender ok
rcpt to: jon@test1.int
250 2.1.5 jon@test1.int... Recipient ok
rcpt to: jon@test2.int
550 5.0.0 jon@test2.int... Go away
rcpt to: bob@test1.int
550 5.0.0 bob@test1.int... Go away
rcpt to: bob@test2.int
250 2.1.5 bob@test2.int... Recipient ok
rset
250 2.0.0 Reset state
quit
221 2.0.0 peach.... closing connection
#

K
0
 

Author Comment

by:1248841
ID: 17154592
It's blocking some now.  I'll keep an eye on it and see how it goes.  I'll update soon.

Thanks!!!!
0
 
LVL 2

Accepted Solution

by:
pitoren earned 223 total points
ID: 17154846
2 new things I learned when looking into this

1) to debug relay rules

$ echo "check_mail jon@test1.int" | /usr/lib/sendmail -bt
..
Basic_check_mail returns: $# RELAY
check_mail       returns: $# RELAY
$

$ echo "check_mail jon@test2.int" | /usr/lib/sendmail -bt
...
Basic_check_mail returns: $# error $: 550 Go away
check_mail       returns: $# error $: 550 Go away

2) to debug alias expansion

$ /usr/lib/sendmail  -d60.5 -d27.2  -bv kevin
map_lookup(dequote, kevin, %0=kevin) => NOT FOUND (0)
map_lookup(dequote, kevin, %0=kevin) => NOT FOUND (0)
alias(kevin)
kevin (, kevin) aliased to kevin.lastname@myorg.int
map_lookup(host, myorg.int, %0=myorg.int) => myorg.int. (0)
self_reference(kevin.lastname@myorg.int)
        ... no self ref
kevin.lastname@myorg.int... deliverable: mailer esmtp, host myorg.int., user kevin.lastname@myorg.int

$ /usr/lib/sendmail  -d60.5 -d27.2  -bv badaddress
map_lookup(dequote, root, %0=root) => NOT FOUND (0)
map_lookup(dequote, badaddress, %0=badaddress) => NOT FOUND (0)
alias(badaddress)
badaddress... User unknown

signing off EE for weekend ...

K
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

This short article will present "How to import ICS Calendar onto Office 365 Calendar". I was searching for free (or not free) tools to convert ICS to CSV without success. The only tools I found & working well were online tools...this was too hard to…
MS outlook is a premier email client that enable you to send and receive the e-mails with various file formats of attachments such as document files, media file, and many others formats. There is some scenario occurs when a receiver of an e-mail mes…
Familiarize people with the process of utilizing SQL Server stored procedures from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Micr…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now