Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 996
  • Last Modified:

SBS 2003 exchange over HTTP

Hello again,

I am trying to configure exchange over http on sbs 2003.  I feel like I have tried everything but cannot get it to work.  Could ISA have anything to do with it?  I can't figure it out.  I am very frustrated.

Wes
0
hmcnasty
Asked:
hmcnasty
3 Solutions
 
technologyworksCommented:
0
 
aa230002Commented:
For RPC over HTTP, you should be running Windows Server 2003 on the following computers:-
1. All Exchange Server 2003 servers that Microsoft Office Outlook® 2003 clients will access using RPC over HTTP, such as mailbox servers and public folder servers.
 
2. All Exchange Server 2003 front-end servers that act as RPC proxy servers.
 
3. All global catalog servers that Outlook 2003 clients and Exchange Server 2003 servers (that are configured to use RPC over HTTP) use

I am not sure if you can use RPC over HTTP with Small Business Server.

Please hv a look at this article ->
System Requirements for RPC over HTTP on Exchange Server 2003
http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3RPCHTTPDep/91dc76e8-e60f-4f95-a32f-d4de63b263ac.mspx?mfr=true

Thanks,
Amit Aggarwal.
 
0
 
eatmeimadanishCommented:
You can use RPC over HTTP in SBS 2003.  In fact it is one of it's setup options.  SBS is one of the easier setups because of the autoinstaller.  
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
hmcnastyAuthor Commented:
In exchange manager under server properties what should the RPC -HTTP be set to.  mY only 2 choices are None and backend server. Middle one is grayed out.

0
 
hmcnastyAuthor Commented:
OK..here's where I get hung up.  I test the url https://mydomain.com/rpc and it works fine.  I get the log in box try it 3 times then I get the page that says:

You are not authorized to view this page. You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server.

HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource.

Internet Information Services (IIS)


Now the strange thing is that this is supposed to be what would be seen in a regular server 2003 environment not SBS 2003.  In SBS 2003 it should read:

The page cannot be displayed

HTTP Error 403.2 - Forbidden: Read access is denied.

Internet Information Services (IIS)

Anyway I assume that that part works.



Now when I test  http://mydomain.com/rpc/rpcproxy.dll I get this:

The page cannot be displayed  
Explanation: The Web server connection was closed.

--------------------------------------------------------------------------------

Try the following:

Refresh page: Search for the page again by clicking the Refresh button. The timeout may have occurred due to Internet congestion.
Check spelling: Check that you typed the Web page address correctly. The address may have been mistyped.
Access from a link: If there is a link to the page you are looking for, try accessing the page from that link.
Contact website: You may want to contact the website administrator to make sure the Web page still exists. You can do this by using the e-mail address or phone number listed on the website home page.

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Code 64: Host not available
Background: The connection to the Web server was lost.  



0
 
eatmeimadanishCommented:
Look at the tutorials on this site.

http://www.msexchange.org/pages/search.asp?query=rpc+over+http

There are two troubleshooting guides you will want to check out, plus a setup guide that walks through every step.  
0
 
hmcnastyAuthor Commented:
I'm still trying to work this out.   I went through the tutorial and I noticed a few things but I'm not sire how to fix them.

When I go to Exchange-HTTP tab in the exchage server properties what should it be set to?  As most of you know there are 3 settings.  

My front end (middle)  selection is grayed out. (should it grayed out?)
So it's either nothing or backend server which doesn't make sense to me.

Any ideas?

Wes
0
 
hmcnastyAuthor Commented:
Im gonna call MS .  I must have something pretty fouled up.  I've been through every inch of those tutorals.
Thank you for all of your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now