Serious - TCP/IP problems

Win XP Home

Can't connect to the internet.

When I ping 127.0.0.1 I get:  Unable to connect IP Driver, Error Code 2

I have deleted Winsock and Winsock2 and restarted, then reinstalled TCP/IP  from windows/inf - No help

I have run WinSockxpFix - No help

I have run netsh int ip reset resetlog.txt - I get an error that it could not obtain host information on the machine.  Some commands may not be available.  No such interface supported.

Any suggestions?
DKerfootAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
SunBowConnect With a Mentor Commented:
Rebuild from scratch, or close to it. You've got too much trashed in networking. You can try going back to a working configuration (<F8> on boot) and similar options; and you can try XP's repair process on the install CD. I am pessimistic on those, but where there's the time, which may be needed for backups, it is worth a shot.

You might have gotten files corrupted, so don't neglect to check_disk while you are at it. You do not mention it ever working. So my best guess is something went wrong in an install, so the solution is to reinstall, especially given all the miscellaneous fix attempts that may now have the machine left in an unknown state of repair. Boot the install CD, wipe the existing partition, add it back, then load it up enabling network services, and secure it as you go.
0
 
Rob WilliamsCommented:
Sounds like a bad network adapter or you need to completely uninstall and re-install the network adapter drivers. Is it a removable/PCI network adapter. I would uninstall the device in the hardware manager, and if you can physically remove the device do so, reboot twice then re-install. Make sure you have the latest drivers and that they are correct. If you cannot remove the NIC install the card in device manager and re-install with the new drivers. If it still fails try disabling the NIC and adding a new one.
0
 
Scotty_ciscoCommented:
Go into the hardware device manager and delete the Netcard and do a complete re-install of the card.  The Driver for the card is hosed up.

Thanks
Scott
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
DKerfootAuthor Commented:
I forgot to mention that the first thing I did was swap out the NIC.  I did also uninstall it and restart just to be sure.

Also, I can't even run ipconfig - I get an error:  Request is not supported.  Contact Microsoft support services.  Unable to query host name.  
0
 
jhanceCommented:
Try resetting your TCPIP protocol.

Open a CMD window and type:

NETSH INT IP RESET C:\RESETLOG.TXT

Then reboot your system and see if things work better.
0
 
prashsaxCommented:
Have your tried using WinsockFix.

http://www.softpedia.com/get/Tweak/Network-Tweak/WinSockFix.shtml

It fixes winsock related errors.
0
 
ianmal2Commented:
Can you supply some history?

What led up to this situation?

What did you change prior to the problem occurring?
0
 
SunBowCommented:
If you've some funds, get another disk drive, and XP professional, which will come with service packs so you won't have to look for as many upgrades to download. A possible is having a good box that goes bad when the malware gets into the machine while you are downloading the patches for them.
0
 
SunBowCommented:
> I get an error that it could not obtain host information on the machine.  

Make sure it has a name. Also run the set command to look for other odds and ends (variables defined). Do you even have a Path?

> Some commands may not be available.  No such interface supported.

Consider HW. It lloks like you are one who would have done it, but without being explicit, I have to suggest that you rid potential collisions, remove every piece of HW that you can and still be able to boot.

and: you do have to enable network services when you boot up. While that is normal default boot, maybe you are not doing that nay longer due to some other prior issue such as for handling of malware.
0
 
Rob WilliamsCommented:
You could also run the system file checker tool. You will need the install CD handy for this, but it will scan for missing or corrupt Windows files:
sfc  /scannow
0
 
DKerfootAuthor Commented:
History - Customer's computer.  It has been running Win XP for at least two years.  He hasn't installed anything (SW or HW) recently.  My guess is that it is due to file corruption - probably just a disk error.

AV has been run every night and no viruses detected in at least the last three weeks (all the records show).  No significant malware of any kind.

I do appreciate the suggestions, but to those who didn't read my original post, I already ran NETSH and WinSockFix.

It does have a name and a valid path.  

Also, I just noticed that I mispoke - It is running XP Pro, not home.

Probably will run sfc or do a repair install...
0
 
jhanceCommented:
Is this XP SP2?  If not, then the NETSH will not work.  If not SP2, then you probably have a virus or trojan on the maching.
0
 
Computerguy107Commented:
Sounds like you have spent quite a bit of time on this. In your situation I would spend about 30 minutes and this would include installing a new network adapter. After that time I would ghost the hard drive to my usb drive and then reinstall XP restoring the data after the successful reinstall.
0
 
DKerfootAuthor Commented:
Yes - SP2.

No - Viruses or Trojans
0
 
DKerfootAuthor Commented:
> Sounds like you have spent quite a bit of time on this.

I've got maybe 45 minutes into it - 1/2 of that typing here!  Doing it as a background job.  I am primarily focused on small business accounts and rarely do residential.  I've done a fair bit of work for the client's company company over the last few years and this is something of a favor.

SFC did not resolve.  

Probably time to fire up Ghost...
0
 
Computerguy107Commented:
yeah I think so.... reinstall ...... I really don't do home computers either...........except for the principles of the businesses I tend to. Home computers always get the weird viruses and all that stuff that teenagers tend to download. Have fun...!!!!
0
 
papimichelCommented:
have you tried to reinstall tcp/ip ?
0
 
cd92k4Commented:
Just change the NIC and install a the respective compatible drivers of a prominant company around you. Or else remove the network services compeletly and re-install them.
regards
0
 
ansh_guptaConnect With a Mentor Commented:
First of all. look for any third party networking softwares which are installed as bindings to the network card. Try in following order and reboot the server after changes.

1. Uninstall all the third party softwares which installs as a binding on network cards.

2. Uninstall the network cards if you could.

3. Look for ghosted network card on the machine.. There might be some ghosted network card installation which are not completely removed from the machine. for this follow these steps...

  Open a command prompt. The run this command to set an environment variable.
 
                          set devmgr_show_nonpresent_devices=1

From the same command prompt run devmgmt.msc to open device manager. Select view show hidden devices. Not apart from ras async adapter, remove any other grey entry.

Reboot every time.

If this all fails then use the brhamastra I.E:  run the windows xp repair install.

0
 
DKerfootAuthor Commented:
Well, I am surprised.  I went to Ghost the drive and after 90 seconds it bailed out with an error message that the drive had too many errors on it.

So, I ran chkdsk and sure enough, it had several problems.   Was then able to Ghost it.  Ran SpinRite which found a few unrecoverable sectors.  

Once done, ran IPCONFIG and everything is rosy.  So, SunBow gets the prize.

ansh_gupta - Your set devmgr_show_nonpresent_devices=1 didn't actually help this time, but that was new to me and I know I'll use it in the future, so I'm awarding you some points too.


Even though I am a little humbled that it was solved by chkdsk, I do appreciate everyone's help!

-Doug
0
 
SunBowCommented:
thanks
> Even though I am a little humbled that it was solved by chkdsk,
humbles me too. After years of it not doing me any good, it now helps me again, but that is independent of the HW. I know it is essentially a video driver messing up, and am not happy about that.
0
All Courses

From novice to tech pro — start learning today.