• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 323
  • Last Modified:

Error when trying to add repository, Error: 501 Protocol scheme '' is not supported

I have just installed activestate 5.8 and tried to add the repository

http://www.ActiveState.com/cgibin/PPM/ppmserver.plex?urn:/PPMServer

I got the following error...  Error: 501 Protocol scheme '' is not supported

I need to install the DBI module and the DBD for oracle.

Workstation is winxp sp2 and uses proxy server to connect to internet.

I have set enviroment variables... HTTP_proxy = <ipaddress>:<port>,  HTTP_proxy_user =<username>,  HTTP_proxy_pass = <password>


D

0
deNZity
Asked:
deNZity
  • 2
2 Solutions
 
Kim RyanIT ConsultantCommented:
Have you tried running the command line version of PPM. http://aspn.activestate.com/ASPN/docs/ActivePerl/5.8/faq/ActivePerl-faq2.html
This is an interactive tool where you can issue commands as follows:

ppm
ppm> install DBI
ppm> install DBD-Oracle
ppm> search Oracle
0
 
deNZityAuthor Commented:
Thanks for the reply.
I am using ppm, at the ppm prompt I entered
ppm>install DBI
and got an error message
error: no repositories found
so I then tried to add the activestate repository
ppm> rep add http://www.ActiveState.com/cgibin/PPM/ppmserver.plex?urn:/PPMServer

ang got the error message
Error: 501 Protocol scheme '' is not supported
at which point I posted here

D

0
 
FishMongerCommented:
0
 
deNZityAuthor Commented:
Hi fishmonger I sorted the repository problem (Needed to have http://<ipaddress>:port>, not just <ipaddress>:port> )

but have another problem :)  http://www.experts-exchange.com/Programming/Programming_Languages/Perl/Q_21885542.html

I will split points for replying if thats ok.

D
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now