Solved

Disk damage resulting from attempt to install second hard drive

Posted on 2006-06-13
28
3,463 Views
Last Modified: 2016-10-27

This situation involves several issues: the status of a new Maxtor HD and the status of the original drive.  The question is limited to the original hard drive.  What may have gone wrong in the mangled attempt to install a second hard drive, and what can be done to fix the original C: drive?

PLEASE note that this stuff is considerably beyond my experience and ability level.  

Problem started when I installed as a second hard drive a Maxtor 160GB EIDE HD 7200/8MB/ATA-133.  The jumper was set as indicated on the HD and installed to the slave IDE connection.  When I booted up, all seemed OK, Windows started and I saw that the new drive was detected.  Because of other duties, I simply shut down in proper manner without doing any of the drive set up stuff.

About a week later, I booted up and all sorts of stuff flashed across the black screen, too fast to read, but ending with "invalid allocation table" and the blinking -.  I removed the second HD, booted, and Windows opened without any unusual messages, and seems to work fine with the exception of any program that deals with partitioning, imaging, etc, and with obvious errors on the drive.

Probably unadvisedly, I switched the slave, master hookups with the two drives.  Windows started whether the original HD was hooked to slave or master, so long as the second drive was not connected.  Regardless of connections to slave or master, if both drives were connected, the "invalid allocation table" message stopped all further boot up.  I think my original objective was to test the cable.

I have not run, either by choice or automatically when booting, any disk utility.  Nor have I allowed any of the installed utilities to attempt to correct disk errors they detected.  I hesitate to attempt to image the drive to CDs for fear it won't succeed and may cause further problems.


Pentium(R) 4 CPU 3.06GHz
3.07 GHz,992 MB of RAM
WXP Pro, SR2, FAT32,
IDE ATA/ATAPI controllers
Disk Drive WDC WD800BB-56JKC0, 80GB
Primary and secondary IDE channels

BIOS: Phoenix-Award BIOS CMOS set up utility (P4M80-M7A)
First boot device: CDROM
Second boot device: floppy
Third boot device: Hard Disk
Other boot device: enabled

Disk Management under Computer Management shows two partitions, both basic:C: FAT32 64.28GB. cME:FAT 2MB (unknown partition).  Both "Healthy" according to this utility.  I don't see anything there that was not as originally shown in this utility before trouble. The HD, however, is an 80GB drive,

I borrowed programs from other computers, installed and tried to run them to see effect and got these results:

"PowerQuest PartitionMagic has detected an error 116 on the partition starting at sector 134833545 on disk 1. (This is the "first physical sector" of cME partition, which is type 49 according to the Computer Management properties of this partition.)  The starting LBA value is 134833545 and the CHS value is 4294967295.  the LBA and CHS values must be equal.  PowerQuest Partition Magic has verified that the LBA value is correct and can fix the CHS value.  Would you like PQPM to fix this error?"  

The exact same message appears when opening PowerQuest Drive Image 2002.

Norton Partition Magic produces the exact same message and offers to fix it.

Acronis True Image Home message is "Failed to read from the sector  151,451,171 with choice to ignore, etc.  When I click "ignore" same message for the next sector, and on and on.

I cancelled out of each program.

Del
0
Comment
Question by:del86
  • 16
  • 6
  • 5
  • +1
28 Comments
 
LVL 6

Expert Comment

by:DCreature
ID: 16899493
OK, from reading all of the above, first thing I would recommend you to do is to make sure your original drive with Windows operating system on it, jumper be set to "Master or Single" or "Master with Slave".

Then with the new second drive that you have, I assume this is going to your data storage drive. Change the jumper on this drive to set it to be "Slave" drive. Hook both of them up with IDE cable to IDE0 connector on the motherboard.

Note that some hard disk drives will come with jumper that set it to limit its capcity to something lower than its actual size, check that you haven't got a jumper limiting it's capacity, if there is, remove it. This jumper is separate one from the Master / Slave jumper, carefully read the instructions on the drive before doing this.

Your CDROM drive should be connected to IDE1 connector on the motherboard, and if there's only going to be CDROM drive connected to this IDE1 connector then the jumper should be set to "Master" for the CDROM drive.

Boot up your computer, it should let you get past the POST (black) screen and into Windows. Once you're in Windows, format the newly installed second drive as Primary partition, leave the size field as default, as this should be the max size of your drive, if not, then you can change it to maximum size stated.

Everything should work out just fine.

However, if all above fail, try this:

Turn off your computer, remove power / IDE cable from your original OS drive so it won't run and get detected. Change jumper of your second drive to Master, hook it up to IDE0 connector, so that this second drive is now primary drive. Grab yourself a copy of Partition Magic boot disk, and boot your computer with it, in Partition Magic, format the second drive with NTFS, if you use Windows XP, or FAT32 if you use Windows 98 / ME, its really up to you.

Once done, exit Partition Magic, it should reboot your computer, once rebooted, turn off your PC at POST (black screen) boot screen. Set your second drive jumper to "Slave" again, hook up your original drive to the IDE cable so now you have both drives connected to the IDE cable. Boot up your computer without Partition Magic boot disk. See if you still have problems.

If you suspect this maybe hardware problem, return the drive to the shop before they won't exchange it for you, most shops allow one or two weeks with 5% - 15% restocking fee.
0
 

Author Comment

by:del86
ID: 16899882
Thanks, DCreature, I think I follow you, but am not a galloping geek, so will take it slow.

I need to remove the system HD to check the jumper settings, although I'm pretty sure they are set right.  The Maxtor drive did not come with any instructions, but on the back of the drive itself, it was clear that for slave, there are to be no jumpers.  There is a diagram with various jumper positions which I can't interpret and my drive seems to be the only Maxtor drive not included in those listed on the Maxtor site, so I'll have to do some digging.  Right now, there are no jumpers on the drive at all.

If I only have one CD drive on a separate cable, do I need to do any checking on that?  The system drive is connected to the master connector and the cable has a  middle connector, which is the one I connected the Maxtor to.  

It seems that the essentials of your suggestions which I have not already addressed are to see if the OS drive is set as you advise and whether or not there is anything needed on the Maxtor to address drive size.  Otherwise, it's the Partition Magic route.

I'll be working on this tomorrow.  
0
 
LVL 87

Expert Comment

by:rindi
ID: 16899892
First the following message you got indicates that the drive isn't set to master anymore, but slave, as disk 1 in most utilities is the 2nd disk, counting starts with disk 0. So make sure you are really back to your original setting on the original disk.

>> "PowerQuest PartitionMagic has detected an error 116 on the partition starting at sector 134833545 on disk 1. <<

Then, is by any chance norton "GoBack" installed? This tool tends to make any disk tool or utility to not work or work erratically. So make sure goback is uninstalled before trying anything. Goback can be difficult to completely remove, so read the howtos on the symantec page.

Another tip, don't use the same IDE cable for both disks. Use the 2nd IDE channel and cable for your new HD. The reason is that the IDE interface can only access one device on the same channel at a time, if both disks are on the same channel, whenever you want access to both, you will very drastically reduce the speed of the system. Another reason is that some disks don't pair well together, and having them on different IDE channels can help if that is the case.
0
 

Author Comment

by:del86
ID: 16899942
Starting to lose track of original question, which was how to repair the errors on OS disk!

rindi, I don't fully follow all of this.  I never intentionally installed GoBack.  If installed, would it show up on the add/remove applet or is it buried in Partition Magic?  I would intentionally not install it if given a choice, and don't recall seeing anything about it.

Your last paragraph, does this mean connecting one of the disks to the same cable with the CD?  How is "channel" related to "cable".  Sorry, not really up on this stuff as I indicated.

Del
0
 
LVL 87

Expert Comment

by:rindi
ID: 16900065
I never use goback, so I'm not sure if it shows up. I think it is part of the norton utilities or systemworks or similar, so if you installed such a utility it could be installed on your PC.

Yes, I mean the same cable as the CD (Use the disk as master, the CD as slave).

Most mainboards have 2 IDE channels, IDE channel 0 and IDE channel 1. Each channel needs a separate cable, and on each channel you can attach 2 devices, the first as master, the second as slave.
0
 

Author Comment

by:del86
ID: 16900146
>>>First the following message you got indicates that the drive isn't set to master anymore, but slave, as disk 1 in most utilities is the 2nd disk, counting starts with disk 0. So make sure you are really back to your original setting on the original disk.<<<

All of what I said about the messages about the disk errors referred to the disk situation after I disconnected the second hard drive.  There is only one disk connected.  I'm aware , generally, that disks start with 0, but is  this true if only one disk is connected?  I have never changed or even touched the original OS disk except as I indicated by "testing the cable", but never had the disk out or changed any jumper settings, and since I could not boot to windows with the Maxtor connected, the installation of the programs that indicated disk errors was done while only the original disk was operational.  Would this indicate some additional problem with the OS disk?

The only Norton product on this computer is Partition Magic, so I think GoBack is absent.

Just FWIW, if I connect the backup HD to the master connector along with the CD drive on the same channel, won't I have a similar problem if copying from the CD to backup HD or vice versa?

BTW, how does one recognize which IDE channel is 0 or 1?
0
 
LVL 87

Expert Comment

by:rindi
ID: 16900445
It depends on your utility software. Most will just identify the master on channel 0 as drive 0, but it is possible that some software will have a different output. I'm not completely sure about how partitionmagic handles this, but i'd think they use disk 0.

The IDE channel is usually identified on the mainboard itself or in it's manual.

And yes, you'd have a similar problem when copying to/from CD to HD, so try copying to or from the other disk when doing that, not to the one on the same channel.

Some systems use Cableselect to define the masters and the slaves. The 80 wire cables usually support CS, and the disk which is connected to the far end of the cable is the master. Also make sure that in such a case the devices connected to the systems have the jumpers set to CS. Don't put a disk which is jumperred as master on the middle of the IDE cable.
0
 
LVL 8

Expert Comment

by:Disorganise
ID: 16902129
Assuming you did not copy any information to the new hard, I would be inclined to do the following:
1) with only the original disk installed, boot to windows and create the partiion magic boot disk/CD  (can skip this if you already have)
2) disconnect original drive, and connect the 'new' drive
3) boot partition magic and delete any partitions on the new drive.  create a new partition(s) as you see fit, and format.
4) disconnect the 'new' drive, and re-connect the original.  boot to windows to check nothings changed
5) connect the 'new' drive and see if windows now boots with it connected.  If it does, goto step 9
6) shutdown and connect the 'new' drive to the CDROM cable - for now you can simply pull the CD cable out and plug the HD in its place
7) Verify in the BIOS that the original WesternDigital disk is booting before the new disk if the BIOS has those options
8) Boot windows to see if it now works.  If it doesn't, there is likely an incompatibility between the drives which you aren't going to easily resolve.  You might try a BIOS update, but if that fails, see if you can get a different HD (change brands)
9) If the 2nd drive is working at this point, I'd be copying my files across to it to ensure you have a back-up.  In fact, if it works, I'd run a full NTBackup against the C drive, saving the image to the new drive letter.
10) Now run your preferred tool and allow it to fix the sector problem
11)  Reboot and cross your fingers!

good luck
0
 

Author Comment

by:del86
ID: 16904006
Disorganize

>>>Don't put a disk which is jumperred as master on the middle of the IDE cable.<<<

I probably did this for at least one bootup attempt.  What were the likely consequences of that goof?

>>I'd run a full NTBackup against the C drive, saving the image to the new drive letter.<<

Is this just an image file using utilities like Acronis True Image or PowerQuest Drive Image, or is NTBackup a separate program.  I do not have a WXP Pro CD, only the OEM recovery disk.  Believe NTBackup is a windows backup utility, right?

>>Now run your preferred tool and allow it to fix the sector problem<<Please name a couple so I 'm sure of what this step entails.

Thanks
0
 
LVL 87

Expert Comment

by:rindi
ID: 16904186
>>  >>>Don't put a disk which is jumperred as master on the middle of the IDE cable.<<<  <<

>> I probably did this for at least one bootup attempt.  What were the likely consequences of that goof? <<

your disk could be in an undefined state and not easy for the System to realize if it is master or slave. this would also throw the utility software etc off track.
0
 

Author Comment

by:del86
ID: 16904624
To All,

in light of rindl's last comment, which is probably the current state of my drive, which is the only one now connected, do the suggested steps offered above still make sense?  I have done nothing yet, trying to get to an understandable starting point before attempting any of the steps suggested.  Have I screwed up the drive so that none of the suggested solutions could possibly work?

My originally stated question outlined the novice steps or misteps I took in creating this problem.  Before switching connections between the old and new drives, I could boot to windows so long as the new drive was not connected, but I did not, at that time, check to see if the old drive had errors. Those errors must have been caused by messing around with the connections, more specifically connecting the old master drive to the slave connector on the non CD cable.

The status of my computer now is as stated first above.  The old drive is connected as originally from the vendor, the new drive is unconnected, my drive has errors.

I apologize for failing to grasp ahold of a solid plan of getting things underway to effect a solution, if one is available.

Thanks

Del

I'm really confused now where to start attempting to clean this up without creating additional problems, if such clean up is in fact possible under the circumstances.
0
 
LVL 8

Expert Comment

by:Disorganise
ID: 16910054
Del,

>>>Don't put a disk which is jumperred as master on the middle of the IDE cable.<<< - that was actually rindi's comment, not mine.  In the dark days of 486 before cable select implementations actually worked, I had no issues swapping maser and slave around on the cable.  The jumpers always win.  I can see a *potential* issue having a drive jumpered as master in the middle, and a drive set for cable select on the end, since you then have 2 masters; although I'm sure the jumpered one would win.  Most likely you get a 'stuck' HD access LED and no boot until you rectify (probably wouldn't even finish POSTing)

You are correct in your asertion of NTbackup.  in XP it's just called Backup and it lives under the Accessories/System Tools area.  Use it to capture C drive and system state to a file on the new drive (or to C drive and then burn to CD/DVD).  This step simply ensures you have an out should things go pear shape.

>>Now run your preferred tool and allow it to fix the sector problem<< - you mentioned "PowerQuest PartitionMagic, PowerQuest Drive Image 2002, and Norton Partition Magic".  use whichever one you're more comfortable with - probably either of the partition magic's.

Now, assuming your system is capable of booting as it currently stands, you're ready to follow the steps I indicated above.  Although perhaps you'd like to have a crack at windows backup first, and save everything to a file on C drive, then burn it to CD/DVD.  Since this utility access the files using the standard windows commands, you shouldn't get errors like you would using an imaging utility - it just doesn't care about partition information.  The reason we're doing this is so that if you end up having to use the OEM recovery disk, you can use windows backup to restore all your files and settings, and since it ignore partition information, it won't re-introduce the problem.

If you've done the NTbackup and burned the file to DVD, you can of course skip step 9.

Just one further point.  IF you were forced to revert to OEM CD, I'd swap the drives.  ie, run the OEM CD against the new drive - this would make the new drive 'it' and provide a working system.  you then add the old drive as a slave to pull off your olf files....and if it seems blank, 'Getdataback' is an awesome tool for 'undeleting' files.  But it won't come to that I'm sure.
0
 

Author Comment

by:del86
ID: 16913137
Thanks for getting back.

FWIW, I did attribute the comment about >>>Don't put a disk which is jumperred as master on the middle of the IDE cable.<<< to rindi, not to Disorganize, but gave it credence because I thought when I did it that it was probably a stupid thing to do, and can't think of what else I might have done to screw up the drive.

Have not used NTbackup because I didn't think I had it.  It's not on XP Home, which is what I use most often and am on now, but the sick computer has XP Pro and has the utility.  I remember Fred Langa addressing this issue once.

I have a single CD drive with a different cable than hooks up the HD.  It's flared at both ends, and looks like if you would wrap the rest of the cable with electricians tape giving it a round shape except at each end.  There is no middle connector, however.

Not having further comment from DCreature, I will try to follow the advice from Disorganize unless I detect some significant conflict in a step along the way.  Hope I am not making a mountain our of a mole hill, but these things scare me when something doesn't work right or I screw up.

Thanks, may be several days before I've stumbled through, but the issues are definitely live and am relying on EE  for guidance.
0
 

Author Comment

by:del86
ID: 16931561
I tried all of the suggested options and never got anything except "invalid allocation table".  Was able to format and patition the drive under Partition Magic, but got no help from that on bootup.

I finally did some research on the drive itself and found the following on the Maxtor site:

CE HARD DRIVES
Maxtor QuickView® hard drives
are designed for digital video recorders (DVR), set-top boxes (STB),
DVD/HDD combos, game consoles and other consumer electronic devices.
QuickView hard drives offer audio-visual performance and advanced
features that enhance the digital entertainment experience.
Ideal for Digital Video Recorders
DVRs integrated with Maxtor QuickView hard drives have the performance
and large video capacity to truly change the way you watch TV. Cable,
satellite or stand-alone STB boxes enabled with QuickView drives allow
you to digitally time shift up to 300 hours of your favorite programs.
You can simultaneously record, pause, rewind, fast forward or play back
programs, giving you more control over your TV…and your time.


DiamondMax 10 Drive
Capacities up to 300GB and Serial ATA with native command queuing, dual processor
technology and larger buffers for faster boot times, file transfers and performance that handles
multiple applications with ease. These high performance 7200RPM drives are designed for
multimedia PC users, system integrators and white-box builders. RoHS compliant versions
of DiamondMax 10 are available.
RoHS Model # Capacity Interface Buffer RPM
6L080P0 80GB ATA/133 8MB 7200
6L120P0 120GB ATA/133 8MB 7200
6L160P0 160GB ATA/133 8MB 7200

The last one listed is my drive, and it's CE.  It might explain why I kept getting some message about "media cable missing" or similar when bootup attempt ending in "invalid allocation table".

I don't know enough about this stuff, but it would seem that the above is relevant and probably causing my problem, and without adequate knowledge, just got the wrong drive for my computer and storage purpose.

Any comments before I wrap this up?  I have a question about backup but may have to ask separately.  I did as Disorganize suggested and made a full backup using the XP utility, but am not sure how to apply it if I have to resort to the Recovery Disk.  Copied to 4.6GB DVD-R.
0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 
LVL 8

Expert Comment

by:Disorganise
ID: 16933299
A hard drive is a hard drive, so don't panic.  besides from your quote above "These high performance 7200RPM drives are designed for multimedia PC users".  you got a CD player, sound card and graphics right?  then you've a multimedia PC :)

You say you formatted the drive - is that the new one?  So have you gotten to step 9/10 but the tool doesn't fix the problem?  Can you elaborate a little?

You say you've done the back-up and it's on DVD - good, at least you can get your data back.

Assuming the new drive is freshly formatted I would be inclined to do the following:
Swap the old for the new drive
Install XP (from recovery CD)
Do the restore

Why?  Well this verifies absolutely that the back-up has all your info, AND it gives you a working system - from here you can try fix the old drive without fear of repurcussions.

How to restore?
Open up Windows back-up and  click 'Advanced mode' if in wizard mode (default)
Click tools/options/restore and select "always replace the file on my computer'
click OK
click Restore Wizard (advanced), then Next
Click browse, and browse again, and navigate to your DVD player and locate the backup file and click Open, then OK
In the left window, expand out the items to restore and select both C drive and system state, then click next
Click Finish
The restore will now commence.  When complete, reboot the system and it should be as it was on the old drive (but without the invalid allocation table issues)

If this doesn't work, swap back the drives and check you did a backup of EVERYTHING and then try again.
Now, assuming you want the old drive to be the boot drive, you can reformat it and then repeat the above steps to bring it back to how it was.  Then simply format the new drive and you're back where you were before the problems started :)  slave the 2nd drive and carry on.

One final point - the BIOS *is* recognising the new drive as the full 160GB right? and not just 127GB or something - just checking you haven't got a BIOS issue (unlikely given the machine spec but doesn't hurt to check)
0
 

Author Comment

by:del86
ID: 16937127
>>>A hard drive is a hard drive, so don't panic.  besides from your quote above "These high performance 7200RPM drives are designed for multimedia PC users".  you got a CD player, sound card and graphics right?  then you've a multimedia PC :)<<<

Admit the same reasoning crossed my mind, but was looking for anything that might shed light on this situation.  "Invalid allocation table" doesn't necessarily mean just that literally, right?  Read somewhere that that error message could simply indicate a problem without specific identification of what the actual problem is.

>>You say you formatted the drive - is that the new one?  So have you gotten to step 9/10 but the tool doesn't fix the problem?  Can you elaborate a little?<<

Using Norton Partition Magic to boot up with both drives attached, the new drive as slave, both drives were shown, original drive 0, new drive as disk 1.  I formatted the new drive, disk 1, which showed 153+GB, as a primary partition, NTFS.  First tried FAT32, same as original drive, but got some message saying the drive may not be usable if FAT32, so switched to NTFS.  Because there is nothing on the disk 1 drive, format was quick as a wink, and PM showed both disks, disk 0 as original, disk 1 NTFS.  PM offered to fix errors on disk 0, chose no, and exited.  System rebooted, but I shut down, I think too late, and the reboot got to "invalid allocation table" again.  Tried again with PM, exited and just got the C:\ prompt.  Removed PM floppy, rebooted, invalid allocation table.

Above does not sound like I followed your steps 9 and 10 but I know I did at one time and upon reboot got the same dead end message, but I will run through that procedure again to make sure.  I don't recall "deleting" any thing on the drive in PM and reformatting, so maybe missed something there, although never having access to the drive other than through PM there should be nothing to delete. (see your comment 06/14/2006 05:58AM PDT, as it appears on my screen, am in Wa state).

I have at no time, whether in regular bootup with only the original drive installed, which is the only way now I can get to Windows, or in PM ever made any changes to the original drive, no error correction or anything.  So that drive is as when started this question.

Also, at no time except through PM has my system ever recognized the new drive, always the file allocation message stops bootup.

For clarification, after having made any changes in PM, you say to exit and PM will reboot and that I should shut off at a particular point.  Could you be more specific where that point is?  I have tried that several times without any success, but may be shutting down at wrong point.  When booting, the first screen shows how to get into BIOS, then is blank briefly before anything appears on screen.  I presume at that blank screen is where I shut off, right?

Before going to Recovery Disk, will check that I have done all you suggest so I can verify your assumptions of where I am.  Your suggestion that I install the Recovery on the new drive presupposes that the new drive is available, recognized, which it is not, at least not yet.  Regardless of configuration of connections and jumpers, the new drive has never been recognized except in PM, always stops with the error message.

>>>One final point - the BIOS *is* recognising the new drive as the full 160GB right? and not just 127GB or something - just checking you haven't got a BIOS issue (unlikely given the machine spec but doesn't hurt to check)<<<The only recognition of the new drive is in PM, does that count for anything relative to BIOS?
0
 

Author Comment

by:del86
ID: 16937403
I see that I'm getting comments from DCreature and Disorganize mixed up and I apologize.  I'll try to straighten it out.  Trying to follow these suggestions, which are quite similar, I think, I get off course on who said what.  Hope you will bear with me as I struggle through this.

And much thanks to all.

Del
0
 

Author Comment

by:del86
ID: 16939368
A bit more info that may have some bearing:

When booting with both drives installed this is what I get: NOTE LEFT SIDE OF SCREEN IS OFF ONE SPACE:

erifying DM1 Pool Data......
oot from CD
ntel UNDI PXE-2.1 (build 082)
opyright (C) 1997-2000 Intel Corporation
or Realtek RTL8139(X)/8130/810X
    PCI Fast Ethernet Controller V2.16 (041224)
XE-E61: Media test failure, check cable
XE-MOF:Exiting PXE ROM
nvalid partition table-(blinking)
END

note invalid partition table vs invalid allocation table as before

When booting with Partition Magic boot disk, the following:

tarting Caldera Dr-Dos
IMEM.SYS : Warning: Address line A20 already enabled
aldera DR-Dos 7.02
opyright (C) 1976.........
     Please Insert Partition Magic Disk 2
END

If this doesn't shed any light, I think I will just install the recovery disk and start over without restoring the backup.  This computer came with a lot of junk software, much of which I either deleted or uninstalled because it wasn't wanted or was trial and I would never consider purchase.  Some was some fancy media stuff which I don't get into much, but am thinking may have some impact on this particular hard drive installation.  Before recovery, think I will attempt to let PM correct errors on the C: drive and then hook up new drive again.  Who knows?

Believe I have tried all suggestions to best of my ability, with no success.

BTW, CD drive is jumpered to master, main HD is master or select, no "cable select" indicated on any of them.  Problem may still be in how I have left the new drive as "slave", with no jumpers, but none of the other settings seem to fit.

Will read all of this through again before trying anything with restore or correcting errors on C: to see if I missed anything.

If nothing else, I have learned some things from this excercise, but wonder how much good it would do anyone else.

Del
0
 

Author Comment

by:del86
ID: 16955970
Think this is all dried up.  Reading back on the comments, if I'm reading them correctly, it seems that I have somehow not made it clear that the new drive has never been recognized by Windows with the possible exception, which is a little mushy in my memory now,  of when I first installed it, but shut down Windows before any initialization or formating.  Once this problem was apparent, I have never been able to get the system to recognize the new drive, so I can do nothing with it.

The only time I can work at all on the new drive is when I boot via the Partition Magic boot disk and work with the Caldera DOS PM program.

BTW. Norton PM shows Disk 1 and 2, not 0 and 1.

Is it possible that this drive needs a special cable?
0
 
LVL 8

Expert Comment

by:Disorganise
ID: 16972888
Sorry dude, haven't posted for a few days - I'm in the middle of a uni assignment.

You'd be better with an 80pin cable for sure - however, a 40 pin cable will work, you just won't get the full speed.

I still think you're around step 5 from my previous post.  although not explicit, upto step 5 was intended to have one drive attached only, if that makes a difference.

from a later post, I would still be inclined to install the new drive on its own (apart from CD).  install XP.  if that doesn't work, you've got fundamental issues.  from step 8 "You might try a BIOS update, but if that fails, see if you can get a different HD (change brands)"
If XP does install ok, then you could do the restore - you then have a a working system with 160GB drive instead of 80GB.
Then add the old 80GB as a slave - if you can't see it then the 2 drives don't play nice.  if you can, then you can let partition magic fix the old drive.  Your choice then whether to leave the system as is, or swap the drives a round so old drive become the master and boot drive - but I'd probably leave it with the new drive as master if it's working.

If you get confused, post back.  I'll have more time Tuesday after my assignment to run thru a more step by step scenario and pull together the previous posts.
0
 

Author Comment

by:del86
ID: 16973663
Thanks, Disorganize, for hangin' in.  I've been cutting grass and stuff I can handle, trying to get some confidence back.

The only thing I've accomplished with the new drive is to format the whole drive in NTFS, and that done in Partition Magic via boot disk.  I noticed in reading some of the back comments that PM sometimes uses disk 0 and 1, other times 1 and 2?

Through PM in windows I have partitioned the old drive and had PM correct errors.  Powerquest Drive Image still can't read certain sectors, but was able to create image with Acronis onto the second partition.  Says it's successful but haven't tested.

Do you see anything significant about the text being off one space on the left of the screen at boot up?

From your last comment:

>>>from a later post, I would still be inclined to install the new drive on its own (apart from CD).  install XP.  if that doesn't work, you've got fundamental issues<<<<.

Does this mean disconnect both hard drives and the CD drive, connect the new drive to the CD drive cable, and attempt to install XP from the recovery disk?  If not, not sure what the above quoted means.

My next step WAS going to be to hook things up as original before installing the new drive, run the recovery disk and without any restore of backup, see if the new drive is recognized, but will now just await your sage advice.

Thanks,

Del
0
 
LVL 87

Expert Comment

by:rindi
ID: 16973996
I've just remembered something about partitionmagic... What version are you using? There was a disk size limit of 80 GB and that only was corrected in the newest version of the software. I think when that got corrected it was already part of symantec.
0
 

Author Comment

by:del86
ID: 16974062
Hi rindi

Norton PartitionMagic
Version 8.05   (Build 1371)  5/5/2004

This from the whats new section:

·      Enables the management of partitions up to 300 GB when the partition is less than 90% full. Larger hard drives may require additional memory.

I didn't see any warning or error message when messing with the 160GB drive and it showed 157+ GB when the drive was formatted.

Del
0
 
LVL 8

Accepted Solution

by:
Disorganise earned 500 total points
ID: 17000248
Hi Del,

There are a number things you need to test/verify, so I'll break it down into a series of parts.

Part 1 - Is your PC able to recognise the 160GB drive properly?
1) disconnect the 80GB from for the IDE ribbon
2) connect the 160GB drive in its place.  ie, you should have the 160GB drive attached to one cable, and the CDrom attached to the other.  Given the issues already encountered, I think you'd be best to set the hard drive jumpers to MASTER or StandALone/single drive - this eliminates any doubt with cable select.
3) If confident with the BIOS, go into it and check the drive is recognised in full
4) Install XP - this can be done from your rescue CD.  If this works, it proves your computer is able to use the drive OK.  If this fails in some way, it would point to some issue between the drive and your PC.  If you have spare IDE cable, try that.  Otherwise you're probably looking to return the drive and get a different make; if you do this, return to step 1 to verify the new drive is gonna be ok.  IF you find more than one drive to not work, there's something wrong elsewhere - motherboard, cables, BIOS or something.

Part 2 - Test your back-up (and bring system back to fully operational) [This part is optional but recommended]
1) Open up Windows back-up and  click 'Advanced mode' if in wizard mode (default)
2) Click tools/options/restore and select "always replace the file on my computer'
3) click OK
4) click Restore Wizard (advanced), then Next
5) Click browse, and browse again, and navigate to your DVD player and locate the backup file and click Open, then OK
6) In the left window, expand out the items to restore and select both C drive and system state, then click next
7) Click Finish
8) The restore will now commence.  When complete, reboot the system and it should be as it was on the old drive (but without the invalid allocation table issues)
9) boot the system and verify everything is working as expected.  You now have a working system using the 160GB drive.  NB. if the restore is incomplete or leaves the system unfinished or unstable, put the 80GB drive back in (remove the 160GB) and re-rin back-up, taking care to capture EVERYTHING.  then return to part 1.

Part 3 - Fix the old drive
1) Change the jumper settings on the 80GB to slave
2) attach the 80GB drive to the 2nd connector on the IDE cable (ie as 2nd drive to the 160GB on same cable)
3) boot system and check is working ok
4) run your partition magic tool and allow it to FIX the 80GB drive (ie let it write out the fix)

CHOICE:  do you want the 160GB or the 80GB drive to be the boot drive?

If 160GB (recommended):
Re-format the 80GB drive for re-use as you wish.

If 80GB:
1) shutdown and unplug the 2 drives
2) change the jumper on the 80GB drive back to master
3) change the jumper on the 160GB to slave
4) connect both drives to cable - 80GB on the end connector, 160Gb in the 'middle'
5) boot system and verify all is working
6) re-format 160GB drive as you see fit

Hopefully, that just about covers it.  Please read it through a couple of times before attempting anything.  If there's any doubt/room for ambiguity, let me know and I'll try to be more explicit.

cheers & good luck
0
 

Author Comment

by:del86
ID: 17006885
Disorganize, step one seems to have gone without a hitch.  The BIOS shows 163GB on the Maxtor drive.  Installed via the recovery disk and now have WXP.  I think I will leave the Maxtor as primary drive.

Have a problem with backup restore, the system as now configured can't read the DVD 4.7G disk on which I restored from the old drive.  The drive is detected, but I think as a CD Rom drive.  The software and/or drivers have not been installed with the Recovery CD, but are on a separate disk which is meant to be installed on the original drive, as it mentions something about installing from a second partition which was a backup partition on the original drive.  This from just what's printed on the disk itself.  Will have to read whatever documentation I have on this particular computer relative to restore.  I would think most restore disks coming with OEM machines would not anticipate a situation such as mine, and would be instructing a simple recovery on the original disk setup, partitions, etc.

I suppose I could, if the old drive functions, burn the restore image on CDs so the new drive could read from them with existing software, just as the new drive would have been restoring to a new disk data that had been backed up from a different disk under your step 2, just using different software.

This is kind of fun for me, but imagine you are getting a little tired of all this.  I will follow your step 2 and hook up the original drive as slave and then see how things interact.  I'm pretty sure I can somehow get the driver and DVD software onto the Maxtor so it can read the restore disk, but I think first I'll install Acronis, Partition Magic , partition the Maxtor or maybe the old drive and make an image of the newly restored XP so I can get back without going to reinstall disk if things blow up.  Or is that not a workable use of the Windows Backup facility?

I will first do your step 2 without the restore and if that is successful will accept your answer and award the points and close it up.  All these other issues could go on for some time and I don't see them as part of this question.  Will be back for at least one more comment before closing.

Thanks a bunch for filtering through all the previous comments and laying out a concise set of steps.  Most appreciated.

Del
0
 

Author Comment

by:del86
ID: 17006915
BTW, is there a mechanism whereby I could ask further questions relative to this thread, refer to this url and maybe get you some more points for some support which may be going beyond the original question but sort of carrying with and directly related to my particular set of circumstances as they have developed in, I hope, solving my original problem?

Del
0
 
LVL 8

Expert Comment

by:Disorganise
ID: 17008333
The recovery partition could well be hidden - although partition magic etc would be able to unhide and allow you access to the files and drivers.

By all means partition your 160GB drive and make a copy of the partition.  the Windows back-up doesn't store partition info so restore won't be affected.

The only issue with going from part 2 to 3 without verifying the restore is that if the 80GB drive gets corrupted (I doubt it will but....), and you find you still can't access the DVD with the backup file on it, you've lost your settings for good.

One option is to swap the drives back, boot up the 80GB and re-run the back-up, and burn to CD (you might need to split the file using winzip or winrar or something), then swap back again to try the restore.  Doing the restore will bring back all your drivers and things too so its worth doing.  Once its restored, take yourself another partition image as a back-up for future use.
Then proceed to part 3 in complete confidence.

as to other questions - it's up to you.  If they're directly relating to this isssue, ask them here.  If you do raise new questions, past the URL of this one into them for background.
0
 

Author Comment

by:del86
ID: 17021178
>>>4) run your partition magic tool and allow it to FIX the 80GB drive (ie let it write out the fix)<<<I don't follow this unless it just means delete and reformat the drive.

Don't know why the 4.7G DVD would not play.  Rather than re-do the backup onto CD, I left the drives as is, Maxtor as main drive and ran the Windows backup utility to restore what would have been on the DVD by sourcing the restore from the folder on the original drive which is now slave.  When running the original backup, per instructions on the facility, the backup went to a folder on the C: drive.  Fortunately, I was able to locate that folder on the disk and restored from that.  So far everything seems OK.

When running Acronis TrueImage Home to image the C: drive on the Maxtor disk, Acronis still refers to errors on the slave drive, secondary drive, which I have ignored.  Partition Magic does not indicate errors on the Maxtor disk, but shows something wrong on the Type 49 partition on the slave drive, which I am presuming will be fixed with the reformat.  Think this is MBR, but since I won't be booting from that drive, does it really matter?  Recall seeing somewhere that the error was related to the boot record being out of sequence.  Neither Acronis nor Drive Image offer a fix on the error anymore.

I still don't know how the original problem with the Maxtor drive developed, but think it was because of the way I originally installed the disk, booted up, but did not initiate and format the drive at that time.  Something must have taken place when the drive was first recognized that was interrupted when I shut down.

Anyway, off to new screwups and you can bet I'll be back.

Thanks to all,

Del
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Hi, I've made you some graphics for a better understanding how RAID works. First of all, there are two ways a raid can be generated: - By hardware - By software What does that mean? This means: If you have a hardware RAID controller, there…
I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now