OWA 2003 click on mail address link - after some try "mailto:" still compare when i click on an email address

after read around the net some workaround to make my owa fill the username when i click on email address i put this string in the registry:

"%ProgramFiles%\Internet Explorer\iexplore.exe" http://MYSERVER/exchange/%USERNAME%/Drafts/?cmd=new&mailtoaddr=%1


so if i click on webpage:
mailto:donald@littlefun.com

my owa client start correctly
but fills the first line:
TO: mailto:donald@littlefun.com

and for that reason it appears a popup with unrecognized address.

i'd like to cut the string "mailto:" and leave only the email address.

i know that exists some software that i can buy, but i won't spend 200$ for that, i think some expert can find a workaround creating a vb script, or vb application or why not, just using the regestry to set up a new environment variable (%2) or something like that.


DenunAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
DarthModConnect With a Mentor Commented:
PAQed with points refunded (500)

DarthMod
Community Support Moderator
0
 
aa230002Commented:
I think, first you need to have your Outlook Web Access (OWA) as your default email client.
once it is done, everytime you will click on any email address, it will be populated in the "To" field and your OWA client will start automatically..

Have a look at this ->
http://blogs.msdn.com/tmeston/archive/2004/01/08/48837.aspx

Thanks,
Amit Aggarwal.
0
 
aa230002Commented:
OR visit this link -->
http://www.asaris-matrix.com/sweber/playground/downloads/forms/DispForm.aspx?ID=10

you only need to execute the OutlookWebAccessAsMailClient.wsf located in the WebForm – NewMail  which is a subfolder to Exchange WebForms, here you simply specify the URL of the OWA server.

Then you can select OWA as the default mail client under Tools > Internet Options > Programs in Internet Explorer

Thanks,
Amit Aggarwal.
0
 
DenunAuthor Commented:
thx for reply, i alredy set owa default client, what i meant is
that It doesn't create a new mail with the e-mail adress:

i think the reason is (from the blog):
"....But %1 in that registry key uses the full "Mailto:username", and OWA doesn't interpret that.... but at least it gets you a wee bit farther than just opening up the OWA window....."


I can't open asaris.matrix :( , can u pls cut and paste the page?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.