Solved

NAT Cisco 2500 Series

Posted on 2006-06-13
4
1,882 Views
Last Modified: 2012-06-27
Trying to  learn cisco, working with a 2514 router, trying to setup NAT. What is wrong with my config listed below.

from 10.10.10.2 I can ping 10.10.10.1 and 192.168.11.107 (DHCP Assigned) , but not beyond on the 192.168.11.0/24 network and vice/versa.

The router is running 12.2(3) Software.

interface Ethernet0
 ip address dhcp
 ip nat outside
!
interface Ethernet1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.11.1
no ip http server
!
access-list 1 permit 192.168.11.0 0.0.0.255
0
Comment
Question by:jcs5003
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 9

Expert Comment

by:robinluo
ID: 16901615
you are missing the IP NAT command, which could be like this:

ip nat inside source list 1 interface e0 overload

The command can be varied depend on your preference.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 16902415
ip nat inside source list 2 interface e0 overload

access-list 2 permit 10.10.10.0 0.0.0.255

Cheers,
Rajesh
0
 
LVL 2

Author Comment

by:jcs5003
ID: 16903013
rsivanandan

your answer worked, thanks alot....can you explain these commands? how does the source list reference the different interfaces? ( source list 2 = e0 ??)

0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 250 total points
ID: 16903557
I'll try to explain it simple;

You have 'ip nat inside' on the e1 interface and 'ip nat outside' on the e0 interface which tells the traffic coming from e1 and going out through e0 should be natted.

Now;

ip nat inside source list 2 int e0 overload

What this tells the router is that, any traffic that matches the access-list 2 should be patted using inteface e0's ip address.

The access-list 2 makes sure that all the hosts inside your network or in other words, all machines in 10.10.10.x network will match it.

Hope that is clear enough.

Cheers,
Rajesh
0

Featured Post

Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco RV 130 - No internet on wired connections, wireless clients ok 32 122
adjusting startup config 6 77
Port Forwarding 4 62
Routers to buy for MDT Multitasking 6 81
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question