Solved

Citrix Presentation Server 4.0 Cannot Connect to the Ctirix Metaframe server / no Citrix server configured on the specified address

Posted on 2006-06-13
17
1,573 Views
Last Modified: 2008-01-09
I have a Citrix PS 4.0 server running everything on one box.
I can connect internally
I can connect externally (over ip address https://64.... ) on a computer that is on my VPN.
When I try to connect via a computer not on a VPN, I get the message above.

no Citrix Metaframe server configured on the specified address.


any ideas?
0
Comment
Question by:Quadeeb2003
  • 11
  • 6
17 Comments
 
LVL 18

Expert Comment

by:mgcIT
ID: 16899984
ok rather than launching the application right-click on it and save the file to your desktop... please post the "Address=" line.
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16900099
[Wordpad]
Address=10.0.0.101:1494
AudioBandwidthLimit=2
AutologonAllowed=ON
CGPAddress=*:2598
ClearPassword=AF647418436336
ClientAudio=On
DesiredColor=2
DesiredHRES=640
DesiredVRES=480
Domain=\33AD855FB55A5890
InitialProgram=#Wordpad
Launcher=WI
LongCommandLine=
ProxyTimeout=30000
ProxyType=Auto
SSLEnable=Off
SessionsharingKey=2-basic-basic-amsnet-justin-DME
TWIMode=On
TransportDriver=TCP/IP

Does this help?
0
 
LVL 18

Expert Comment

by:mgcIT
ID: 16900148
>> 10.0.0.101:1494

see this is the problem.  When not on the LAN and not on a VPN (virtual LAN) your computer will NOT be able to communicate with this private address.

Open the Access Suite Console again and go to Manage Secure Client Access > Edit DMZ Settings

Post the details of the rules you have configured there.
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16900184
I have
client ip address           mask          access method
default                                                secure gateway direct
10.0.0.101                 255.255.255.0             Direct
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16900188
I am guessing we are going to make a new translation, and then reference it in the DMZ settings?
0
 
LVL 18

Expert Comment

by:mgcIT
ID: 16903713
yea we might have to... what is the local IP Address range of the computer you were testing with?

if it is in the same range as your LAN (10.0.0.x) then it's not going to work because your web interface is detecting that and thinking the computer is on the LAN when it's really not.  Try removing that 2nd rule and connecting from the outside and see if it works.  Your default connection (the secure gateway) actually should work from any location.
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16904167
OK, this is disapointing.  I tried removing the second line, and no luck with either WAN (over VPN)  or LAN.  The Notepad application does not start, and in fact does not even give me an error on the WAN, on the LAN I get a red circle with a white X: ERROR: An error has occurred while connecting to the requested resource.

My alt site VPN LAN 10.0.10.x
the other sites are default for the routers 192.168.1.*


The only thing I changed on the system was the attempt to get the install to go when people log in (Other Question Option 2).  I did  as prescribed and restarted the IIS.  I'll check that question again.
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16904327
Also, when connected from the LAN now after log in, i get a security information alert / this page contains both secure and non secure items. Do you want to dispay nonsecure items?, yes, no,
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16908848
Alright, fixed logging problems over LAN and WAN, like an idiot I pressed 'repair database'.
Seemed to lose everything, had to build a new WI and I got LAN and VPN connection up.

Still trying to get internet connection up when not on VPN.
0
 
LVL 18

Expert Comment

by:mgcIT
ID: 16908939
ok can you tell me which connection you are using when connecting from LAN or VPN?  (again use the steps I posted in the very first comment).

For it to work correctly over the internet the launch.ica file will look like this:

[Wordpad]
Address=STA;3K4J324K3432KJ432J4324K3  
...
basically a bunch of jumbled characters.

I think what is happening is that when connecting from your remote site it (without VPN) it is still trying to use the 2nd Access rule because of your local IP Address.  Are you able to test a connection from another site where the local IP address does not use the 10.0.10.x mask?
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16909005
I think what I need to do is get the WI an alternate IP address, and get it in a DMZ.  I purchased a router that can accomplish this, but I won't get it for a bit.  All the articles/posts I have been reading are pushing me down that path.

but, from my house right now
[Wordpad]
Address=10.0.0.101:1494 (does not work - no VPN) LAN 192.168.1.x
from my LA office (VPN) LAN 10.0.10.x
[Wordpad]
Address=10.0.0.101:1494
From my office desktop   LAN 10.0.0.x
[Wordpad]
Address=10.0.0.101:1494

At this point though I would like to do this just because...there has to be a way.
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16909026
Ok, I tried to telnet port 1494 from all three locations, and of course my home  does not get the ICA response, but the other two do.
0
 
LVL 18

Accepted Solution

by:
mgcIT earned 500 total points
ID: 16909166
>> I think what I need to do is get the WI an alternate IP address

If you are going this route then you aren't really using Secure Gateway, however it will work.

And you don't even really need a DMZ in that case then.  You already have an external IP Address (your web interface must have one) so all you need to do is open port 1494 through your firewall to that IP address.

Then on your citrix server you will run the altaddr command:

altaddr /set 64.xx.xx.xxx

Lastly change the Default Connection in the Access Suite Console to Alternate instead of Secure Gateway direct
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16913244
ok, I have my router port 1494 open and pointing the the ip address of the web interface.
I ran teh altadd /set command and I see the alt address listed
my default connection is now alternate, instead of Secure Gateway Direct

But I still cannot get the app to run
0
 
LVL 18

Expert Comment

by:mgcIT
ID: 16913361
are you getting the right IP address in the launch.ica file?  It should now show the external IP address
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16913548
No, but that might have something to do with the fact that I created a new interface.  Before, If i just typed in the https://xxx.xxx.xxx.xxx, i got the site, now, it gives  me this site is under construction.  On the computers I was trying from before the path was already in the Internet explorer, and it filled in the citrix/metaframe portion.  That could be part of my problem, or not.
But to answer your question, no I did not manage to get the other address in there.
0
 
LVL 1

Author Comment

by:Quadeeb2003
ID: 16915577
mgcIT Please check my new open question
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

#Citrix #XenApp #Citrix XenApp #Citrix Concurrent License #Citrix Licensing #Citrix Policies
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now