Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Any ideas on what this error means?

Posted on 2006-06-14
10
Medium Priority
?
531 Views
Last Modified: 2013-12-16
We have ES3.0 (Redhat) and it runs very well for the most part. It's used to host our database accounting application. I ran into some problems this AM (unusual). First of all, I couldn't get the tape to eject from the drive. Finally I decided to reboot the server and get it out then. While shutting down, I lost the X window and had a black screen with line after line of this:

"ext3-fs error (device sd(8, 5)) in start-transaction: Journal has aborted"

Like I said, line after line after line of that. I couldn't get the machine to respond so I tried getting a terminal window up with the F keys. When a terminal would open, after a moment, I would get:

"journal committ I/O error"

Finally it rebooted

Any ideas on what the two errors are caused by, or what they are referring to?
0
Comment
Question by:dwielgosz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 88

Expert Comment

by:rindi
ID: 16905366
Ext3 is as opposed to the older ext2 a journaling filesystem. Journaling filesystems keep journals of their transactions inside reserved space. This allows the filesystem to be repaired in case of the disk being disconnected or turned of without properly shutting the system down by replaying these journals to the original filesystem. Something has now probably happenned to your filesystem which the journal can't restore, and that seems to be on sd8, partition 5. Maybe that device is bad.
0
 

Author Comment

by:dwielgosz
ID: 16905386
How can I check that in Redhat ES? The integrety of that partition?
0
 
LVL 88

Expert Comment

by:rindi
ID: 16905437
While the partition isn't mounted run fsck.ext3 (if it is a system partition you might have to be in single user mode). Without options you should get the correct syntax.
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 

Author Comment

by:dwielgosz
ID: 16905478
I'm really green at Linux. Could you tell me how to determine if it's a system partition? And by "single user mode" do you mean open an F1 terminal and log off as root?
0
 
LVL 88

Expert Comment

by:rindi
ID: 16905671
When you boot up there should be a boot menu, and if there is something similar to "recovery" or "disaster" or similar, boot into that mode. Then you are in single user mode. Then you don't need to worry whether this is a system partition or not (System Partition where files needed by the OS are on).
0
 
LVL 22

Expert Comment

by:pjedmond
ID: 16909622
In order to work out which partition is which, type:

mount

after a normal startup, and you'll get a list of your mounted partitions. This also gives details of whick partitions are mounted where:

man mount

for more info.

When booting into 'recovery' mode, you often do this from your 'boot CD'. In which case, the boot process will get as far as the prompt:

linux:

At this prompt, enter either:

1
or
single
and press enter.

You should then boot into safe mode (or single user mode).

Alternatively, you can boot into single mode via your normal 'grub' bootloader. You will need to edit the command similar to:

kernel /vmlinuz-2.4.21-15.EL ro root=LABEL=/

and change it to:

kernel /vmlinuz-2.4.21-15.EL ro root=LABEL=/ single before booting, and you'll boot into single mode.

fsck.ext3 is in the /sbin directory, so you may need to enter the path in full to get it to work:

/sbin/fsck.ext3

This assumes that the /sbin partition is mounted. If the /sbin directory is on sd8, then you ought to carry out the process using your recovery/install CD. This is because, partition repairs should only be attempted when they are not  mounted.

man msck.ext3 in order to find out exactly which options you want to use, although running it without any 'switches', (- switches) should be fine for the first run.

HTH:)

0
 

Author Comment

by:dwielgosz
ID: 16921989
This is what "mount" returns:

[root@REDHAT root]# mount
/dev/sda5 on / type ext3 (rw)
none on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sda3 on /appl type ext3 (rw)
/dev/sda1 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
/dev/sda2 on /u type ext3 (rw)
[root@REDHAT root]#

"REDHAT" is the name of the server btw.
0
 
LVL 20

Accepted Solution

by:
nedvis earned 2000 total points
ID: 17028974
First you have to identify what device is failing on your system.
The error message you were getting states it is  ---->   device sd(8, 5)
Now just open terminal window  and  type following command :

                          cat  /proc/partitions  

This will identify your partitions ( devices )  by their  major and minor character and block device numbers .
In your case it is (8 5)
-------------------------------------
you will se something similar to this ( which I get on my PSlinuxOS PC with two mounted IDE drives ) :  

[nedvis@PCLOS ~]$ cat /proc/partitions
major minor  #blocks  name

   3     0   10022040 hda
   3     1          1 hda1
   3     2    5205060 hda2
   3     5    4104544 hda5
   3     6     305203 hda6
   3     7     401593 hda7
   3    64   20010816 hdb
   3    65    5004688 hdb1
   3    66          1 hdb2
   3    69    4951768 hdb5
   3    70    7499488 hdb6
   3    71    2547688 hdb7

or something  like this  ( ON MACHINES WITH  8  mounted SCSI drives   )

# cat /proc/partitions
major minor  #blocks  name

   8     0   17774160 sda
   8     1    1052226 sda1
   8     2     208845 sda2
   8     3   10490445 sda3
   8    16     976576 sdb
   8    32     976576 sdc
   8    48     976576 sdd
   8    64     976576 sde

-------------------------------------------------------------
You should be able to narow down the list and pinpoint to failing or malfunctioning device
( I think it was your SCSI tape backup  unit )
"journal committ I/O error" basically translates to whether your device is malfunctioning, it isn't mounted , files system is corrupt or simply
device is unavailable for  kernel  to execute scheduled task ( journaling fs every 5 seconds )  

nedvis
0
 

Author Comment

by:dwielgosz
ID: 17050542
"You should be able to narow down the list and pinpoint to failing or malfunctioning device
( I think it was your SCSI tape backup  unit )
"journal committ I/O error" basically translates to whether your device is malfunctioning, it isn't mounted , files system is corrupt or simply
device is unavailable for  kernel  to execute scheduled task ( journaling fs every 5 seconds )"

This really hit it right on target. It is a failing tape drive. The above explanation made it crystal clear for me. Thanks so much for the information and sharing of your knowledge.

Dave  
0
 
LVL 20

Expert Comment

by:nedvis
ID: 17052479
Great!
nedvis
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question