[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 944
  • Last Modified:

Oracle 8.1.6 on Fedora core 4 and php-oci8

URGENT : solution needed today imperatively
First of all excuse my English for my beeing french.
I am trying to install Oracle 8.1.6 client on my Fedora Core 4 (kernel 2.6.16) and I am having problems.
When i launch the runInstaller.sh provided in the Oracle 8.1.6 cd-rom i get the following message :

Initializing Java Virtual Machine from ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre. Please wait...
/media/cdrom/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libzip.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference (libzip.so)
Unable to initialize threads: cannot find class java/lang/Thread
Could not create Java VM

I have been looking over Internet and it seems that the jre cannot be loaded with this kernel.
The problem is that i can't change my kernel release because i have several applications already installed and no much time.
By the way, we have glibc and it says that the glibc.2.1.3 is required, is it really necessary?

Do you know if there is a solution available to make the runInstaller.sh running with the 2.6.16 kernel of Linux (Fedora Core 4) ?
0
jifsoftware
Asked:
jifsoftware
  • 2
  • 2
1 Solution
 
MohanKNairCommented:
Install Java J2RE and Mozilla Plug-in
http://home.gagme.com/greg/linux/fc4-tips.php#rplayer


For Java in  Fedora Core 4
http://www.fedorafaq.org/fc4/#java

0
 
jifsoftwareAuthor Commented:
It doesn't help.
The issue is that the Installer of Oracle lauch the java version given in the cd of Oracle 8.1.6.
I have tried to change the link to a local jre but it doesn't work either.
Please someone help me i can't find any answer on this issue over internet.
Is it possible or not to install the Oracle 8.1.6 client on fedora core 4 with kernel 2.6.16-1.2069

Thanx anyway
0
 
Pradeepgv03Commented:
HI,
I am sorry , I dont know a workaround here.

But one thing what you are attempting is not a certified combination. In this case results will be unpredictable even if you use workarounds to get this run. Suggest you to use a certifed combination and supported Oracle version.

You can refer to Metalink 'Certify&Availability' matrix to see all the certified OS/Database combinations.


Regards,
Pradeep George.
OCM 9i
0
 
Pradeepgv03Commented:
Hi
For documentation purpose you may refer to the following note too (In addtion to certify matrix).

This note lists the symptoms you get when installation of a non-supported combination is tried.
Your error is also there.

See Note 264044.1  Symptoms and Errors When Installing on Unsupported Linux                   Distributions


Pradeep
0
 
jifsoftwareAuthor Commented:
I accepted the answer from  Pradeepgv03 because i couldn't qsolve the problem with the oracle client version 8.1.6.
I just changed the oracle version to be 9i.
Now I have been able to install the client and everything seem to run correctly using sqlplus.
The problem is for the use of oci8. Indeed the only packaged version I know is configured for the instantclient basic version 10.2 and it can't be installed without the 10.2 running.

I am really having troubles to get this working.
So, the problem, is using PHP 5 (or 4) with oci8 extension oracle client 9i on Fedora Core 4 and connect a Oracle 8.1.6 database by the network (VPN).
Anyone can help ?

0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now