Solved

Exchange 2000 OWA page not found when I add a new Certificate.......

Posted on 2006-06-14
7
212 Views
Last Modified: 2010-03-06
GooD Day Experts,

I am trying to add a certificate (just created it by installing Certificate services) to Exchange 2000 on SBS 2000 and OWA becomes incaccessible when I do this.  If i switch back to the old certificate then OWA works fine.  What am I doing wrong?

Many Thanks,

Ellsworth
0
Comment
Question by:ellsworth2000
  • 3
  • 2
7 Comments
 
LVL 16

Expert Comment

by:kshays
ID: 16908462
Not an expert on this, but sounds like it could be a few problems from the sounds of it.

did you create and sign the ssl cert yourself?  If so did you give it the correct fqdn?

If you say there was a ssl cert already in place then why did you add another one?

regards,

kshays
0
 

Author Comment

by:ellsworth2000
ID: 16915118
Thanks for the Reply Kshays,

I assigned a new one because the name of the cert didn't match the name of the site.  Yes i did create and sign the ssl cert myself.

Thanks,

ellsworth
0
 
LVL 16

Accepted Solution

by:
kshays earned 500 total points
ID: 16916971
I've had some problems signing the cert myself also.  If all you are going to do is use ssl for owa then you could probably get by creating your own, but I find that rapidSSL or thawte isn't that expensive and much better imho.

Are you able to successfully issue the cert to the website?  If so you may want to double check that you are requiring a secure connection on the web site and it didn't uncheck it when you removed the old ssl cert.  If those are correct it sounds like there was a problem when you were setting up the ssl cert somehow.

kshays
0
 

Author Comment

by:ellsworth2000
ID: 16946322
Kshays,

I am able to right click the on the website through IIS and go through the steps of assigning the certificate to the website.  And then I can view the certificate afterwards too.  Just when I go to our OWA url, I have a return of:  page cannot be found.  Though I just checked the default website properties in IIS(which currently has the old Cert with the wrong name), the box for require a secure connection wasn't checked and OWA works fine right now.

Thanks,

Ellsworth
0
 
LVL 16

Expert Comment

by:kshays
ID: 16948026
No problem :)

kshays
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now