Solved

Exchange Server 2003 Name Issue - Domain.local

Posted on 2006-06-14
8
385 Views
Last Modified: 2012-06-21
Hi All,

I’m trying to resolve an exchange 2003 naming issue, but was not after to find a solution after research everywhere.

This is what happens, when setting up email account for exchange server.

Under Outlook 2003 -> Email account -> Exchange Server Settings:

If we enter “exchange.domain.com or IP address for the exchange server” -> Click check name, it will find the user account. However, the Exchange name will automatically change to “exchange.domain.local”.

We would like to use either “exchange.domain.com” or “IP address” BUT “exchange.domain.local” for a group of users. But, it just keep changing it back.

Below is some info about our environment

Server name is: exchange 2003 SP1
DC is: Windows 2003
Domain is: domain.local
Exchange server is a member of “domain.local” domain.
OWA and exchange are in the same server.
DNS: exchange.domain.com (DNS should setup correctly)
POP3 and OWA users can use either exchange.domain.com or IP address without problem.

Thank you in advance for all the help.
0
Comment
Question by:bluedan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 3

Assisted Solution

by:ppuro
ppuro earned 150 total points
ID: 16907786
Seems there is nothing wrong here!!!

By default when you configure the user's profile and do check name it will take the exchange server local FQDN name itself.

As while configuring profile it queries to the AD(DC/GC) through local DNS

i.e exchange.domain.local

It will never look for exchange.domain.com.

Regards,

Prasad
0
 
LVL 5

Expert Comment

by:simonpainter
ID: 16907926
That is exactly what is supposed to happen... it changes it to the FQDN of the ex box.

Nothing to see here.
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16908051
As already pointed out, what you are seeing is normal behaviour.
Lets twist the question on its head. What is the goal here? What are you trying to achieve by having something else in that box?

Simon.
0
Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

 
LVL 10

Author Comment

by:bluedan
ID: 16912924
Hi All,

Thank you so much for all of your helps. Here is our goal.

We have a group of users that will need to access the exchange via other domains. Their DNS server can see our "exchange.domain.com" but not "exchange.domain.local. Therefore, if we can somehow make it Exchange Server Settings: looks at  "exchange.domain.com" or "IP address" in stead of "exchange.domail.local" FQDN, then we don't need to configure new DNS for each other domains with "exchange.domain.local." This will save us alots of troubles.

I have tried to remove "exchange.domain.local" from our local ADs (DC/GC) DNS and configure it at exchange.domain.com only. Local AD's DNS has domail.com setup as secondary but this did not work.

I think if we manually added it to the host file it will work, but it'll be too much troubles.

Is there anyway, we can make it this to work??

Again, I want to thank you all for your generous helps.



 
0
 
LVL 5

Expert Comment

by:simonpainter
ID: 16913071
Manually create a zone file in the other domain's dns for domain.local and then add a CNAME (alias) for exchange.domain.local pointing to exchange.domain.com or an A record (host) for mail.domain.local pointing to the IP of the mail server.
0
 
LVL 5

Accepted Solution

by:
simonpainter earned 200 total points
ID: 16913082
Alternatively you can put the IP of the DNS server for domain.local as a forwarder on the other domains that you want to have access.
0
 
LVL 104

Assisted Solution

by:Sembee
Sembee earned 150 total points
ID: 16913629
The name will always change.
That is how Exchange/Outlook is designed. You can put what you like in to the hosts file, the name will always change to the machine's real name.

Are you attempting to go across the Internet?

You sound like an ideal candidate for RPC over HTTPS. This will allow you to use a public name for Internet traffic.

Simon.
0
 
LVL 10

Author Comment

by:bluedan
ID: 16922833
I guess we have to manually add the DNS for all other domains.
I have splited points for everyone. Thank you so much for all of your help.
0

Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question