[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 721
  • Last Modified:

Apache2 configuration for php5 : apxs not found

Hello,

We are trying to install php5 on SuSe 10 OSS. Before this we need to configure Apache for php which is done using ./configure with apxs but in our case I can not located apxs in /usr/sbin directory where apache2ctl is installed.

I have installed 2 different versions of Apache but apxs is still not visible in server, though man pages for apxs are available.

where I run ./configure it says
/bin/sh bad interpreter Permission Denied.

Could you please provide some solution why apxs is not getting installed ?

Many Thanks
Regards
0
Anupama_2005
Asked:
Anupama_2005
  • 2
1 Solution
 
imacgoufCommented:
Is it

# ./configure --with-apxs2=/usr/local/apache2/bin/apxs
0
 
imacgoufCommented:
Just for your reference, here is one on Setting Up PHP 5 Under Suse 9.1
http://www.artima.com/forums/flat.jsp?forum=271&thread=70581
0
 
Anupama_2005Author Commented:
Hello,

I have not yet started with php5 configuration, It gives error while configuring Apache itself

I downloaded httpd-2.0.58 and when I say  

sh ./configure --enable-so

......
......

Configuring Apache Portable Runtime library ...

checking for APR... reconfig
configuring package in srclib/apr now
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
Configuring APR library
Platform: i686-pc-linux-gnu
checking for working mkdir -p... yes
/data2/apache/httpd-2.0.58/srclib/apr/configure: /data2/apache/httpd-2.0.58/srclib/apr/build/get-version.sh: /bin/sh: bad interpreter: Permission denied
/data2/apache/httpd-2.0.58/srclib/apr/configure: /data2/apache/httpd-2.0.58/srclib/apr/build/get-version.sh: /bin/sh: bad interpreter: Permission denied
APR Version:
checking for chosen layout... apr
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
configure failed for srclib/apr

What could be the reason for this ?
Regards
Amit

0
 
GinEricCommented:
/bin/sh is being flagged as a bad interpretor.  I think maybe you need to re-read also :

http://httpd.apache.org/docs/2.2/programs/configure.html#configurationoptions

Here's a typical compile configure that we use:

http://www.Musics.com/Status/38.revert.Bach.08.Apache2.MAPPS.html

Maybe you've confused enable-sockets with enable-shared, because we don't use "enable-so" for the very reason that abbreviations can, and often do, conflict as GNU changes.

You're supposed to disable-static when you use enable-shared also.

More imporantly, you got an Access Denied, which means some directory does not have proper permissions, or, the simple "execute bit" is not set for the script you're trying to execute!  Very likely.  Get /bin/sh properties and see if it even has execute permissions turned on.

The shell script must have permission to execute, by whomever is either installing or compiling, and the configure script must be correct.  and /bin/sh should be in /bin/sh

If you're trying to call it at some other location, it probably doesn't have permission, or, you're calling the wrong shell script.

Look into all I've said.

0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now