Solved

Exchange 2003 - Set As Primary value ignored; not an obvious recipient policy problem

Posted on 2006-06-14
13
609 Views
Last Modified: 2012-08-14
I'm running an Exchange 2003 server which hosts several domains. I'm familiar with the Default Recipient Policy construction and have multiple users that have mulitple email addresses and have differing domain names, all working just fine. At least until I added the most recent domain. The goal was to add support for a new domain and have one user use that new domain as his primary address.

So here's what I did:
* I added the new email address user@new-domain.com to the users AD user account.
* Remembering that I needed to add new-domain.com to the default recipient policy, I went and did that and set this Exchange server as responsible for delivery to this domain.
* I tried sending mail from this user to an external email account.

However, when I receive mail from user@new-domain.com it shows as being from user@domain.com. The user@new-domain.com address is Set As Primary (and is bold in the list) and the magical "Automatically update e-mail addresses based on recipient policy" is not checked. If I change the primary address to user-test@new-domain.com the from address changes to user-test@domain.com. I can create another email address for this user of user@another-domain-hosted-here.com and that works just fine.

If I create an address in my account in the format my-account@new-domain.com, it comes through as my-account@domain.com. If I select my-account@another-domain-hosted-here.com as primary, that works fine.

Oh, if I try sending mail from user@new-domain.com to my-account@domain.com when everything is set how it looks like it should be set, the mail comes through the Exchange server as from user@new-domain.com; it seems that the from header only changes when the mail actually leaves the system and that the problem is only with this new domain.

One final note. I also use ASSP as my spam filtration system. It works great and I suggest everyone use it. Anyway, the maillog of ASSP sees the outbound from as user@new-domain.com, but the receiving server still sees it as user@domain.com. I have tried pulling ASSP out of the mix and there is no change in behavior, from-header-wise. I have also sent mail through several different receiving servers using different OSes and different MTAs.

I've rated this question high due to its difficulty. I know what I'm doing (or at least I think I do!), and I'm stumped!

Any suggestions?
0
Comment
Question by:JWGruener
  • 6
  • 5
13 Comments
 
LVL 12

Expert Comment

by:aa230002
ID: 16908970
Have you also configured your Exchange to receive emails for this new-domain? I mean do you have MX records updated matching to your new-domain.

Thanks,
Amit Aggarwal.
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16908992
Are you sending mails out using ISP(smart host) or directly using DNS? i have seen SendMail or something like that sitting in between and configured to re-write "from" address. There might be something else sitting in between your domain and destination domain. which has the list of all domains hosted in your environment and is also configured to let mails go out from all the domain names listed and re-write "from" address back to "domain.com" if any of the domain is mentioned in the from field which is not there in its list.

Thanks,
Amit Aggarwal.
0
 

Author Comment

by:JWGruener
ID: 16908994
I have created MX records at the external DNS server (Dotster's managing DNS for new-domain). Mail flows to user@new-domain.com, no problem, even through the ASSP filter (also works without the filter, of course).

Thanks,
--Jamie
0
 

Author Comment

by:JWGruener
ID: 16909019
Amit, that's what I was thinking, too. I do send all mail through my ISP's smarthost, but it has never re-written any email addresses before. I've only got ASSP in the middle on my side, and removing it doesn't help things. Also, if the smarthost or ASSP were re-writing addresses, why would the other from addresses work just fine?

I'll try not using the smarthost and see what happens and post back.

Thanks,
--Jamie
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16909027
yes, thats a good idea. Also check with your ISP, they must be having the list of all domains hosted in your environment and might be doing something.

Or simply skip the smarthost and directly send the mail. Hope that will help you find the solution.

Thanks,
Amit Aggarwal.
0
The curse of the end user strikes again      

You’ve updated all your end user’s email signatures. Hooray! But guess what? They’re playing around with the HTML, adding stupid taglines and ruining the imagery. Find out how you can save your signatures from end users today.

 

Author Comment

by:JWGruener
ID: 16909066
I tried sending the mail from Exchange without the smarthost or ASSP in the mix and lo and behold the mail is delivered with the correct from address.

I can't leave things this way because my IP is dynamic and all sorts of folks will reject my mail because of that. That's why send mail out through my ISPs smarthost, which is smtp-server.nc.rr.com, for what that's worth. Also, it's going to be difficult to test with ASSP and without the smarthost because of the way that ASSP works. Hmm...

It seems that RoadRunner is changing my from addresses. How would they even know how to do that? I'm going to have to dig into the MX records, I guess.

Thanks for the tip,
--Jamie
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16909075
You got it. Go after RoadRunner, they should be knowing what they are doing and should be able to answer why?
I think, u just need to tell them the name of your new domain so that they can update their list.

Thanks,
Amit Aggarwal.
0
 

Author Comment

by:JWGruener
ID: 16909081
There's the rub. I've never had any communication with them, ever. If there are other domains of mine on some list, they got there automagically. I'm guessing that the problem is with my DNS records.

--Jamie
0
 
LVL 12

Accepted Solution

by:
aa230002 earned 500 total points
ID: 16909089
Try www.checkdns.net to check your DNS configuration on the internet.
0
 

Author Comment

by:JWGruener
ID: 16909155
CheckDNS doesn't like my DNS settings. The results aren't as clear as I'd like them to be:

While fetching MX list from ns1.nameresolve.com [64.94.117.196], DNS server returned non-MX record, type=5

And the help isn't much better:
Importing now...

However, I think the problem was that I used a CNAME record for the mail server in the MX record. I hadn't known that you can't use a CNAME record in MX data, but apparently that's the case. I've changed it to be an A record but will have to wait for Dotster's DNS to update before I know if that fixed it. Don't know how long that'll be, but I'm hoping it's not too long.

Thanks,
--Jamie
0
 
LVL 12

Expert Comment

by:aa230002
ID: 16909163
You are right. It shouldnt take much time. at most 48 hours in the worst scenarios..

Hope everything would be fine after that.

Thanks,
Amit Aggarwal.

0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
This video discusses moving either the default database or any database to a new volume.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now