• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 648
  • Last Modified:

Disable Safe Mode boot options in W2K


I need to disable the safe mode boot options (particularly safe mode with command prompt) when you press F8 on startup in Windows 2000.  

Can anybody help?
  • 6
  • 2
  • 2
2 Solutions
A. Cristian CsikiSenior System AdministratorCommented:
hi Illuminas,
Here are some tips how to kill save mode. Delete this registry keys:

-HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode
- HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\SafeBoot
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SafeBoot

* Note: before doing this export them, so you can add them back to restore the save mode.

Good luck
This is probably more effective - a beautiful hack for the ntldr:


Obviously make a backup of your ntldr first:)
IlluminasAuthor Commented:
Thanks for this nodramas.

In case others are interested...deleting these registry keys throws up a blue screen if Safe Mode, Safe Mode with Command Prompt, and Safe Mode with Networking are selected.

pjedmond - I would have preferred your solution but unfortunately it didn't work.  Perhaps because the solution was for an XP machine (I'm trying to apply this on W2K SP4 machines).

I'll leave this open for a bit to see if anyone has a cleaner solution than deleting registry keys.
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

A. Cristian CsikiSenior System AdministratorCommented:
I tried my tip and worked on xp. When save mode is atempting to load he automatic restarts and so on. NO blue screen i had.

Other wise people sad tried that before me and worked as well. see :

Regards, nodramas
Looks like some bootloaders have the capability to control keystrokes during boot, which can be used to prevent the Safe mode from being accessed (without a password):


is one that I've found and may offer another avenue to explore?
Not very elegant!:
How do I disable Safe Mode? (NT, 2000, XP)

    Windows NT, 2000 and XP do not have any easy way to disable Safe Mode. However, there is a way to 'break' safe mode temporarily.

    Doing this is not recommended. Proceed at your own risk!
    Click on the Start Button
    Select Run
    Type in "regedit" and hit OK
    Expand the left hand side to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SafeBoot
    Under SafeBoot, you should now see Minimal and Network. Click on them and hit F2 to rename them to "Minimal-" and "Network-", respectively.

    This should cause Windows to crash the next time it is booted into Safe Mode.
Wooohoooo - Progress:

Edit the C:\boot.ini file

There should be a line that says:


or similar.

Change it to:


..and guess what, you get 0 seconds after pressing F8 to select a boot mode. (This effectively prevents the use of F8). Now to work on F5?

OK - I have one working - Not very clean/elegant, but very effective.

Again based arount the ntldr. Obviously, this is all done *AT YOUR OWN RISK*!!!! Towards the end of the file you will see a number of ASCII text elements. (These are the ntldr commands that are passed to the loading process) Unfortunately, not as simple as the one for XP, but combined with thr timeout=0, you may be able to find the one that is triggered by F5. I just changed them all.

Using your favourite hex editor, edit SAFEBOOT and change it to BOOTLOG .

There is a space after the BOOTLOG in order to avoid changing any addresses anywhere else in the program. It may be that you only need to change one of them in order to prevent a direct boot into safe mode.....but I just changed them all!

What this does is change SAFEBOOT to LOGGING:)...hence preventing anyone entering safe mode:)

I'm feeling quite please with that!
IlluminasAuthor Commented:
Hi pjedmond

Sorry I've been away so haven't been able to comment.  Thanks for your suggestions.

I couldn't find boot.ini (I've enabled "see hidden files and folders") - this sounded like the best option.

I found the word SAFEBOOT in ntldr but it just looked like a display prompt - "Press ESCAPE to disable safeboot and boot normally".  I changed the word safeboot to bootlog which caused no difference in my boot options.  I'm sure I'm doing something incorrect here - can you tell me where I change SAFEBOOT to BOOTLOG (my first time using a hex editor with ntldr).


OK - I failed to keep up with this one.

>can you tell me where I change SAFEBOOT to BOOTLOG

Everywhere it appears ensuring that you do not increase or reduce the number of chars in the file.

>I couldn't find boot.ini

A problem in itself?

(   (()
(`-' _\
 ''  ''

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 6
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now