How to POP to Exchange clients e-mail another external POP user?

Hi all,

I have an SBS server using POP to Exchange services (GFI to be exact) to collect and distribute all mail internally, works with no issues.  The issue is when internal users e-mail a person on the outside with the same domain name (This is also a POP account) the following occurs

The following recipient(s) could not be reached:

      'name@domainname.com' on 15/06/2006 11:35 AM
            The e-mail account does not exist at the organization this message was sent to.  Check the e-mail address, or contact the recipient directly to find out the correct address.
            <someserver.server.local #5.1.1>

Now these external users only use POP accounts to recieve their e-mail and do not need to be part of the server or a user.  

I have had this working in the past but for the life of me cannot figure it out.  Anyone have any ideas?

Your time appreciated.
servicadAsked:
Who is Participating?
 
DarthModConnect With a Mentor Commented:
PAQed with points refunded (500)

DarthMod
Community Support Moderator
0
 
g127404Commented:
I've had this problem as well and ended up adding those external users as a local user.  Even if they don't use the exchange mailbox the server needs to see they are valid users in the domain.  There may be a way to set up aliases for those users and skip the actual creation of a mailbox, so we can wait and see if someone else has a better option.
0
 
servicadAuthor Commented:
YEs If you add them as local users then the e-mail gest stuck in Exchnage internally.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Lee W, MVPTechnology and Business Process AdvisorCommented:
It sounds like you named your domain the same as your internet domain.  Not a good idea.  Should have been named "yourdomain.local".  Then you wouldn't have this problem.  The only solution is pretty much what g127404 suggests.
0
 
servicadAuthor Commented:
no it is called server.local  
0
 
servicadAuthor Commented:
As per error message in original post
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Sorry, I initially thought this was similar to a setup I have, but upon further reflection, it's not.  I have a setup where the the domain is .local and I had problems like this.  I suspect you have a recipient policy defined so, among other things, you have e-mail go out correctly.  BUT, in my setup, I only use Exchange for a mail store (WANT it to handle mail entirely, but owners are too paranoid)

Why not use the server as it was meant to be and make it your primary mail server?
0
 
SembeeCommented:
This is a classic problem. Wouldn't matter what your internal domain was called - whether it was a .local or a .com - you would get the same problem.

The basic issue is that Exchange thinks it is responsible for all email for that domain.
Ideally you should have all email delivered to the Exchange server. If you are on any kind of permanent connection then you can easily switch over to SMTP delivery. That will give you a better user experience.

You could look at recipient policy for the domain and deselect the option that says that Exchange is responsible for all email delivery for the domain. That might work.
Otherwise take a look at this page at Microsoft which gives you more options: http://support.microsoft.com/default.aspx?kbid=321721

Simon.
0
 
servicadAuthor Commented:
Thanks Sembee,

Thought that would do the trick but it prevented anyone from e-mail outside the office.  Bummer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.