Solved

MS Virtual Server 2005 R2, Cannot access the Administration Website

Posted on 2006-06-15
13
465 Views
Last Modified: 2008-01-09
I have installed VS2005 R2 on a Win2003 server with no errors. When I try to open the Admn Website I get "You are not authorized to view this page" msg and HTTP Error 403 - Forbidden: Access is denied. Is this an issue with IE, IIS or VS2005 security? I initially got a logon screen and logged in as administrator.

Any help would be appreciated.
John
0
Comment
Question by:johnconti
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
  • +1
13 Comments
 
LVL 84

Expert Comment

by:oBdA
ID: 16916280
Are you starting the admin page from the machine itself while being logged on through RDP? Then add the URL you're accessing to the list of trusted sites, and make sure that "Automatically send logon credentials" (or similar, not using an English version) in the IE settings is set to "Trusted Zone only"; in other words: make sure the logon dialog pops up, do NOT use automatic logon.
0
 

Author Comment

by:johnconti
ID: 16917096
I am trying to connect on the same machine that VM2005 is installed on.  I am not logged on through RDP. I am not using automatic login.

The login address is:   http://dell-xps2.jc.lcl:1024/VirtualServer/VSWebApp.exe?view=1 
0
 
LVL 12

Expert Comment

by:GinEric
ID: 16925533
Interesting, I had that problem until I initialized IIS.  In the Internet Information Servics [IIS] manager, once I added a website, www2, set the port to 8080, it worked.  Although neither the default website nor the www2 one is actually started or running [Apache2 is running on port 80 though].

I also put in the real computername as host.domain.tld, rather than localhost or the way you have it, then, simply calling an http of computerame.domain.tld:1024 brought up a login prompt.  With the proper credentials, it logged right in.
Execute for scripts permission had to also be on, I believe, in the properties of the default and www2 websites.  What you have above is also an executeable, VSWebApp.exe with the question mark followed by the view=1, which tells the virtual server which script to execute; fairly sure of that.

You should have gotten a login prompt; if not, it's your IIS Configuration, probably for that site, which, in our case was not default, rather, www2, even though that is not even used and both the default and www2 are not even running.

Strange way to configure it, but it works.

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:johnconti
ID: 17065273
Sorry for not getting back sooner, this project had to wait.  Since then I installed VM on another Win2003 server set up as a member server and the VM Admin website worked fine. I also did the following:
- Checked the IIS security settings on both and they matched
- Created a website on IIS on the bad server and it worked fine, but VM Admin still not working
- Execute script permission was set to on

Is there a problem installing VM on a DC?

Any ideas would be appreciated!
John Conti
0
 
LVL 88

Accepted Solution

by:
rindi earned 250 total points
ID: 17065285
Probably there is a problem when installing on a DC. I don't use the m$ stuff though, I prefer vmware, much better. Anyway, even vmware warns you when you try to install on a DC, I guess the m$ version just "forgets" to warn you.
0
 

Author Comment

by:johnconti
ID: 17065359
Thanks rindi, I will try uninstalling and reinstalling VS. Maybe this could solve the mystery.
0
 
LVL 12

Expert Comment

by:GinEric
ID: 17066795
Installed Virtual Server again; this time the 64-bit version.  no problem, except that I had to configure the port.

"You are not authorized to view this page" we get this whenever we create a new directory and try to access it.  Permissions to do with whether or not you're allowed to browse as a directory, or, whether or not you have a default index page [index.html index.php index.asp and so on].

We get it both in IIS and Apache.  It is Windows security that is preventing it.  Most likely the DCOM or other permissions under Component Services and the various user, group, and application permissions.

The only time we find this problem is when the server is given the Domain Controller role.
0
 
LVL 88

Expert Comment

by:rindi
ID: 17160790
Johnconti, what's the status?
0
 

Author Comment

by:johnconti
ID: 17164998
Demoting the server to a member server fixed the problem.
Thanks for your help,
John
0
 
LVL 88

Expert Comment

by:rindi
ID: 17165590
your welcome
0
 
LVL 12

Expert Comment

by:GinEric
ID: 17166573
Makes sense; you give it role of Domain Controller, then install whatever webserver, no one has permissions.  You demote it, but now your webserver is in the registry, so the new role recognises it.  Understand the dichotomy here?
0
 

Author Comment

by:johnconti
ID: 17167886
I do. Fortunately I have other DC on the network to takeover the roles.
Thanks,
John
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Changing the installation path of this MSI 5 119
Windows 8 rebooted without shutting down first error message 11 122
Windows 8.1 HP issues 11 95
Mac printing problem 1 41
In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question