Solved

Cisco pix 506e opening port 444

Posted on 2006-06-15
3
574 Views
Last Modified: 2013-11-16
HI Experts,

I have question if someone can see if this will open ports 444 on my Pix.
here's the config file I want to use
this is what I'v come up with so the users that VPN in and can access our sharepoint server

static (inside, outside) tcp interface 444 10.10.10.X 444
access-list outside_in permit tcp any host XX.147.8.82 eq 444
access-group outside_ in in interface outside

.

here's the cisco config

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxencrypted
passwd xxxxxxxxxxxxxencrypted
hostname pixfirewall
domain-name My domain .con
fixup protocol dns maximum-length 1500
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
no names
name 10.10.10.2 XXXXX Web
name 10.10.10.8 XXXX demo
name 10.10.10.7 XXXXXX demo
name 10.10.10.9 XXXXXX demo
name 10.10.10.6 XXXXXX book
object-group network Web
  network-object 10.10.10.2 255.255.255.255
  network-object 10.10.10.7 255.255.255.255
  network-object 10.10.10.8 255.255.255.255
  network-object 10.10.10.9 255.255.255.255
  network-object 10.10.10.6 255.255.255.255
object-group service FTPGroup tcp
  description FTP and FTP-Data
  port-object eq ftp-data
  port-object eq ftp
object-group network Web_ref
  network-object XX.XXX.8.51 255.255.255.255
  network-object XX.XXX.8.52 255.255.255.255
  network-object XX.XX.8.53 255.255.255.255
  network-object XX.XX.8.68 255.255.255.255
  network-object XX.XXX.8.69 255.255.255.255
access-list outside_access_in permit icmp any any
access-list outside_access_in remark Web Access
access-list outside_access_in permit tcp any object-group Web_ref eq www
access-list outside_access_in remark Web Access
access-list outside_access_in remark Mail Access
access-list outside_access_in permit tcp any host XXX.XXX.8.51 eq smtp
access-list outside_access_in remark For PPTP Tunnel
access-list outside_access_in permit gre any host XXX.XXX.8.51
access-list outside_access_in remark For PPTP Tunnel
access-list outside_access_in permit tcp any host XX.XXX.8.51 eq pptp
access-list outside_access_in remark POP3 opened for Blackberry
access-list outside_access_in permit tcp any eq pop3 host XXX.XXX.8.51 eq pop3
access-list outside_access_in permit tcp any hostXXX.XXX.8.69 eq www
access-list outside_cryptomap_20 permit ip host 10.62.100.10 192.168.45.0 255.25
5.255.0
access-list inside_access_in remark Default Outbound
access-list inside_access_in permit ip any any
access-list inside_outbound_nat2_acl permit ip 10.10.8.0 255.255.252.0 192.168.4
5.0 255.255.255.0
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside XX.XXX.8.82 255.255.255.128
ip address inside 10.10.8.1 255.255.252.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.10.10.2 255.255.255.255 inside
pdm location 10.10.10.7 255.255.255.255 inside
pdm location 10.10.10.8 255.255.255.255 inside
pdm location 10.10.10.9 255.255.255.255 inside
pdm location 192.168.45.0 255.255.255.0 outside
pdm location 192.168.45.0 255.255.255.128 outside
pdm location 192.168.45.128 255.255.255.128 outside
pdm location 10.10.10.6 255.255.255.255 inside
pdm group Web inside
pdm group Web_ref outside reference Web
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 10.62.100.10
nat (inside) 2 access-list inside_outbound_nat2_acl 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) XX.XXX.8.51 10.10.10.2 netmask 255.255.255.255 0 0
static (inside,outside) XXX.XXX.8.52 10.10.10.7 netmask 255.255.255.255 0 0
static (inside,outside)XX.XXX.8.53 10.10.10.8 netmask 255.255.255.255 0 0
static (inside,outside) XX.XXX.8.68 10.10.10.9 netmask 255.255.255.255 0 0
static (inside,outside) XX.XXX.8.69 10.10.10.6 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 XX.XXX.8.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.10.8.0 255.255.252.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set pfs group2
crypto map outside_map 20 set peer XX.87.52.69
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp enable inside
isakmp key ******** address XXX.XX.52.69 netmask 255.255.255.255 no-xauth no-conf
ig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.10.8.0 255.255.252.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
console timeout 0
dhcpd address 10.10.8.2-10.10.9.1 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside

Thanks Again Experts

phishman out :)
0
Comment
Question by:phishman1000
  • 2
3 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
Comment Utility
>this is what I'v come up with so the users that VPN in and can access our sharepoint server
If users VPN in then you don't need anything like nat or access-list or any changes to the PIX. If the VPN users can't get to the portal now, then it is a configuration problem either on the VPN server or on the Sharepoint server, not the PIX.

Your proposed config changes will allow anyone on the Internet to access your sharepoint on port 444
0
 

Author Comment

by:phishman1000
Comment Utility
Irmoore,

yeah thats not what I want. thought maybe since the users vpn in they should already have access....but the pix was blocking the port.
yeah I'm new to sharepoint so I'll give that a whirl. I 'll let you know the outcome.
0
 

Author Comment

by:phishman1000
Comment Utility
Irmoore,
you're right it was a config issue had not put the (A) record in dns....doh!, everything works now.
thanks again experts,
phishman out!!
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
VLAN ip for Cisco switch 11 55
Hardening ScreenOS 8 64
Cisco Layer 2 Switches 6 48
Route summarization 9 40
This article assumes you have at least one Cisco ASA or PIX configured with working internet and a non-dynamic, public, address on the outside interface. If you need instructions on how to enable your device for internet, or basic configuration info…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now