Solved

OMA problem with first configuration

Posted on 2006-06-16
4
251 Views
Last Modified: 2010-03-06
Hi

I have Exchange and OWA running ok.
I have activated Mobile Access at Exchange System Manager/Global Settings folder/Mobile Services and the Enable Outlook Mobile Access and unsuported devices are enabled.
About IIS Manager, the OMA folder has unchecked SSL require, and basic and integrated authentify...
I have reseted IIS "iisreset" command
Then I try http://server/oma and get this message
"A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator"

I think I have all the requeriments activated... Any ideas?

Thank you
0
Comment
Question by:isaacmateo
  • 2
4 Comments
 
LVL 3

Expert Comment

by:htgits
ID: 16919749
Check the authentication settings on the virtual directories. They need to be:

/exadmin: Integrated ONLY
/exchange: Integrated and Basic ONLY.
/exchweb: Anonymous ONLY.
/Microsoft-Server-ActiveSync: Integrated and Basic ONLY
/OMA: Basic ONLY.


If any of these are different you will find that OMA will not work.

Hope this helps
Andy
0
 
LVL 104

Accepted Solution

by:
Sembee earned 400 total points
ID: 16920191
Does the /exchange virtual directory have require SSL enabled? That can break the feature as well.

What happens if you browse to oma with a regular desktop Internet Explorer? Make sure that you have show friendly http error messages turned off so that you can see the real error message.

Simon.
0
 

Author Comment

by:isaacmateo
ID: 16926550
Hi all,

Htgits, I have all options exactly like you have wrote but does not work

Sembee, I have disabled Require SSL at Exchange server an it works! But I would like to protect this for OWA https access. How can I do that?

Thanks both
0
 
LVL 104

Expert Comment

by:Sembee
ID: 16926645
You cannot have require SSL enabled on the /exchange virtual directory if you want to use mobile devices.
It doesn't stop you from using SSL - just means you cannot force enforce it.
If you want to force users to use SSL, then simply block port 80 on your firewall. As long as http traffic works internally the feature will continue to work.

If you have users who are simply too lazy to type in the https:// bit, then setup a redirect on your public web site that redirects to the secure web site.
So http://www.domain.com/exchange redirects to https://mail.domain.com/exchange

With some clever code you could even put a redirect on to send mobile users to the OMA version automatically.
http://www.amset.info/exchange/owa-redirectpages.asp

Simon.
0

Featured Post

Why won’t your email signature format correctly?

Struggling to get your corporate email signatures to format correctly? Does the logo keep resizing? Is the text appearing too big? What can you do to prevent this? Find out how you can save your signatures today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now