Solved

USB to IDE Internal Hard Drive Access

Posted on 2006-06-16
23
1,500 Views
Last Modified: 2016-06-27
Ok, here is the scoop....I have an XP machine that crapped out and will not boot, I took out the internal hard drive and purchased an USB/IDE cable to connect to a good XP machine.  The good XP machine will recognize the drive but when I click properties it shows "full" and will not open to see the files.  I am trying to extract my data (pictures docs etc) off drive, after that I don't care about it.  It is Western Digital WD400BB.  I have it set to master.  Any ideas?
0
Comment
Question by:precision
  • 8
  • 4
  • 4
  • +5
23 Comments
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
With WD drives, there is a separate jumper setting "Single" which is used when the drive is used by itself.  "Master" on these drives implies there is a "Slave" connected on the same cable.
0
 
LVL 87

Accepted Solution

by:
rindi earned 500 total points
Comment Utility
Use getdataback to recover the data, the best recovery software. You can scan the disk using the freetrial, but the scan will take a long time. When you know what you can recover, you need to register the software to actually get the software.

http://runtime.org
0
 

Author Comment

by:precision
Comment Utility
Callandor....I see 5 settings:
CS
SLAVE
MASTER
"BLANK"
PM2
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Remove the jumper entirely for Single drives: http://www.westerndigital.com/en/library/eide/2579-001037.pdf
0
 

Author Comment

by:precision
Comment Utility
ok, I took the jumper pin out all together and when I go into "My Comuter" the total size and free space there is nothing, when I double click it, it just does nothing.  Drive is running since there is a power cord that goes with USB/IDE cable.  My Computer sees the drive but I cannot view anything..HELP
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
You should try the GetDataBack product mentioned by rindi.  If it still can't see the files, you'll have to install the drive as a slave on the IDE cable instead of using an IDE-USB interface.
0
 
LVL 70

Expert Comment

by:garycase
Comment Utility
There's a possibility your USB-IDE controller requires cable select.   Jumper pins 1 & 2 on the drive and see if that resolves this for you.   (the external USB interfaces have their own IDE controllers; and you have to match their requirements)

If not ...  the best success rate for recovering data from a drive is when it's hooked up directly to an internal IDE controller as the only device on that controller.   The best recovery product for a functioning drive is GetDataBack, as already suggested.   So you're already on pretty much the right track here.

I'd recommend you do the following:

(1)  Open up the good XP machine and simply unhook the IDE connector from the optical (CD/DVD) drive(s).   This should give you an IDE cable with nothing connected to it ==> connect it to the disk drive you want to recover data from (use the end connector).   You can leave pins 1&2 jumpered (as above) or pull the jumper to set it as a single master (try both).  Don't forget to connect a molex power connector.

(2)  If that works and you can "see" the drive, you're basically done.   If not, try GetDataBack and see if it can see your files.     ... if you can "see" the drive, but can't access the directory tree, you probably just need to "take ownership" of the file structure.  Post back if you need help with this.

0
 
LVL 11

Expert Comment

by:knoxzoo
Comment Utility
I went through probably a dozen of those USB2IDE cables before deciding they're complete crap.  Another great idea gone horribly wrong.  Most of the external cases that connect via USB work, but the all in one cable sets were a complete waste of time.  

WD's can be a real problem when working via USB.  Using the same external case, I've had WD's that wouldn't work if they were jumpered to Master.  I've had them not work if left unjumpered as a single drive.  There doesn't seem to be a rule of thumb with WD drives and externals.  You just have to play with it 'til you get it right.

garycase and Callandor have you steered in the right direction.
0
 
LVL 5

Expert Comment

by:Silly_Burrito
Comment Utility
If nothing else, connect that drive as a slave, and try booting with a BartPE disk to see if you can possibly view the files though that and move them over to the good drive. That's worked for me quite a few times. You can also burn a CD with your files with BartPE and the proper plugin. I recommend the Ultimate Boot Cd for Windows for this job.
0
 

Author Comment

by:precision
Comment Utility
Thanks all...I will not be able to try till monday morning so any other hints, tips or experiences would be helpful and I can read and digest over weekend...thanks a bunch
0
 
LVL 44

Expert Comment

by:scrathcyboy
Comment Utility
Go back to the drive jumpering the way you had it, your first situation was just a permissions issue, not a drive recognition issue that you have now created.  Once your setup is back to original, as you said --

"The good XP machine will recognize the drive but when I click properties it shows "full" and will not open to see the files"

Then open windows explorer, file manager that is, and choose tools, folder options, view, and in the last checkbox, "use simple file sharing", uncheck this box.  Close file explorer, reopen it, and go to the USB drive with the IDE hard disk you want to get the files from.  Right click, choose, take ownership (this assumes on the new drive you have admininistrator privileges) and take ownership of the drive.  Now you will see all your files.  Copy them off to a local hard disk, and in future, realize that a USB drive is prone to this kind of "ownership" problem, which is rooted in the NTFS file assumptions that someone owns the files and that no one else can get to them -- that is a ridiculous assumption for a single user PC -- but then again, that is the MS mentality that everyone struggles with, it does not make sense to normal people.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:precision
Comment Utility
I am not too sure what you mean about "file manager", is the "my computer"?
"display simple folder view in explorers folder list"

I don't see "use simple file sharing"

0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Have you checked getdataback from the link I suggested? If it can see the files then you just have to register it to copy your data off from the disk.
0
 
LVL 2

Expert Comment

by:SaxicolousOne
Comment Utility
Ah, I see what scrathcyboy is getting at. I would not have thought of that. Precision, to turn off simple file sharing, click Start and then click on My Computer. Now at the top of that window, click Tools -> Folder Options... Now click the View tab and scroll all the way to the last item of the Advanced settings, and uncheck "Use simple file sharing (Recommended)". Just remember to turn simple file sharing back as soon as you have successfully taken ownership of the drive or files in question. Otherwise, when you start moving things around, they will not automatically take on the normal permissions for their destination and things could get weird allover again. One thing I'm worried about: will this work on XP Home, or just XP Pro? If there is no option to take ownership or no "Security" tab when you click on the properties for that drive (with simple file sharing turned off), you'll just need to take ownership while in safe mode. XP Home will let you do that. Once you take ownership of the drive and all its contents, you'll have it whether in safe mode or not.

Silly_Burrito's idea about some bootable CD is also a pretty good way to get some idea of what is going on. For example, I know a live Linux CD shouldn't respect the whole NTFS permissions thing, so you could, for example, boot into Knoppix to at least try to LOOK into the drive. If you can't see your data then, there really might be some sort of hardware problem.
0
 
LVL 70

Expert Comment

by:garycase
Comment Utility
As I noted above, if you can "see" the drive but not access the files, you need to "take ownership" of the files.   Disabling simple file sharing is only applicable to XP Pro.   If you're using XP Home you MUST boot to Safe Mode using an account with admin privileges.   You will then have a Security tab that allows you to "take ownership."   You simply right-click on the drive or folder that you need to take ownership of, select Properties, click on the Security tab, and "take ownership."   If you are using XP Pro you can do this from "normal" mode as long as the account has admin privileges and you have disabled simple file sharing, as noted above.   As I said before, "... Post back if you need help with this."   You can read the details here: http://support.microsoft.com/?kbid=308421
0
 

Author Comment

by:precision
Comment Utility
Ok, I put the pin back to master, I went in and "turned off simple file sharing", I closed "my computer", I opened it back up (takes forever) and again I see the drive but it shows nothing in column "total size" and "free space".  When I right click (takes forever) there is no "security tab" in the properties.  I have XP Pro.

Also, if this helps, when I go into properties under file type it states "RAW", not sure what that means.

I just downloaded "GetDataBack" and will run through and see how it can help??

Or should I just ... "Open up a good XP machine and simply unhook the IDE connector from the optical (CD/DVD) drive(s)."  ???
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Hooking it up directly to an IDE cable is preferable and will give you the best chance at recovery.
0
 

Author Comment

by:precision
Comment Utility
I hooked up to good XP machine, I took IDE cable off of floppy and also hooked up power cable, I used IDE from floppy drive.  I used master, slave, cable select computer but did not see the drive ???  Each time I rebooted too.  I have to be hooking something up wrong here.

Should I go back to the "GetDataBack" and try that?
0
 

Author Comment

by:precision
Comment Utility
Oops not floppy, I used spare IDE cable...should I disconnect the CD drive?
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Yes, use getdataback with your new setup with the disk on the other cable.
0
 
LVL 2

Expert Comment

by:SaxicolousOne
Comment Utility
Precision, you say that even though you have simple file sharing turned off, "When I right click (takes forever) there is no "security tab" in the properties.  I have XP Pro." You mean you can't: right click -> Properties -> Security? Now I'm slightly more worried than before that there might be something weird going on, but perhaps not--note that this does have to be done from an Admin-level account....

Also, I wonder if the "takes forever" thing might be relevant?
0
 

Author Comment

by:precision
Comment Utility
BINGO...GetBackData did it....with USB/IDE cable...FANTASTIC.....!!!

Look for my new question....thanks!
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Glad you saved the data.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

What happens if your PC crashes? What would you do if your MacBook® computer is stolen? What if you accidentally drop and shatter your cell phone? Without a backup plan, you could lose all your music, all your videos, and all of your financial docum…
WDLabs is proud to engage with makers and innovators creating projects of their own. As a part of this outreach, WDLabs provided the Honey Bee Gardens Hive Project with free WD PiDrive 314GB test samples. Take a look to find out more about this elec…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now