Solved

XP work stations randomly loose connection to mapped drive on Win2k server

Posted on 2006-06-16
11
356 Views
Last Modified: 2008-02-01
The Server is up and running and is used for a single Database / app. The Server is used for a timekeeping/patroll system. The system needs to have data imported to it on a biweekly schedules. Lately, the workstation that does the importing will randomly loose connection to the mapped drive on the server. When I disconnect the mapped drive and go to reconnect it, I get an error:

The mapped Drive could not be created because the following error has occured: The specified server cannot perform the requested operation.

The server also shows a similar error when trying to log into it. It's like it goes a week and then chokes on the network credentials and you cann't log in. The web based timekeeping app works no problem. Right now, the mapped drive haves dropped and I can't reconnect, but the server was open, so I have the desktop.

Couple of other things about this server.

The event viewer logs go blank after I open the event vewer, so I can't see any errors that might have occured. I am in the process of dumping the corrupted logs and restarting it so it creates new logs. I hope this will fix that issue.

Also, a couple of weeks ago when this server started to act funny, I noticed that the C:\ drive was low on space. - really low. I ghosted the server and resized the partition in the process. I have about 7gb of space on C:\ now so that is no longer the issue.

Could it be a failing Nic?

Please help.
0
Comment
Question by:alexmauer
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 26

Expert Comment

by:jar3817
ID: 16922363
Are the clients accessing this server by a dns name or by IP address? If by dns, what is your dns setup? Do the clients and server all use internal resolvers, external (isp's) resolvers, or a mix of both? If anything but internal, I would suggest you include only nameservers that can resolve your internal dns names. When you mix internal and external dns servers sometimes you get an answer for an internal name and sometimes you don't depending on which server is queried.

It might not be dns related, but it's something to check.
0
 
LVL 30

Expert Comment

by:ded9
ID: 16922366
It seems the server is being infected or files are corrupted reinstalling the server is the only best option.
Reps
0
 

Author Comment

by:alexmauer
ID: 16922390
I just tried to use net use to map the drive, but I get error 67 - The network name cannot be found. I tried the IP address and the Server name

I can tracert and ping the IP address and the Server name
0
 

Author Comment

by:alexmauer
ID: 16922461
Well, I thought about the server being infexcted, but I have run a litney of tests on this server and I cannot find any indication of corruption or infection. The partition being low on space was my fault and I actually did an anaylsis of the files on the c:drive and the totals matched the size of the drive.

This all started to occur after I did an upgrade to an ADP system that works in concert to this system. Prior to this, the machine plugged along without an issue.

I am pretty religious about patching and scanning and I use 4 good tools that will always find something if it is there. The mache has not crashed once.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 16924165
Interesting, usually in this situation you get a #53 The network path cannot be found.
I wouldn't be rebuilding the server, at least not yet. That's a little drastic. I suspect the problem is the workstation not the server. A few things I would recommend.
On the XP workstation:
-verify "allow the computer to turn of this device to save power" is not enabled on the network adapter, under power management, in the NIC's properties in device manager
-if trying to manually re-map first run  
  net  use  /persistent:no
  net  use  X:  /delete
  then see if you can remap
-verify DNS is configured properly, with only your internal DNS server listed on the NIC's TCP/IP properties, i.e. no ISP DNS here.  ISP's DNS should only be listed as a forwarder in the server's DNS configuration
-If there is a possibility of a name resolution issue try as a test adding an entry in the LMHosts file  {%WinDir%\System32\divers\etc\lmhosts }  If not familiar with LMHosts advise and we can elaborate.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 30

Expert Comment

by:ded9
ID: 16925262
Upgrades and patches instead of solving creates new problems in the system. Check if any recent upgrades are available for your server. It seems like the upgrade or patch didnt worked as expected for your system.
The only way out is backup all data as fast as possible and reinstall the server.
Or check out for latest upgrades.
Reps
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 250 total points
ID: 16926424
Sorry, alexmauer, I missed the last part of your question "Could it be a failing Nic?". The disconnected drives could definitely be that as well. Is it possible, after checking power settings, to disable or remove the NIC and try another?
0
 

Author Comment

by:alexmauer
ID: 16936942
Ok last wrinkle.

I noticed that the mapped drive dropped this weekend. so I tried to connect to the server from home using remote desktop connection.

I got in to the signon screen, so there was some communication going on. When I signed on with the correct user and pass, I go this error.

"The System cannot log you on due to the following error:

The network request is not supported.

Please try again or consult you system administrator"

I tried adding anew nic card, but I had some issues. I have a embedded nic on th emother board. I thought I could simply disable the suspect nic and add the new one, but something screwed up and the new on showed up and then disappered. It had somehow gotten mixed in with the existing one and then I los communication. I uninstalled the drivers and removed the nic and rebooted and then all was fine.

I will try it again but delete the existing nic first.

The rebuild vs fix argument. I cannot find anything that would indicate infection of virus or corruption.

I've run to date:

Symantec Corp 10 (latest dat)
TrojanHunter - Lic version
xoftspy
Adaware
Spybot S&D
stinger
McAfee
hijack this
panda

I get nothing but clean results. I've poured over the sys32 dir and there is nothing that seems off. I really think itsa simple nic card failer.

Has anybody seen the above error before? Is it an indication of lost connectivity or impared connectivity?

I really want to avoid rebuilding the server as the system it's used for is a complex one. I do have backups of everything.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 16938630
The 3 solutions I have heard for that error are:
-Re-start the system
-Install all Microsoft updates
-Run Spyware removal tools, specifically Microsoft Defender:
   http://www.microsoft.com/downloads/details.aspx?FamilyID=435bfce7-da2b-4a6a-afa4-f7f14e605a0d&displaylang=en

Non are terribly convincing to me  :b
0
 

Author Comment

by:alexmauer
ID: 17123307
It was a failing NIC driver. I reinstalled the drivver and this puppy has been running like a champ
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 17123375
Thanks alexmauer, glad you were able to resolve.
--Rob
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Connect to wifi using GPO 6 61
Email Domain Transfer 2 34
Backup UPS - email alert 3 83
Nic to NIC 5 46
Some time ago I was asked to set up a web portal PC to put at our entrance. When customers arrive, they could see a webpage 'promoting' our company. So I tried to set up a windows 7 PC as a kiosk PC.......... I will spare you all the annoyances I…
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now