Solved

Using Port 3390 on Remote Desktop Control

Posted on 2006-06-16
15
10,452 Views
Last Modified: 2013-11-29
I changed an XP machine to use port 3390 for Remote Desktop Control.

I can easily connect within our network to the machine's internal IP address.

But from outside using our external ip address:3390  - I cannot connect.

In the router, I put in 3390 in the port forwarding, using UDP and TCP.

What do you think I missed?
0
Comment
Question by:jimmysupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
  • +4
15 Comments
 
LVL 77

Expert Comment

by:Rob Williams
ID: 16924474
There are a couple of ways to do it on the router.
-If you can redirect external ports to internal ports you can avoid having to make the registry changes on the XP machine, to change the listening port on the workstation. You simply direct external port 3390 to internal <appropriate IP> and port 3389.
-if you don't have that option redirect port 3390 to <appropriate IP> port 3390

Neither answers your question though <G>
You can test your port forwarding by going to http://www.canyouseeme.org from the appropriate computer and testing for the appropriate port.

If blocked, verify you do not have any ports blocked by a firewall such as the Windows firewall. When you enable remote desktop it automatically configures the firewall for port 3389, but not 3390. Test by disabling the firewall. If resolved re-configure the firewall on that computer for that port.

One other possibility; assuming you have port 3389 configured and working properly your router configuration method is correct but numerous people have reported problems with using side by side ports on some SOHO routers. Try switching to port 3391, i.e. space them out by at least 2 ports.
0
 
LVL 15

Expert Comment

by:nprignano
ID: 16924665
depending on the router, you may also have to allow traffic on port 3390.  i know for a fact that you have to do that for watchgaurd firewalls, so its a possibility.


nprignano
0
 
LVL 2

Expert Comment

by:usurper_ii
ID: 16924774
I agree with RobWill on testing the port with something else just to make sure it is getting through...and then go from there.

You can also use the TinyWeb server (a less than 40k web server you can configure to use any port) and a web browser to easily test ports. There are simple, easy to follow instructions here:

http://www.quest4.org/etc/tinytest.htm

Usurper_ii

0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 
LVL 30

Expert Comment

by:ded9
ID: 16924832
hi pal
Okay i had this issue in my own machine.
Reason: You cannot connect because
1. windows firewall issue or other firewall installed
2. Unisntall any proxy servers running in the machine .

Solution : If the ports are forwarded correctly then
1. First get your internet ip of the server machine by http://www.whatismyipaddress.com
2.If your are connecting from outside the network the best option woul be "remote desktop web connection"
The article link is here
http://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx
The above link is the best way to connect computer from external network
Also check www.portforwared.com
If any doubts after reading the above link please let me know
But i am sure the above solution will resolve all your problems

Reps

If the above solution helped to solve  your problem please appreciate my work by providing points  


0
 
LVL 30

Expert Comment

by:ded9
ID: 16924836
Sorry it is www.portforward.com
0
 
LVL 22

Expert Comment

by:p_davis
ID: 16925137
what model/kind of router/firewall are you using ---this would be helpful in solving the issue..
0
 

Author Comment

by:jimmysupport
ID: 16925225
I am using Windows XP Remote Desktop Connection.

I am using a Belkin Pre-N Router.

I have one machine using the default 3389 - and it connects from off premise just fine.

I changed the port in the Registry to 3390 and tested in within the building and it works fine thorugh XP Firewall and all.

the article by Northup is almost exactly what I did to make the first one work.

This one was done the same...except I changed the XP Machine to listen on 3390.

The portforward.com site is very nice, but offers no solution to this issue, thanks, though for looking at my issue.

It may be the "spacing out" issue, I will have to try that.

0
 
LVL 30

Expert Comment

by:ded9
ID: 16925234
what is the ip address you are using  to connect the computer from external network. Is it the inernet ip
0
 
LVL 30

Expert Comment

by:ded9
ID: 16925281
http://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx
did u read the above link on setting
"Remote Desktop Web connection"
0
 

Author Comment

by:jimmysupport
ID: 16925542
Yes, read the article..and as I said I did almost everything exactly as he wrote for the first connection and the only thing different on the second is that i set the listening port to be 3390.

Yes, I am using the Internet IP - when I use it for the 3389 machine, it works fine, when I add the :3390 it won't connect.

But, inside the building - it does.
0
 
LVL 44

Expert Comment

by:scrathcyboy
ID: 16925617
You have to assign the computer a static IP in the range of the x.x.A.X domain structure, and whatever that IP is, you have to forward the port in the router to that static IP.  Also in the IP setup of the system with the static IP, you must specify the gateway as the IP address of the router, once again, must be static.
0
 
LVL 30

Expert Comment

by:ded9
ID: 16926040
okay in your tcp configin network connections  have u added static ip ,subnet and the gateway ip to the computer also add prefered and  alternative dns server . Also give particular ports access from windows firewalls. I had the  exact same problem after a lots of trial and error method i had it solved.Also i had the problem wtih port not getting forward so i set it in DMZ zone and it worked. You can also try putting the router in DMZ zone and try to access from external network. Also there is a possibility of isp blocking particular ports.

Reps
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 500 total points
ID: 16926404
In my "humble" opinion, you obviously know how to set this up as you have port 3389 working on one machine. Therefore, I would assume you have done 3390 correctly. The one thing that is different is the registry changes and you have verified that. However, as I mentioned earlier the Windows firewall (or any other such as Symantec, ZoneAlarm, McAfee, etc.) would have to be configured manually for port 3390. If you haven't done so already switch it off, for testing, or add the new port exception. To do so open he firewall; control panel | Windows firewall | Exceptions | Add a port
Make sure you you also click change scope and select "any computer (including those on the Internet)"
0
 

Author Comment

by:jimmysupport
ID: 16928043
I changed it to 3391 - just to be safe..not that.
It was your idea Robwill.....I added the port to the Windows firewall...I put
Name Remote - 3391 tcp
and also
Name Remote2 -3391 udp
I also added in the internal address as running the RDC  under the LAN tab of the Windows Firewall.

Thanks everyone for your ideas. Best $50 I ever spent!
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 16928057
Thanks jimmysupport, glad you were able to resolve.
--Rob
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question