Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

SELECT permission denied on object

Posted on 2006-06-16
5
Medium Priority
?
837 Views
Last Modified: 2008-01-09
Hi, i have an ASP application that i am using against an SQL Server 2000 box.  This application worked fine on access but when upsized to SQL2000 i now have the following error...


Microsoft OLE DB Provider for ODBC Drivers error '80040e09'

[Microsoft][ODBC SQL Server Driver][SQL Server]SELECT permission denied on object 'tblAnalytics', database 'live_xxxx', owner 'dbo'.

/process.asp, line 54

*****************
Line 52: Set RS = Server.CreateObject("ADODB.Recordset")
Line 53: SQL = "SELECT * FROM tblAnalytics WHERE ID = 0"
Line 54: RS.Open SQL,Connection,3,3

I have gone into SQL server and put permissions on everything i can find in that DB for the account that i have set up.....

Still not working,

Any Ideas?

Thanks

0
Comment
Question by:net-workx
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 75

Accepted Solution

by:
Anthony Perkins earned 2000 total points
ID: 16924782
You need to give the user in your connection SELECT permissions on the tblAnalytics table.
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16924787
Also, the following question is now conisdered abandoned, please attend to it:
http://www.experts-exchange.com/Web/Web_Languages/ASP/Q_21845686.html

Thanks.
0
 

Author Comment

by:net-workx
ID: 16924846
i have done this already...


Right click on table > properties > permissions > the user Live_XXXX has ticks in SELECT, INSERT, UPDATE, DELETE, DRI

But it still does not work!

As regards the open question, it is still valid, i will update this tommorow.

Carl
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 16925082
>>But it still does not work!<<
Than that is not the correct user or you are missing something.  There is I am afraid no other way around it.

>>i will update this tommorow.<<
Please do.
0
 

Author Comment

by:net-workx
ID: 16926417
Obviously made a mistake....

I created a new user and set the permissions on the table again then modified the connection string and it is all ok now!

Thanks,
Carl
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In today's business world, data is more important than ever for informing marketing campaigns. Accessing and using data, however, may not come naturally to some creative marketing professionals. Here are four tips for adapting to wield data for insi…
Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question