Complex Image Print Jobs - Memory Upgrade Questions

Posted on 2006-06-16
Medium Priority
Last Modified: 2008-01-09
We use 10 Brother HL-5170DN network-connected printers.  The printers come standard with 32MB memory.

Complex images are frequently only partially printed (or not printed at all).  It was suggested that we upgrade the memory in the printers to cope with these images.

We have purchased 128MB upgrades, bringing the total memory in the printers to 160MB.  The printers do report 160MB as being installed.

The printer includes a configuration option called ‘Page Protect’.  This is set to the default of ‘Auto’.  Other options include Letter, Legal and A4.  Selecting A4 instead of Auto for this option results in the same problem described below.

The only other printer setting that sounds memory related is Input Buffer.  The default is ‘3’.  I’ve tried setting it to the maximum of ‘15’.  There is no indication of the unit of measure for ‘3’ and ‘15’.  The problem persists.

Both PCL (5e) and PostScript 3 printer drivers are provided by Brother.

In the PCL printer driver, there is an option under Advanced settings called Printer Memory.  This is a drop-down list with a maximum value of 36MB.  I have set it to the maximum value – the problem persists.

In the PostScript printer driver there is an option under Advanced Settings, Font Substitution Table, called Available PostScript memory.  This defaults to 5029KB.

There is no mention in any of the Brother documentation about this value.  Our problem doesn’t strike me as being ‘font substitution table’ related.

PROBLEM: Print jobs containing complex images sent to the printer cause the status light to flash (as if the printer were processing the job) but without generating any printout, the status light returns to normal (solid green).

Can anyone offer insight into what might actually fix our problem?  Have we wasted a fair bit of money to buy upgrades that are not going to fix our problems?
Question by:Robert Hall
  • 2
  • 2
  • 2
  • +1

Expert Comment

ID: 16925441
Have you seen these partial prints from a bunch of different applications or just one or two? If it's just an app or two, which app(s) is it?

Also, check the network firmware (http://global.solutions.brother.com/hl5170dn_all/en_us/download/network_firm.html) and make sure you have the latest. I'd try this on a single printer first. That way, if it's not the problem, you won't waste time on the other 9 printers.

Some other things to try:

1) Disable "Use Reprint" under "Job Spooling"
2) Lower the resolution to 300 dpi, just to see if it prints.


Author Comment

by:Robert Hall
ID: 16925573
The problems tend to be with Acrobat Reader (6 and 7).  These are scanned drawings and floor plans.

I have confirmed we are running the latest version of firmware (1.50).

I attempted to print using 300dpi.  Same situation.

I cannot locate 'Job Spooling'.  Any hints?

Expert Comment

ID: 16925918
For "Job spooling," go to the Advanced tab of the driver properties. Click on the last button (the configure button). It's the first one in the list (this is the same list that has Page Protection).

If you don't see it in there, click on the support tab and check the driver version. I just downloaded the driver to look at the UI. It's Version 2.03 for Windows 2000/XP. If you're also using XP and have an earlier version of the driver, grab this driver from Brother and see if it works better.

Also, from Acrobat, click on the advanced button and toggle the "Print as Image" option. That might help as well.
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

LVL 39

Expert Comment

ID: 16929190
The suggestions of thoffman about spooling and printing as image are good ones.

Just to clarify the PostScript memory setting: that is the memory available for the PostScript memory stack (called "VM") in the printer, and it bears very little relation to the amount of installed memory. More memory usually increases VM, but not necessarily.

There should be another driver setting, maybe under an Options tab or similar, that lets you tell the driver how much memory is installed. The driver then uses that to calculate the amount of VM.

You can try enabling the PostScript error handler in either the driver or the printer (if it has that option). That may give you some idea what the real problem is.
LVL 21

Accepted Solution

wyliecoyoteuk earned 2000 total points
ID: 16930841
In the print driver, advanced tab , is spooling set to "start printing after the last page has spooled"?
on the printer, in addition to the buffer setting, is there a timeout value? If so, increase it.
The problem is probably not the memory, it is the render time.

Typically, if printing PDFs to a postscript printer, the file spools quickly , and the printer takes it's time printing.
If printing the same file to a PCL printer, the file takes ages to spool, but the printer prints quickly.

The problem is that the rendering has to happen somewhere, and it is a balance between the speed of the computer, the network, and the printer, and a laser printer needs a whole page in memory before it can start printing.
We sell printers that print 105 pages a minute, but even the fastest PC struggles to render 105 PCL pages a minute from a postscript program file.
Settings to ensure printing:
1. "start printing after the last page has spooled" eliminates rendering bottlenecks, thus ensuring that the job is rendered and ready to send before starting transmission, limiting the problems to transmission time. There will be a longer delay before printing starts, but the job will print, and the total time is usually shorter.
2. Increase buffer size, this reduces transmission time.
3. Increase timeout value. This stops the printer timing out if it does not receive a full page image in a set time.
4. In the advanced tab of the printer driver, untick "enable enhanced printer features" this disables Microsoft EMF spooling, which often causes huge spool files and slow printing.

Increasing the memory in the printer only enables the rendering of more complex jobs, it does not help with spooling problems like this one, although some printers support Hard disks for spool printing.

Author Comment

by:Robert Hall
ID: 16931223

We have a large HP 9000DN.  Its PostScript driver has, under "Installable Options", a field for defining the 'Total Printer Memory'.  Ours has 192MB.  The value defined is '192-255MB'.  This is in addition to 'Available PostScript Memory' which defaults to 249KB, and does not change when changes to Total Printer Memory occurs.  The help for the Available PostScript Memory field is 'it's best to accept the default determined by your printer manufacturer'.

Unfortunately the Brother driver does not allow definition of 'Total Printer Memory'.


Lots of great suggestions!

For the PS driver, a combination of  "start printing after the last page has spooled", increasing the timeout value (from 5 to 60 seconds), unticking "enable enhanced printer features" AND increasing the buffer size to 15-whatevers results in (slowly) printed jobs.  With only the first 3 items (without increasing buffer size) it was the same story.

For the PCL driver, "start printing after the last page has spooled", increasing the timeout value (from 5 to 60 seconds) and unticking "enable enhanced printer features" did the trick.

Care to posit a bit as to why these worked?  The points are all yours.

LVL 21

Expert Comment

ID: 16932566
Print spooling is essentially a simple process, but it is often misunderstood.
this link explains a little further (work in progress, may change)


The buffer size just increases transmission speed, and on to-days networks, with fast line speed and fast printer engines, is probably less important than it once was.

With a Postscript job (PDF is Postscript for the screen), if sent via a Postscript driver, it is sent to the printer virtually "as is" and the printer renders the programmed instructions. This means that the speed of the printer's rendering engine governs the speed of printing.
If the same file is sent to the same printer using a PCL driver, the PC has to translate the Postscript program into a rendered PCL job, and send it to the printer. Thus the speed of the PC governs the speed of printing. Usually in this situation, the job takes a while to start, but prints at full speed.

Postscript printing is slower than PCL for most jobs, but it is far more accurate when reproducing images, especially complex, high resolution colour.

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

If you use a Brother DCP 130C or similar Brother printer, at some point you might encounter the following problem: after you change the ink cartridge, the printer displays an "ink empty" message. Sometimes you just need to follow the instructions…
This seems to be a very common error related to the Samsung printer driver. First, this is the error we're talking about: Log: System Type: Error Event: 7000 Agent Time: 3:37:24 am 22-Apr-09 Event Time: 6:07:24 pm 21-Apr-09 UTC Source: Se…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…

584 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question