Solved

PC Boot Up Problem

Posted on 2006-06-16
16
383 Views
Last Modified: 2008-03-10
I am having an intermittent problem when booting my pc. At switch on, the pc gets to the first couple of boot-up sceens to where it says boot from CD Rom, if there is no bootable CD present, the pc will try and boot from the HDD. It then displays a Y and infinity symbol (8 on it's side)and a Y and infinity symbol, e.g. Y∞Y&#8734 (paste this code into an HTML and you will see what I mean); and I can't get any further. I can't boot to safe mode either.
To resolve this, I have to re-install a backup image from a second HDD. The pc boots up OK after this.
This problem can happen at any time, twice in the same day is the most that it's happened.
My main HDD does run quite hot, 50 - 55 deg C, but I don't think it is a temperature related problem, as it can happen after the pc has been off for some time.
My OS is Windows XP Pro with SP2
CPU P4 1.7 GHz
Ram 712 MB
HDD - 3 of configured as 1 Master on IDE to Mobo, plus 2 HDD's connected to PCI IDE card & configured as primary master & secondary master. This configuration has worked well for the last year, the problem I am having has only started in the last few weeks.

My AV is up to date Kaspersky 6 with latest definitions & I run PC Doctor up to date, I am also behind a router.

BIOS Boot Sequence
1. FDD
2. CD Rom
3. HDD 0

Both my C & D drives are Maxtor HD's and I have run Maxtor Powermax HD Diagnostics on both these drives, no errors were detected.
0
Comment
Question by:jim_elliot
  • 5
  • 5
  • 2
  • +2
16 Comments
 
LVL 92

Accepted Solution

by:
nobus earned 50 total points
ID: 16925817
i would test the ram, just to be sure; use memtest86+ from :   http://www.memtest.org/      
you can troubleshoot this by disconnecting or disabling hardware, and boot with the minimum :
mobo, 1 ram stick, video card, 1 HDD, keyb + mouse.
on the soft side, you can try disabling programs and services with msconfig (from the run box) :
- in sstartup tab, click disable all
- in services tab, click hide  MS services, then click disable all.
Does it happen with another disk?
0
 
LVL 30

Assisted Solution

by:callrs
callrs earned 50 total points
ID: 16925898
---Disk may be going bad:
Run a full surface scan of the disk if you haven't already.
If you have Norton "Disk Doctor" or some other scandisk utility, use it. Else, read:
http://kb.iu.edu/data/agno.html         In Windows 95, 98, Me, NT, 2000, and XP, how can I check a disk for errors?
Other info:
www.experts-exchange.com/Hardware/Q_20831222.html (Surface scan utility for IBM & Western Digital, not Maxtor)
www.maxtor.com/en/support/downloads/scsimax.htm  (Maxtor surface scan utility for SCSI (not IDE?))
www.experts-exchange.com/Hardware/Q_21498387.html   (Links, may or may not help, + info on chkdsk /f & /r options)

(The best utility though, for hard drive diagnostics, may be:  http://www.grc.com/spinrite.htm)

--Repair Install.
If surface scan fails, try a repair install (Google for: xp repair install.  You get www.michaelstevenstech.com/XPrepairinstall.htm etc.)

-R.S.
0
 
LVL 8

Assisted Solution

by:mugman21
mugman21 earned 50 total points
ID: 16926095
I would disagree with some of the above post. Several things here:

1. if your not hearing any weird beeping patterns when you power up, post is completing error free. (there should be one beep if post succeds. )

2. I don't think it's a memory issue (if it is, re-setting the mem sticks would probably solve the issue). The reason I don't think it's a mem problem is because it doesn't sound like the boot loader ever gets fired. This means the upper 512k of memory where post gets loaded (from bios) is good (most likely).

3. If the boot loader throws an error while initializing the hal, the system will die instantly without printing anything to the screen - nor will the system bug check since the kernel isn't loaded and it's trap handler hasn't yet initialzed.

I would submit to you that you conduct a test - CHANGE your boot order to HDD first. I'm guessing perhaps the IDE cable on your CD drive is flaky - or the CD drive itself is going bad. At this phase in booting, and if something goes wrong, there is a good chance the mbr stored on the HD is going to get jacked-up because the reader heads are going to be right there on platter one, cylinder one, sector one.

If you go to HDD boot first and the problem doesn't manifest itself, then I'm onto something here.

Otherwise, I've had too many brews tonight....

Mugman
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 30

Expert Comment

by:callrs
ID: 16926116
>> I'm guessing perhaps the IDE cable on your CD drive is flaky
Why I didn't say that? lol

Also ensure:
- The cable is firmly in the hard drive & on the motherboard slot
- That you have an ultra ATA (80 wire) cable, not the 40-wire cable, for ultra ATA drives
- The power connector is not loose & that the connector pins' position in their sockets is OK.
0
 
LVL 15

Assisted Solution

by:bpmurray
bpmurray earned 50 total points
ID: 16927263
I had something like this and it turned out to be a flakey FD. I made the HD first and it still didn't work - I had to disconnect the FD.
0
 
LVL 30

Assisted Solution

by:ded9
ded9 earned 50 total points
ID: 16929372
hi Pal

It seems like MBR is corrupt. So try fixing  MBR.

Also you can backup your data then deleted partitions and create new partition
The new partition will create new MBR.

Surely the above solution will resolve the issue.
MBR=Master Boot Record

Try it

Reps

 
0
 
LVL 15

Expert Comment

by:bpmurray
ID: 16929402
Could be MBR. Boot using your XP CD and select Repair. From the console execute FIXMBR C:
0
 
LVL 8

Expert Comment

by:mugman21
ID: 16929422
Yeah yeah, I mentioned the mbr in my original post. The question is, if this is the problem, what is currupting it?

I gave my theory, were are your theories? This guy is copying images back from one disk to another, his backup image is clearly good - what is currupting it is the question? This is the issue that must be resolved......

Mugman
0
 
LVL 15

Expert Comment

by:bpmurray
ID: 16929511
Actually. I just reread the original post - it can't be the MBR since it's only intermittant. If you've screwed your MBR before, you'll knom it's pretty consistent :-)

The Hardware block is probably the best source of the problem. Of course, it could be an associatated problem caused by BIOS settings.
0
 
LVL 8

Expert Comment

by:mugman21
ID: 16929534
no, it CAN be the mbr, re-read the post again. The OP say's  after he re-images the drive, the system comes back. A back-up and an image are two different things. The disk image would contain an mbr.

Regardless of this mbr talk, I still think he has flaky hardware in his machine, whether it be a cable or drive.

mugman
0
 
LVL 8

Expert Comment

by:mugman21
ID: 16929550
From my reading of the original post, it's intermitent problems, followed by an image being copied to the disk to solve it, untill the next problem occurs.
0
 
LVL 15

Expert Comment

by:bpmurray
ID: 16929627
Yep - I should take more time when I read these things!

I'll restate it as I see it: the boot sequence is corrupted so that it doesn't get into the first part of the boot sequence. This *is* typical MBR corruption. However, it is not at all clear why this should happen. I had a funny behavior where the MBR on a secondary drive was being corrupted, and never got to the bottom of it: in that case, the drive was on the second MoBo IDE connector. However, it has corrected itself, or, more likely, my hackery has accidentally fixed it. Assuming the latter, it seems likely that the original cause was a loose cable (I tend to push all connections home whenever I open the box).

Perhaps it's the cables as mugman suggested: ensuring all cables are properly seated is a simple thing to do and is not likely to cause any harm. In any case, if it happens again, check to see if it's the MBR by using FIXMBR rather than re-imaging the drive - if it works, that's the problem, and the next step is to find what corrupts it.

Do you have a diagnostics disk with your machine? Perhaps it can identify if anything's misaligned or behaving badly.
0
 
LVL 8

Expert Comment

by:mugman21
ID: 16929705
I would concur wth myself about the bad cable :=) I can't think of any other reason why chars would be written to the screen.... The OS didn't do it (it's not loaded yet), and I doubt BIOS did it (limited abilities).....

"boot sequence is corrupted so that it doesn't get into the first part of the boot sequence. This *is* typical MBR corruption" - but where did the strange chars he see's come from? On my test machine, 99% of the time when I corrupt the MBR, I get a bios error, "Inaccesible boot device" or "no partition found"; something like that....

The other 1% of the time I get a specific hardware error.

Mugman
0
 
LVL 15

Expert Comment

by:bpmurray
ID: 16929719
Actually, if you've ever removed a Linux volume before cleaning up the MBR, you'll see odd strings displayed during boot, exactly as this describes.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
how can I translate an audio video clip from Spanish to English? 4 42
will india ph work in usa? 21 59
Problem to router 7 56
Interpreting a header of junk mail 8 141
Since 2008, the stock markets have been in a haphazard state of fluctuation. At times it has been a steep decline (2008) and at others, a steady incline full of promise (2010). Just weeks ago, in August 2011, together we saw the stock markets plunge…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
The Bounty Board allows you to request an article or video on any technical topic, or fulfill a bounty request to earn points. Watch this video to learn how to use the Bounty Board to get the content you want, earn points, and browse submitted bount…
Saved searches can save you time by quickly referencing commonly searched terms on any topic. Whether you are looking for questions you can answer or hoping to learn about a specific issue, a saved search can help you get the most out of your time o…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question