?
Solved

Failing to connect via remote desktop because of terminal connection busy.

Posted on 2006-06-17
4
Medium Priority
?
19,015 Views
Last Modified: 2012-06-27
I have this XP computer that I remote desktop to, and when the XP machine first reboots, I can make the first connection to it with no problem.
But if the first connection goes down, then I get the following error when I try to connect again:
"The requested operation cannot be completed because the terminal connection is currently busy processing a connect operation"

How can I fix the XP machine so the second logon attempt works, and is there any way to force it to kill existing connection remotely?
0
Comment
Question by:Axter
  • 2
4 Comments
 
LVL 11

Expert Comment

by:grsteed
ID: 16936007
Check out this Group Policy setting in XP.

Start > Run > gpedit.msc

The navigate to
Computer Configuration > Administrative Templates > Windows Components > Terminal Services

With Terminal Services highlighted on the left, there will be a list on the right. (clicking on "standard" makes it easier to see)  Double click on "Keep-alive connections" and look at the Explain tab. I think enabling this will solve your problem.

From the explain tab

"After a terminal server client loses the connection to a terminal server, the session on the terminal server might remain active instead of changing to a disconnected state, even if the client is physically disconnected from the terminal server. If the client logs on to the same terminal server again, a new session might be established (if Terminal Services is configured to allow multiple sessions), and the original session might still be active. "

Cheers,

Gary

0
 
LVL 30

Author Comment

by:Axter
ID: 16936090
What should it be set to?
0
 
LVL 11

Accepted Solution

by:
grsteed earned 2000 total points
ID: 16936172
Enabled.

It's confusing (as many group policy items are) because it sounds like it's going to keep your connection alive, but I think that this line explains it.

"You can use this setting to enable keep-alive connections and ensure that the session state is consistent with the client state. By default, keep-alive connections are disabled."

It seems like the server isn't recognizing that the client has disconnected and enabling this should force it to check it.

I would think that setting the time to around 5 (mins) would be OK.

Cheers,

Gary
0
 

Expert Comment

by:shri_mani
ID: 23989398
How i will know that from which system session is establish. I have changed on my XP machine and try to logged on server but still same issue. Pls any one help me out
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are 2 things you must have in order to connect to the internet behind a router, The "Gateway IP" of the router, which is usually something like 192.168.xxx.1, I've seen routers with default values of: 192.168.0.1, 192.168.1.1, 192.168.11.1, …
Are you unable to synchronize your OST (Offline Storage Table) file with Microsoft Exchange Server? Is your OST file exceeding 2 GB size limit? In Microsoft Outlook 2002 and earlier versions, there is a 2 GB size limit for the OST file. If the file …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question