[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1271
  • Last Modified:

mail goes to clientmqueue but not mqueue

Hi,

I am on a server, where mail goes to clientmqueue but not mqueue.  I get an error in one of the files.

-rw-rw----    1 nobody   smmsp         104 Jun 18 01:15 dfk5I6Fhjq028710
-rw-rw----    1 nobody   smmsp         765 Jun 18 01:15 Qfk5I6Fhjq028710

grep defer clientmqueue/Qfk5I6Fhjq028710
Mhost map: lookup (supportteam.net): deferred

Can anyone tell me how to fix, or give suggestion?  Also I don't think either the MTA or MSP is running; the only thing running is this:

root     23963  0.0  0.1  3664 1552 ?        S    01:42   0:00 sendmail: accepting connections

The other one was running a while back but I killed it and don't know how to start it correctly again.  It said this:

root      2071  0.0  0.1  3644 1480 ?        S    01:23   0:00 sendmail: Queue runner@00:15:00 for /var/spool/mqueue
0
bryanlloydharris
Asked:
bryanlloydharris
  • 3
1 Solution
 
bryanlloydharrisAuthor Commented:
Also I don't know if it is important, but these mails are not from regular sendmail, but rather from the php mail() function.  The regular sendmail works just fine.
0
 
bryanlloydharrisAuthor Commented:
Also in /etc/sendmail.cf, there is this line.  Again, I don't know if it is important.

O QueueDirectory=/var/spool/mqueue
0
 
bryanlloydharrisAuthor Commented:
Hi,

I have run the following command, which seems to clear the clientmqueue.

sendmail -Ac -q -v
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now