Solved

Terminal server settings won't save ?

Posted on 2006-06-19
8
315 Views
Last Modified: 2011-10-03
Using 2 server:
1 Terminal Server with Windows 2003 Standard SP1
1 Active Directory/Exchange server with Windows SBS 2003 SP1
+/- 10 Users using client Windows XP SP2

Every user want his own settings. The problem is when they change these settings like toolbar or the view of explorer. That when they log off and login again sometime's these settings going back to default.

The users have full control over there profiles. We dont use roaming profiles.
The profiles stands in the c: documents and settings map.
We have these users in a OU and use a GPO, in this GPO we only disable shutdown and some stuff in the startmenu.

When we put out these users out of the OU we still have this problem. Even when we give them admin rigths

We scanned for spyware or virus but nothing special found. Using internet under terminal server is not alowed.

Only windows settings wont save. When we change someting in word or something else there is no problem with it.

Can someone help me thanks !
0
Comment
Question by:techwaresystemen
  • 4
  • 2
8 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16933926
With an SBS you must keep the default OU's in place.  All users must stay in \MyBusiness\Users\SBSUsers.  Instead of creating different OU's, SBS relies on Security Groups for delegation of GPO's.

However, there are a number of other important things to follow when adding a Terminal Server to an SBS network, and also for deploying roaming profiles.

Please see http://sbsurl.com/sbstss for specific instructions on adding a Terminal Server to your network.  Then please see the Roaming Profiles section of http://sbsurl.com/postinstall for the important settings necessary for roaming profiles.

But before you even start there... you need to move all users back to the default OU.

For more info on SBS overall, please see http://sbsurl.com/itpro

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16933948
Just to clarify... since I reread your question and you say that you don't use roaming profiles... is this because the Terminal Server users only ever log onto the Terminal Server?  If that's the case, then ignore my comments about roaming profiles, but definitely you need to have those users stay in the default OU.  All users should be created with the user templates via the add user wizard.  If you want a specific one for TS users, then you should create a new template by copying an existing one and modifying.

Jeff
TechSoEasy
0
 

Author Comment

by:techwaresystemen
ID: 16935879
Since I reread your question and you say that you don't use roaming profiles... is this because the Terminal Server users only ever log onto the Terminal Server?

Yes they only log on the Terminal Server. They arent in a domain just only workgroup.


With an SBS you must keep the default OU's in place.  All users must stay in \MyBusiness\Users\SBSUsers.  Instead of creating different OU's, SBS relies on Security Groups for delegation of GPO's.

Ok, the users arent in this group. I will put them in these group. But can really cause this my problem because they are in a wrong OU ??

Thanks
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16936415
Well, I'm not sure.

In the answer to the first question you say that they aren't in the domain... but that's not really possible unless if they are authenticating through the SBS.  But if you created users in an OU, then they are domain members... if you created them in an OU other than the default, then their settings will most likely not stick... especially if you didn't follow the Terminal Server Install guide I linked above.

And, just so you understand the licensing... you are required to have both SBS CALs AND Terminal Server CALs for these folks, as well as licenses for any software you have installed on the Terminal Server.

Jeff
TechSoEasy
0
 

Author Comment

by:techwaresystemen
ID: 16942136
In the anser to the first question you say that they aren't in the domain... but that's not really possible unless if they are authenticating through the SBS.  

I am sorry I mean that the workstations aren't in a domain. Ofcourse the terminal server is at the rigth domain.

With an SBS you must keep the default OU's in place.  All users must stay in \MyBusiness\Users\SBSUsers.  Instead of creating different OU's, SBS relies on Security Groups for delegation of GPO's.

I put the users at this OU, but I still got the same problem.  

:(


0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 125 total points
ID: 16945153
Did you manually put them in the OU? or did you add the users with the Add-User wizard and they were put there automatically?

With SBS you must ALWAYS use the wizards to configure things because otherwise you'll end up breaking other dependent components.

Your Terminal Server should have been added to the network by first running the Add-Server wizard on the SBS, and then running http://<sbsservername>/connectcomputer from the TS.  If it was not done this way you need to follow these steps to fix it:

The following needs to be done on the Terminal Server:
1.  Log in with THAT machine's LOCAL administrator account.
2.  Unjoin the domain into a WORKGROUP
3.  Change the name of the computer
4.  Delete or rename the following directory C:\Program Files\Microsoft Windows Small Business Server\Clients if it exists
5.  Make sure that the network settings are configured to get an IP address automatically (DHCP enabled).  If you want the server to have a specific IP, create a DHCP reservation on the SBS
6.  Reboot

Then on the server, from the Server Management Console:
1.  Remove the server if it still shows in the Servers screen on the Server Management Console's Upper tier.
2.  Add the server with it's NEW name using the Add Server wizard

Then, go back to the Terminal Server and join the domain by opening Internet Explorer and navigating to http://sbsservername/connectcomputer

Finally, run the Configure Email and Internet Connection Wizard again so that the new Terminal Server will be recognized and a menu item will be created in Remote Web Workplace... this is where remote users should log onto the Terminal Server.

Jeff
TechSoEasy

0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of us need to configure DHCP server(s) in their environment. We can do that simply via DHCP console on server or using MMC snap-in on each computer with Administrative Tools installed in a network. But what if we have to configure many DHCP ser…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now