Solved

Setting up cisco 827h with PIX 501

Posted on 2006-06-19
7
370 Views
Last Modified: 2013-11-16
Hi,

I am trying to setup VPN connection with Cisco PIX 501 through a Cisco 827h router using Cisco VPN client 3000 4.6. Do I have to forward a UDP or TCP port?

Cheers

PIX 501
--------


PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl_out permit icmp any any echo-reply
access-list outside_cryptomap_dyn_20 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_40 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_60 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_80 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_100 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_120 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_140 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_160 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_180 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_200 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_220 permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_240 permit ip any 192.168.180.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any 192.168.180.0 255.255.255.0
access-list outside_cryptomap_dyn_260 permit ip any 192.168.180.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.180.4 255.255.0.0
ip address inside 192.168.180.6 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool admin 192.168.180.7-192.168.180.254
pdm location 192.168.180.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.180.3 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.180.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 80 match address outside_cryptomap_dyn_80
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 100 match address outside_cryptomap_dyn_100
crypto dynamic-map outside_dyn_map 100 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 120 match address outside_cryptomap_dyn_120
crypto dynamic-map outside_dyn_map 120 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 140 match address outside_cryptomap_dyn_140
crypto dynamic-map outside_dyn_map 140 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 160 match address outside_cryptomap_dyn_160
crypto dynamic-map outside_dyn_map 160 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 180 match address outside_cryptomap_dyn_180
crypto dynamic-map outside_dyn_map 180 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 200 match address outside_cryptomap_dyn_200
crypto dynamic-map outside_dyn_map 200 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 220 match address outside_cryptomap_dyn_220
crypto dynamic-map outside_dyn_map 220 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 240 match address outside_cryptomap_dyn_240
crypto dynamic-map outside_dyn_map 240 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 260 match address outside_cryptomap_dyn_260
crypto dynamic-map outside_dyn_map 260 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpngroup test address-pool admin
vpngroup test dns-server 192.168.180.1
vpngroup test wins-server 192.168.180.1
vpngroup test idle-time 1800
vpngroup test password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.180.7-192.168.180.134 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:f8e0620da4d2dc483edb7e490b88ff51
0
Comment
Question by:Glenhomes
  • 3
  • 2
7 Comments
 
LVL 9

Expert Comment

by:stressedout2004
Comment Utility
Is the 827H in front of the PIX? How many public IP do you have?

------internal LAN--------PIX---------------827h-----internet-----

If the 827 is in front of the PIX and is atleast running 12.3, you need to configure port redirection on UDP port 4500, 500 and ESP protocol.
0
 

Author Comment

by:Glenhomes
Comment Utility
Hi,

I have only the one public IP address and the 827 is in front of the PIX but running 12.2. Will forwarding these ports work on 12.2?

Cheers
0
 
LVL 9

Expert Comment

by:stressedout2004
Comment Utility
It depends on the feature set and IOS release. Can you post the output of "show version" from the 827 so I can double check if the port forwarding will work on your version.
0
 

Author Comment

by:Glenhomes
Comment Utility
Thanks for getting back. As requested.


Cisco Internetwork Operating System Software
IOS (tm) C820 Software (C820-OY6-M), Version 12.2(4)YA4, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Synched to technology version 12.2(5.4)T
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Fri 27-Dec-02 11:28 by ealyon
Image text-base: 0x80013170, data-base: 0x806AA244

ROM: System Bootstrap, Version 12.2(4r)XM2, RELEASE SOFTWARE (fc1)
ROM: C820 Software (C820-OY6-M), Version 12.2(4)YA4, EARLY DEPLOYMENT RELEASE SO
FTWARE (fc1)

admin uptime is 6 weeks, 4 days, 22 hours, 58 minutes
System returned to ROM by power-on
System image file is "flash:c820-oy6-mz.122-4.YA4.bin"

CISCO C827H (MPC855T) processor (revision 0x501) with 31744K/1024K bytes of memory.
Processor board ID FOC072413KW (1936771040), with hardware revision 0000
CPU rev number 5
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102
0
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 500 total points
Comment Utility
Unfortunately, your IOS doesn't support the feature that you need. Based from Cisco's feature navigator, the minimum IOS that would support the IPSEC through NAT support that you need is 12.3(2)T. You have two options:

1) Upgrade the router to a minimum of 12.3(2)T which only requires 20 DRAM and 8 MB flash. You meet the memory requirements so you should be fine.

2) Get one more public IP from your ISP.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

There are many useful and sometimes not well documented or forgotten IOS or ASA/PIX commands. See IPE article here , there was also one on PacketU and on Cisco Tips & Tricks. Below are my favorites. I give also a few most often used for Cisco IPS an…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now