Windows 2003 server, internet connection drops

I'm running a windows server, from home, connected to my broadband connection.

I've setup the router/server to allow access to it via http and vpn, it works ok for a period of time, ie. I can access it externally from the internet, but eventually I lose the ability to connect to the server (after a day or two).

If I reboot the server it fixes the problem.

I can't see anything in the logs that would explain this.

Any advice much appreciated.
mike99cAsked:
Who is Participating?
 
Rob WilliamsCommented:
>>"There's no keep alive option as such. I've got a netgear DG834GT"
Actually there is an Idle time out option, but as mentioned it only exists if you have a PPPoE connection.

>>"Any ideas on how I can schedule a task to force the connection open"
You can create a standard scheduled task. Start | all programs | accessories | System tools | scheduled task. Browse for Internet explorer, then under advanced you can set the frequency.
Next, open Internet Explorer and on the menu bar go to Tools | Internet Options | General | Under Temporary Internet files click "Settings" | under "check for newer versions of stored pages" check "
This will force it to load a new, rather than cached page, every time it opens.
0
 
Erik BjersPrincipal Systems AdministratorCommented:
Does your ISP provide you with a static IP?  If not you may be getting a different IP, and a reboot may be renewing the IP back to the old one.
0
 
mike99cAuthor Commented:
I do have a static IP, I'm thinking that something is timing out on the server, after a period of no net access.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Erik BjersPrincipal Systems AdministratorCommented:
if it's a server, there should be no time outs.  Anything in the event log?
0
 
Rob WilliamsCommented:
By default it should not be enabled on the server, but make sure "allow the computer to turn off this device to save power" is not enabled under the power management  tab, of the network adapters properties, in device manager. It is possible it is going into a power saving/stand by mode.
0
 
mike99cAuthor Commented:
Thanks for that, the network adapter properties did have the box ticked to allow the computer to turn it off to save power. Have unchecked the box, will leave it 24 hours and see if I can access the server.
0
 
Rob WilliamsCommented:
That might do it for you. XP has it enabled by default but the server O/S is not supposed to, but I have seen it before. Good luck, let us know how you make out with it.
0
 
mike99cAuthor Commented:
Hmmmm, I'm still losing net access, I noticed to fix it all I need to do is open a browser on the server, then I can connect to it again.
0
 
Rob WilliamsCommented:
another thought; is your Internet connection a PPPoE connection? If so, on the router there will be an "idle time out period" and/or "keep alive" option. If "keep alive" exists, enable and set to 3 seconds (this will disable "idle time out" as well), if only idle time out set to 0 which disables it.
0
 
mike99cAuthor Commented:
There's no keep alive option as such. I've got a netgear DG834GT.

I thought about running a scheduled task to fire up IE every 30 mins, but it will probably load a cached page and not actually open a connection. Any ideas on how I can schedule a task to force the connection open, can I run a curl command from a batch script?
0
 
Erik BjersPrincipal Systems AdministratorCommented:
schedule a ping
0
 
mike99cAuthor Commented:
I tried scheduling a ping (to the gateway), but I still lose connection
0
 
Rob WilliamsCommented:
Sorry last 2 lines should read:
 under "check for newer versions of stored pages", enable "Every visit to the page".
This will force it to load a new, rather than cached page, every time it opens.
0
 
mike99cAuthor Commented:
Thanks for the response, I scheduled IE as you described but I was still losing the connection. I ended up getting a ZyXEL 661 and this has the option to keep the connection 'Nailed Up', as soon as I set that it has been up continuously.
0
 
Rob WilliamsCommented:
Thanks Mike. Glad to hear you have a resolution.
--Rob.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.