Connecting Database to GoldMine.

I'm trying to open a older SQL GoldMine database, and seem to be having a few problems... The database is called GMSM_Golf, so in the path I'm putting in: MSSQL: GMSM_Golf: dbo: but I keep getting connection errors... I should probably add that when I get back to the screen that allows me to select a database, it shows that it's trying to open a dBase, when it should remain MSSQL....  any ideas??

Thanks!
-mathieu
mmanaigreAsked:
Who is Participating?
 
TommyTupaCommented:

1. On the box hosting goldmine go to Control Panel-->BDE Administrator.  If you cant find it then do a search for Bdeadmin.exe.
2. Create a new Alias: Object --> New -->MSSQL --> OK.
3. Name the Alias: e.g. GM_thisisatestalias
4. In the Database Name field on the left enter the name of the new Sql Server Database e. g. Goldmine_testdatabase.
5. In the Server Name field enter the server name or preferably the IP address on which Sql  Server is located.  
6. In the UserName field enter the SQL Server Service Account which has access to your  database, e.g. sa
7. Goto Object --> Apply.
8. Assure your alias connects to Sql Server by double-clicking on the alias name ( GM_thisistestalias).
9. You will be prompted for your Sql Server account password.  Enter it in and click OK.   If the left hand side refreshes as if nothing happened then you connected succesfully.  If  you get an error or some kind of timeout then your Sql Server username or password is not  correct and you have not connected to the database.
10. Exit BDE such as via Object --> Exit.
11. Attach Goldmine to this new alias
0
 
TommyTupaCommented:
Check your GM.ini file.  The sysdir path should point to the location of your license file.  The CommonDir and GoldDir should say MSSQL: GMSM_Golf: dbo


0
 
mmanaigreAuthor Commented:
I'm trying to connect to a second database, the GM.ini file has the original database in it but not the second...
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
TommyTupaCommented:
Does your second database have a BDE alias created?  Do you need to know how to create a second BDE alias?

0
 
mmanaigreAuthor Commented:
uh.. yes I think I do need to know...  
0
 
mmanaigreAuthor Commented:
This fixed my problem on the test server, but I still can't connect on the production... the BDE is definately already setup, but for some reason, I'm getting the same error as before...

The database is setup with the same bde alias, so the connection string should be: MSSQL: GMSM_Golf: dbo:

the user name fiels is correct, and I can connect no prob from the BDE Adminisitrator...

I confirmed every letter, so I'm not sure what I'm doing wrong... Anyway, I will continue to play with the production server, and hopefully I'll get it going...

thanks again!
0
 
TommyTupaCommented:
Glad to help.

Two things come to my mind:
1. Servername rather than IP Address in BDE settings.
2. Problem with BDE settings or path.

If it were me I'd backup my idapi32.cfg, delete the BDE portion from the registry, delete the folder path  and resintall BDE.  

You can find out more about BDE paths and settings by going to support.frontrange.com-->online support.  Search for one of the installation guides such as:
GoldMine 5.7 Business Contact Manager Installation Guide

Also, there is a very active goldmine discussion forum here: forums.frontrange.com
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.