Solved

XP slow login on laptop with wireless:  hangs at applying network setings. Sound familiar to anyone?

Posted on 2006-06-19
7
1,079 Views
Last Modified: 2012-08-13
I could not find an adequate solution to this problem anywhere on the net.  People attributed it to DNS, but that was not the cause here.  In my case, I found the problem and wanted to share the solution with others and see if it solves their issues as well:

Symptoms:

Laptop with XP Pro, SP2, completely patched, hangs when user thries to log in when connected to the domain or stand-alone.  This behavior occurs when the wireless card is turned on or off.  The system hangs at "applying network settings."  DNS is configured without any problems.  This only effects 3 laptops on the entire network.

Solution:

In your wireless settings, check your list of "preferred networks."  Every time you connect to a hotspot, windows adds it to this list.  In my case, the affected laptops belonged to employees who travelled A LOT and had 50-60 "preferred networks" listed from airport hotspots to hotel networks.  I removed all of them except the ones used for the office and his home network, and it completely fixed the issue.

I am not sure of the technical reasoning behind it, but my guess would be that Windows checks each of these connections at some point during the boot-up (perhaps during the "applying network connections" stage) to poll them for availability. 3-4 preferred networks doesn't take long, but processing 50-60 of them causes the system to take a lot more time to do this.

If there is anyone else who is having similar problems, try this and see if it works.  I am interested to see if it helps other people as well.
0
Comment
Question by:mnmorency
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 70

Expert Comment

by:Merete
ID: 16940893
Hi for a starting point please
look in control panel administrative tools event viewer applications note the event and id  number and post back here a couple to help us pin down the problem.
it could be that these 3 have the same ip address or not in the correct workgroup?

User Profile Hive Cleanup Service
http://www.microsoft.com/downloads/details.aspx?familyid=1b286e6d-8912-4e18-b570-42470e2f3582&displaylang=en
0
 

Author Comment

by:mnmorency
ID: 16942169
Merete:

There is no problem any longer.  As stated, I have already solved it and was posting here because no one had offered this solution, nor had I found this particular solution to the problem listed anywhere online.  It seemed every thread I found on this web site and others were abandoned or forced closed without definitive resolution.  I am merely looking for others who may have this issue to see if my solution helps them as well.

For the record, though, when trying to solve this issue I did look at the event viewer and there were no errors or problems.  I also tried running the profile hive cleanup and it did not help.  DNS was configured perfectly, there were no duplicate IP addresses, and they were all joined to the domain correctly.
0
 
LVL 70

Expert Comment

by:Merete
ID: 16944420
lol ok thank you I am at work and its 3.13 am here, I do remember seeing similar situations here at EE, if I come across these posts will send you a link here if this is still active. :)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 17117020
PAQed with points refunded (250)

CetusMOD
Community Support Moderator
0
 

Expert Comment

by:dotsmit
ID: 21878142
Worked like a charm. Thanks for your post
0
 

Expert Comment

by:TECHDLS
ID: 23838892
Hello
This really helped us resolve the "laptop slow at network login".  In our situation, the user only had 2 wireless networks listed, but both of them were set to automatic.  Once we changed them to "on demand" the slowness went away.  Thanks for sharing this fix.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question