Solved

Help!! Outlook not connecting to Exchange

Posted on 2006-06-19
18
444 Views
Last Modified: 2010-03-06
Ok this happened when our ISP changed their DNS numbers. After I added the new DNS numbers in teh DNS server outlook 2003 takes longer to connect to exchange 2003 server.

I can ping the server by name and IP address. So what seems to be causing the outlook to go so slow. Each outlook 2003 is configured as cached mode as well but this was not a problem before until now. Any immediate help is appreciated.

I called Microsoft Tech support and have been on phone with them almost half a day now and got so frustrated that hung up on them and they will be returning my money back for not able to solve the issue.

0
Comment
Question by:gorhamoien
18 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16938730
Hi gorhamoien,

What kind of server is your Exchange running on???

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16938738
gorhamoien,

Actually, please post a complete IPCONFIG /ALL which is run from the Command Prompt for both your workstation and the server.  

Jeff
TechSoEasy
0
 
LVL 27

Expert Comment

by:Exchange_Admin
ID: 16939301
Sounds like you are have name resolution (DNS) problems.

You said:
"After I added the new DNS numbers in teh DNS server ..."
What and where exactly did you add the new DNS numbers?

Here is the way that I would configure DNS:
ALL workstations and servers should ONLY list your internal DNS server when you run an IPCONFIG /ALL.

On your DNS server add FORWARDERS pointing to the ISP's DNS servers. Do this in DNS configuration.
0
 
LVL 5

Expert Comment

by:Amitspeedstar
ID: 16939965


Yes if u r using your dns to use forwarders than the new dns numbers that ur isp gave should be added to ur dns forwarders entry , and if u r using any smtp virtual server or smtp connector to route external mail than put those numbers in thr .

but the thing is that ur clients should always point to ur internal dns server , regardless of what u are doing on ur dns or exchange server .

I hope this would clear the confusion and solve ur problem

Amit.
0
 

Author Comment

by:gorhamoien
ID: 16960206
Ok none of the solutions provided has helped. the DNS entry is where it should be. The problem is from each workstation when one pings exchange.domain.com it is going to the public ip address instead of the internal exchange server IP address. All workstations get IP from DHCP server which is a windows 2000 server. The exchange 2003 server is on a windows 2003 server.

0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 16967667
None of the solutions may have helped because you have't provided a complete IPCONFIG /ALL as requested.

Please open a command prompt on the workstation and also on the server and enter IPCONFIG /ALL, then right click the title bar of that window to access the editing features so you can copy & paste.

Jeff
TechSoEasy
0
 

Author Comment

by:gorhamoien
ID: 17002336
Well as I said none of the above suggestions works. It not only takes a long time logging into outlook but also the server as well. Something wrong with DNS but how to correct it. All workstations get their IP address from the DHCP server (192.168.10.1). Exchange server is on server (192.168.10.3)

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ghost
   Primary Dns Suffix  . . . . . . . : ghost.domainname.com
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ghost.domainname.com
                                       domainname.com

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-13-72-F6-CB-50
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.10.3
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.10.2
   DNS Servers . . . . . . . . . . . : 192.168.10.3
                                               192.168.10.1
                                             

C:\Documents and Settings\Administrator>
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17006111
Well your DNS is probably wrong.  You have posted the workstation... which has itself designated as a DNS Server... which doesn't make sense.  You are also having it resolve to itself for DNS Name Resolution (ghost.domainname.com).

And I would suspect that because you have a .com as your internal domain name you may not have the correct DNS Zone File records to allow for proper external resolution.

An IPCONFIG /ALL was also requested from your server... without posting that I cannot provide you with any further information about how to fix this other than removing 192.168.10.3 from the current configuration as shown above.

Jeff
TechSoEasy
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:gorhamoien
ID: 17010384
The server is this.....All workstations are getting their IP address from this DHCP server. We do have several servers and several dns servers. This server is pointing to its own DNS, and two others just in case this one fails.

Right now I am also getting under this server event viewer event ID 5774 and it says DNS operation refused. Could this be causing all the problem and why the workstations are not picking up the correct things?

Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : scin
        Primary DNS Suffix  . . . . . . . : scim.sandcompanies.com
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : exchange.sandcompanies.com

Ethernet adapter sciteam:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : BASP Virtual Adapter
        Physical Address. . . . . . . . . : 00-06-5B-0E-46-36
        DHCP Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.10.40
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.10.1
        DNS Servers . . . . . . . . . . . : 192.168.10.48
                                            192.168.10.40
                                            192.168.10.43
0
 

Author Comment

by:gorhamoien
ID: 17011530
The problem is now that if I make all workstation first DNS to DHCP server then everyone can logon but then their outlook takes forever to open.

The DHCP server which is also a DC where users authenticate to is a windows 2000 server and then two DNS they get on their workstation is the 192.168.100.40 and also 192.168.100.48

Now if the first DNS that all workstation get is 192.168.100.40 then the machines login without much delay. But then outlook does not work right away and take almost 20 minutes to connect to the exchange server which is on a separate DC which is a windows 2003 server and its IP address is 192.168.100.48

If I change the DNS order that each workstation gets to 192.168.100.48 then each machines takes 20 minutes to login but outlook works great.

We have been running these server without any issues for almost three years. But all of a sudden after we got new DNS numbers from ISP and adding them to the DNS server on the 192.168.100.40 has caused issues.

Can anyone help. Microsoft has no solution and they are still researching. They had me change the order but then no one can login and it takes forever.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17016587
Your DHCP server should be assigning the DNS IP's that's what DHCP is there for... it's not just to assign the workstation's IP address!

All DNS Servers should be replicating eachother, so it wouldn't matter which one was first actually.  

I think you should really take a look at how to configure DNS in a Server 2003 environment, and follow the guidelines outlined here:
http://technet2.microsoft.com/WindowsServer/en/Library/7f6df44c-06c3-4b92-ba32-63d895a7924b1033.mspx?mfr=true

Jeff
TechSoEasy
0
 

Author Comment

by:gorhamoien
ID: 17047745
techsoeasy, Yes DCHP server assigns the DNS servers to workstation as well. But if you read carefully it says that the problem is when it looks to DHCP Dns server first then outlook does not work and takes for ever to open which is on another server. How can I make sure that all DNS servers are replicating each other on different servers? By the way the DHCP server is windows 2000 server and exchange server is on 2003 server.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17048250
Exchange actually still uses either WINS or NETBIOS resolution... it looks as though you may not have either of those enabled.

http://support.microsoft.com/kb/837391

Jeff
TechSoEasy
0
 

Author Comment

by:gorhamoien
ID: 17125565
Thank you all for responding. After lot of thinking I finally figured out and I am surprised that even Microsoft could not be of much help. Since I have two separate domain server each havings its own farm each DNS server should have identical information and should include the zones from each server such that no matter which DNS server it can resolve from either. Once I created both servers zones on both server it was working like a charm.

Nothing to do with forward DNS, DHCP releasing which IP addresses, etc. One can only replicate each other DNS if they belong to the same domain and trusted. With separate domains and no trust between domains it is better to add other server zones. I am really surprised that it has worked well over the last three years like that.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17126265
Well, I probably should have caught that you had different domain names on each server... but thought you just modified one and not the other for posting purposes.  It would have been impossible for us to otherwise determine the cause of this problem without knowing that there were two domains without a trust.  I'm wondering if your suprise with Microsoft's inability to do the same has to do with them not being told of this as well.

Glad you got it figured out though.

Jeff
TechSoEasy
0
 

Author Comment

by:gorhamoien
ID: 17150840
Well I did mention there are two different domains and the names are different one main and one called exchange. Microsoft was on those two servers remotely and looking at it and still could not figure out. Sometimes one cannot see the obvious when it is right there. Also I did say why I cannot have it ping to the internal IP address of the exchange.domain.com and while mail.exchange.domain.com pinged fine.

I am glad it is all good now and just trying the issue froma  global perspective.
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 17350829
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now