Windows 2000 Server "regedit" not work, it display "Register Editor has been disable by your administrator"

I has infect a Virus before. I using administrator to login Windows 2000 server and run "regedit", it display "Register Editor has been disable by your administrator", is it possible to fix?
Who is Participating?
Pete LongConnect With a Mentor Technical ConsultantCommented:
or run this reg file

You could try unlocking the registry with this reg file: Just log on as administrator.

+++++++++++ Cut below +++++++++++++++++++

Windows Registry Editor Version 5.00


+++++++++++ Cut Above and Save in Notepad as a .REG FILE +++++++++++

credit to germati
Pete LongTechnical ConsultantCommented:
Start  > Run > gpedit.msc {enter}

Navigate to  > User Config\Admin Templates\System\Prevent Access To registry Editing Tools

Set it to  "Not Configured" and reboot the server

NOTE this may be set iin group policy (though if its the result of a virus I greately doubt it) it the problem persistas post back :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.