• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 182
  • Last Modified:

Sharing on 2003 server

I have a 2003 server standard on a workgroup.  I want users to access shares without being prompted for username and password.  PLus I dont want to setup a million local accounts on the machine.  How can I make it so users can double click on the server and just get to the shares ?
1 Solution
You need to create a domain and join the computer to this domain (instead of using a workgroup) -  best solution

You can enable the Guest Account on your windows 2003 server - not a good solution

You can create user account on the windows 2003 server that match the desktop logins...  -  you already know about this solution.  difficult, because you will have to create a bunch of accounts and modify these accounts as users change thier local passwords.
focusenAuthor Commented:
They dont want a domain unfortantley.. that is what I suggested.  What will happen if I enable the guest account, will that do what I need it to ?
NJ is right, a domain is the way to go.

if they say they dont want a domain,,,,, that is the same as saying "i want to enter my username/password everytime and i also want to create a nightmare with all these local accounts"

what reason did they give for not wanting a domain?  Are they confusing a windows domain with a publically registered domain by chance?
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

You can try an equally unsecure option (equal to guest acct. lol): execute a batch file on each workstation upon logon with credentials locked in!  

net use * \\server\share /user:username password
if you are sticking with a workgroup setup you need to have identical accounts for each user on every machine, once they match, you wont get prompted for passwords as the local SAM's have matching credentials which they use to authenticate
i know its not what you want, but this is the only "secure" workaround available to you in a workgroup
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now