Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2461
  • Last Modified:

Disable Multiple Remote Desktop Sessions

I want to know how to go in the registry or terminal services management on my Windows 2k3 server machine and disable multiple remote desktop sessions.  I hate remoting in from one place and not getting my locally logged in desktop session, it generates a new session and lets you have multiple simultaneous different remote sessions open.  I know this is a "feature" for some but it annoys me because I leave applications running locally and then remote in and cannot get to the already open documents etc.
Any help would be appreciated, thanks!

Nathan
0
ironwill96
Asked:
ironwill96
  • 4
  • 3
  • 2
  • +3
3 Solutions
 
infotraderCommented:
have you tried going to
start --> run "mstsc /console" (do not put quotes)
0
 
Netman66Commented:
Open up Terminal Services Configuration.
Select Server Settings on the left.
On the right , configure "Restrict each user to one session".

Is that what you are asking?

0
 
BLipmanCommented:
He wants to connect to the console ('Zero Session') every time.  I like this syntax best:

mstsc -v:servername -console

This will lock the physical console and pass you the session.  
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
harleyjdCommented:
Everyone is on the right track.

infotrader - you need to add the -v:servername

BLipman, it's /console (yeah, servername is dash v, but console is slash... go figure)

But there's another option, along the same path.

Remote Desktop Client 5.2 allows the /console to be added to the servername in the GUI...

Just start Remote Desktop Connection, type the servername and /console.

If it gives an error about an invalid client name then you need to upgrade the RDP client to 5.2 from the Windows Server 2003 -  \SUPPORT\TOOLS\MSRDPCLI.EXE

I have a Windows Server 2003 R2 CD and the file is dated 30 Nov 2005. If it's older than that then it may not have the support to get it from MS at
http://www.microsoft.com/downloads/details.aspx?FamilyID=80111f21-d48d-426e-96c2-08aa2bd23a49&DisplayLang=en
0
 
harleyjdCommented:
Dang.

That link is wrong - that's the XP SP2 version which says it is 6.0.2600.0, but it doesn't support GUI /console.

Version 5.2.3790.1830 comes off the Server 2003 R2 CD and DOES support GUI /console... I don't know what MS are playing at, but if you look at the top of the link page it claims it is 5.1.2600, and in the detail 6.0.2600.0. Thanks, Mr. Gates...



0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Just one other point... if you don't have settings configured to limit users to a single session... just open Terminal Services Manager, and switch sessions.

Jeff
TechSoEasy
0
 
ironwill96Author Commented:
Thanks for the help!  The -v:ipaddresshere -console idea worked.  I sort of wish it could just default to that, but i'm ok with having to type that in to remote to my machine.  I already had the multiple sessions disabled in the Terminal Services manager but that doesn't change the not seeing the locally logged in session which you have now showed me how to do.

Thanks!
Nathan
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You can default that if you either save the RDP client settings OR you can use the Terminal Server Management Console (TSMMC.MSC) which I think is awesome:
http://support.microsoft.com/kb/309375

I use it to access all of the networks I manage from just one screen... http://techsoeasy.com/m.jpg will show you an example.

Jeff
TechSoEasy

0
 
infotraderCommented:
This is bogus.  I am the 1st person who came up with this and I got no point split??!!

BTW, mstsc /console DOES work...  No typo, no unclarity... it just works!!  if you don't believe me, you should try it sometimes....  It actually works better because it allows you to type the server name on the RDP request windows, and if you mess up, you can retype it....

- Infotrader
0
 
ironwill96Author Commented:
Infotrader, I tried your way but it didn't work for some reason on the computer I was on and the other way did.  I might have been typing something wrong though, so I apologize for not giving you points as well.  I'm not sure if the moderators can fix it to give you points or not but I will make a post requesting it.

Thanks,
Nathan
0
 
infotraderCommented:
Hi Ironwill,

That's ok.  Don't worry about it.

I was just wondering what happened.  Thanks for the thought though.  Glad your problem is resolved regardless.

- Info
0
 
ironwill96Author Commented:
Infotrader, fixed :-)

Thanks for your help!

Nathan
0
 
infotraderCommented:
Thanks!!!
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 4
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now