Solved

SQL Server 2000 - "SQL Server does not exist or access denied"

Posted on 2006-06-20
9
408 Views
Last Modified: 2012-06-22
Ok, I am relatively new to SQL Server. I just installed SQL Server 2000 Developer Edition on my development workstation, which is XP Pro SP2. In my ASP.NET application I get the error "SQL Server does not exist or access denied." I have done some troubleshooting, looking at other questions here, microsoft, etc., but no luck. I have disabled the windows firewall and I am not running any other firewall on this box.

I moved this project from a different dev box running XP Pro SP2 with a local SQL Server 2000 instance, and it was working fine. I used the import/export wizard to transfer my database to the new box. I believe my connectionstring is OK, but I'll post it here anyway:

data source=localhost;integrated security=false;uid=mt_master;pwd=********;database=MT_Calc

mt_master is a sql server login.

I am running SQL Server 2000 SP4. I can use Enterprise Manager fine, and I can connect to the instance fine using Query Analyzer, choosing my server, etc. It just doesn't work from my application. The error occurs when it tries to open the connection. I have compared my SQL Server logins on the new dev box to those on the old and everything seems to match. I am plum out of idea!

Any help would be greatly appreciated!

jkwasson
0
Comment
Question by:jkwasson
  • 3
  • 2
  • 2
  • +2
9 Comments
 
LVL 10

Expert Comment

by:pai_prasad
ID: 16947335
data source=localhost
>> is this a DSN??...

if u meant local server ...it shud be "(local)"
0
 
LVL 21

Expert Comment

by:Yurich
ID: 16947601
I found that sometimes it's better to use server name even if it's a localhost - try that.

regs,
yurich
0
 
LVL 5

Author Comment

by:jkwasson
ID: 16948468
thanks for the replies. locahost is not a DSN, but my attempt to connect to the SQL Server directly...I tried both of these connectionstrings:

data source=(local);integrated security=false;uid=mt_master;pwd=****;database=MT_Calc
and
data source=D9150;integrated security=false;uid=mt_master;pwd=****;database=MT_Calc (D9150 is my machine name where server is running)

I got the same error with both. It is different than what I was getting before. It is:

"Login failed for user mt_master"

Seems to me like this is progress, as it seems I am now at least communicating with SQL Server enough that it is rejecting the login...Do you guys agree? I think my permissions are setup correctly for mt_master...at least they were on the other dev box before I moved to this dev box.

FYI, I also have SQLExpress 2005 running here, but I have it stopped. It installed with VS 2005...don't think it really factors into the equation here though...

so given the new error message, does that give us any more direction?

jk
0
 
LVL 3

Expert Comment

by:chhapia_chintak
ID: 16948924
The way to schedule backups in SQL Express is to use the Windows Scheduler.  Have it call a cmd file.  

That cmd file should contain following T-SQL syntax to back up your database:

suppose my database is test_db then

EXEC sp_addumpdevice 'disk', 'De_test_db', 'c:\test_db.bak'
BACKUP DATABASE TEST_DB TO De_test_db
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 3

Expert Comment

by:chhapia_chintak
ID: 16948955
Please ignore my last comment. It was done by mistake.
0
 
LVL 28

Expert Comment

by:imran_fast
ID: 16949464
check the following

1. Does user mt_master have access on database MT_Calc on server D9150
2. For SQL 2000 , On your sql server go to sql network configuation and check if tcp \ip is enables
3. For SQL 2005 , On your sql server go to sql Server configuation  Manager and check if tcp \ip is enables for network and for client
4. on your workstation from where you are unable to connect sql server check the preferd DNS name if it is correct.


Note: for option 2 and 3 go to progrm file microsoft sql server 2000/2005
0
 
LVL 5

Author Comment

by:jkwasson
ID: 16951869
imran...

1. Yes
2. Yes
3. Yes, but I am not using SQL Express for anything...
4. SQL server is loaded on my local workstation

Thanks,
jk
0
 
LVL 21

Accepted Solution

by:
Yurich earned 500 total points
ID: 16966094
1. have you tried to use trusted_connection = true (integrated_security=true) - it'll give you idea whether it's this account or a whole connection.

2. Have you tried to connect using MSDE with your credentials?

regs,
yurich
0
 
LVL 5

Author Comment

by:jkwasson
ID: 17052421
that seemed to do the trick...thanks!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Join & Write a Comment

Everyone has problem when going to load data into Data warehouse (EDW). They all need to confirm that data quality is good but they don't no how to proceed. Microsoft has provided new task within SSIS 2008 called "Data Profiler Task". It solve th…
JSON is being used more and more, besides XML, and you surely wanted to parse the data out into SQL instead of doing it in some Javascript. The below function in SQL Server can do the job for you, returning a quick table with the parsed data.
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.
Viewers will learn how the fundamental information of how to create a table.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now