Solved

How to change the Username and Password in a Cisco Series 827 ADSL Router

Posted on 2006-06-20
10
627 Views
Last Modified: 2010-05-18
I changed my ISP from one ISP to another but I need to know how to change it in my cisco router. I dont wish to pay a cisco engineer alot of money for just changing the username and password. If someone were able to tell me how to do it I would be greatful. I know that it involes the console as Cisco routers dont have GUI's and I'm fairly onto it person, so if someone would be nice enough to let me know how.

Thanks
David
0
Comment
Question by:milltechtga
  • 6
  • 4
10 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 16950254
Assuming that you can connect to the console port with a PC using Hyperterminal (settings 9600,8-n-1-no flow control)
Router>enable
Password:<password>
Router#config term
Router(config)#username mynewusername password mygoodpassword
Router(config)#no username myoldusername
Router(config)#end
Router#copy run start
[OK]
Router#
0
 

Author Comment

by:milltechtga
ID: 16955239
I got as far as the first step, and then it asks me for the password. I don’t know what it is. Are there any standard or default passwords I could try?
If that didn’t work how hard would it be to reset the router and program it again? Does it involve more than just the username and password?

Thanks
David
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16955304
If you don't know the enable password, the default is a blank, no password.
If that doesn't work, here's the enable password recovery procedure
http://www.cisco.com/warp/public/474/pswdrec_827.shtml
0
 

Author Comment

by:milltechtga
ID: 16956321
Thanks Irmoore, I managed to reset the password using the recovery link you gave me. I put in the new username and password and it looks like its connecting yet no page will display. Is there any other settings I have to change? Maybe DNS settings or something simply like that?

Thanks
David
0
 

Author Comment

by:milltechtga
ID: 16956606
Thought I would post this if it helps.

Building configuration...                        

Current configuration:                      
!
version 12.1            
no service pad              
service timestamps debug uptime                              
service timestamps log uptime                            
service password-encryption                          
!
hostname Kongs              
!
enable secret 5 $1$8uCL$YDTl6XsOLZkMBE6NrzbSN/                                              
enable password 7 095E4F071D551A                                
!
username milltechtga@clear.net.nz password 7 1407115F150B3F                                                          
!
!
!
!
ip subnet-zero              
no ip domain-lookup                  
ip name-server 202.27.184.3                          
ip name-server 202.27.184.5                          
!
!
!
!
!
!
interface Ethernet0                  
 ip address 192.168.2.1 255.255.255.0                                    
 ip nat inside              
 no ip route-cache                  
 no ip mroute-cache                  
 shutdown        
!
interface ATM0              
 no ip address              
 no atm ilmi-keepalive                      
 pvc 0/100          
  encapsulation aal5mux ppp dialer                                  
  dialer pool-member 1                      
 !  
 bundle-enable              
 dsl operating-mode auto                        
!
interface Dialer0                
 ip address 210.86.2.140 255.255.255.0                                      
 ip accounting output-packets                            
 ip nat outside              
 encapsulation ppp                  
 no ip route-cache                  
 no ip mroute-cache                  
 dialer pool 1              
 dialer-group 1              
 ppp authentication pap callin                              
 ppp pap sent-username kongsnz.xadsl@xtra.co.nz password 7 00101C041D                                                                  
!
ip nat inside source list 101 interface Dialer0 overload                                                        
ip nat inside source static tcp 192.168.1.10 3389 210.86.2.140 3389 extendable                                                                              
ip nat inside source static tcp 192.168.1.10 1723 210.86.2.140 1723 extendable                                                                              
ip nat inside source static udp 192.168.1.10 1701 210.86.2.140 1701 extendable                                                                              
ip nat inside source static udp 192.168.1.10 500 210.86.2.140 500 extendable                                                                            
ip nat inside source static udp 192.168.1.10 25099 210.86.2.140 25099 extendable                                                                                

ip nat inside source static tcp 192.168.1.10 25099 210.86.2.1                                                            
ip nat inside source static tcp 192.168.1.10 25099 210.86.2.1                                                            
ip nat inside source static udp 192.168.1.10 5631 210.86.2.140 5631 extendable
ip nat inside source static udp 192.168.1.10 5632 210.86.2.140 5632 extendable
ip nat inside source static tcp 192.168.1.10 5632 210.86.2.140 5632 extendable
ip nat inside source static tcp 192.168.1.10 5631 210.86.2.140 5631 extendable
ip nat inside source static udp 192.168.1.10 1706 210.86.2.140 1706 extendable
ip nat inside source static tcp 192.168.1.10 1706 210.86.2.140 1706 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password 7 105C081701471F
 login
!
scheduler max-task-time 5000
end

The router plugs into a computer with the IP of 192.168.2.2 so it needs to match that. And it get assigned a IP by my ISP.
Anything you can see that I need to change?

Thanks
David
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:milltechtga
ID: 16956657
After looking at the log file I noticed this.

ppp authentication pap callin                              
 ppp pap sent-username kongsnz.xadsl@xtra.co.nz password 7 00101C041D                

Am I correct in saying that it sounds like it using the old login??
Maybe that is the problem?

Thanks
David
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 16956909
Yes, because of this entry:
>ppp pap sent-username kongsnz.xadsl@xtra.co.nz password 7 00101C041D    

Change that one, too
Router>enable
Password:<password>
Router#config term
Router(config)#int dial0
Router(config-if)#no ppp pap sent-username kongsnz.xadsl@xtra.co.nz
Router(config-if)#ppp pap sent-username milltechtga@clear.net.nz password <password>
Router(config-if)#end
Router#copy run start
[OK]
Router#
0
 

Author Comment

by:milltechtga
ID: 16957283
Ok I have changed that also. But still no internet. I'm not sure where to here. Altho I have noticed that these lines:

ip subnet-zero              
no ip domain-lookup                  
ip name-server 202.27.184.3                          
ip name-server 202.27.184.5  

Refer to my old ISP dns servers, would these have to be updated to my new ISP dns server?

Thanks
David
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 16958712
No, those lines don't change.
Can you post result of
Router#show ip int brief
Router#show ip route

Check with your ISP for the ATM pvc settings
>pvc 0/100          <== this is what you have now. The new ISP may require a different setting here
0
 

Author Comment

by:milltechtga
ID: 16980171
The PVC settings remain the same. I will post the info you mentioed when I get home tonight.

Thanks
David
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

In a WLAN, anything you broadcast over the air can be intercepted.  By default a wireless network is wide open to all until security is configured. Even when security is configured information can still be intercepted! It is very important that you …
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now