Solved

SBS SMTP Connector

Posted on 2006-06-21
10
4,614 Views
Last Modified: 2011-02-28
Can someone direct me to a walk through for setting up an SMTP connector on a 2003 SBS? I have used the SBS wizard and still can't seem to get email to move off-site...either via DNS or via an SMTP connector to my hosting company's SMTP server.
I know that my hosting company requires SSL and related custom ports. There doesn't seem to be anywhere in the SMTP connector to configure these values.
How can I verify that the SMTP server I am trying to communicate is a "smart host".
Should I be trying to connect with the SMTP server of Bellsouth, my ISP, rather than my domain hosting company? I know that sometimes they prefer this. However I have no problem setting up the SMTP connection directly on the clients in Outlook.

The POP3 Connector to my domain hosting company is working fine.
0
Comment
Question by:ArkAdmin
10 Comments
 
LVL 13

Expert Comment

by:itcoza
ID: 16951529
Hi,

Here is a test that you can do for the outbound SMTP.  What you will need is the FQDN (or IP address) of the ISP (connectivity provider) SMTP server.

Open a command prompt window:
Type “Telnet FQDN 25” You must type in the name or IP of the ISP SMTP server in place of FQDN
Type "HELO FQDN" for example "HELO exchange.server.com"
Type "mail from: Mail@adresse.dk" use your own e-mail address
Type "rcpt to: Mail@modtager.dk" again your own e-mail address
Type "data"
Type "subject: "your subject" and press enter twice
Type your message and finish with "." then Enter
Finish with "Quit"

If you are allowed to relay mail through your ISP SMTP server, you will receive a mail from your self within the time it takes your server to collect POP3 mail.  Many ISP’s do not allow port 25 traffic out from their system and you will need to forward all mail to their SMTP server.

The other option is to give your ISP a call and ask them.

I walk through to set up the SMTP connector can be found at: http://support.microsoft.com/default.aspx?scid=kb;en-us;314961&sd=tech 

Regards,
M
0
 

Assisted Solution

by:eke-the-electron
eke-the-electron earned 200 total points
ID: 16954214
Check in the Server Management Console Under

Exchange - Servers - "Your Server Name" - Queues

It will show you if the messages are stuck in the queue you can right click to find the messages stuck.
And it will tell you what the error is, something like " Could not connect to SMTP using any know protocals" or whatever it happens to be at the bottom of the screen.

You should look at the following articles:

http://www.microsoft.com/technet/prodtechnol/exchange/guides/E2k3TransnRouting/40f655a8-f5f9-4e25-a93e-9dc14c8ceaa2.mspx?mfr=true

http://ts2community.com/blogs/jwlocke/archive/2005/12/17/507.aspx
0
 

Author Comment

by:ArkAdmin
ID: 16954676
itcoza, i was able to telnet to the mail server. everything works fine up to where i enter the "rcpt to:" command. it asks me to "please try again later"

not sure how to proceed along this line
0
 
LVL 74

Assisted Solution

by:Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy earned 100 total points
ID: 16955600
It's quite possible that your ISP is blocking port 25.  Check with them before making ANY additional changes to your server.

Jeff
TechSoEasy
0
 
LVL 13

Expert Comment

by:itcoza
ID: 16956026
Hi,  

What you need to do in this case is that you need to contact your ISP and find out if their SMTP server requires authentication for you to use it.  If your connection is a broadband connection, it is most often your access username and password.  Best to contact them and find out.  Many broadband providers prevent the sending of SMTP mail without some form of authentication due to the SPAM problem.

Regards,
M


:)
0
Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

 
LVL 13

Expert Comment

by:itcoza
ID: 16956038
Just as a matter of interest, did you attempt to make a telnet session to send mail to your hosting provider?  This should show you clearly if your Connectivity provider is blocking SMTP on the default port 25.

:)
0
 

Author Comment

by:ArkAdmin
ID: 16959903
Here are the settings that my domain host requires. As I mentioned above, it is pretty easy to set this up through outlook on the individual clients, but there doesn't seem to be a place in the SBS SMTP connector to put this type of info.

Outgoing Mail Server: smtp.yourdomain.com (Please, replace yourdomain.com with your hosted domain name).
Authentication – Turn on Outgoing Server Authentication and use the username and password as specified in 2 and 3.
SMTP Port and Connection settings - you have two options:
·         Outgoing (SMTP) mail port: 465. You have to use SSL secured connection for the Outgoing mail server.

·         Outgoing (SMTP) mail port: 587. You have to use TLS secured connection for the Outgoing mail server.

0
 

Author Comment

by:ArkAdmin
ID: 16961161
Ok, so rather than using the SMTP server of my Domain Host with all the specialized ports, I am trying to use the SMTP server of Bellsouth, my ISP.

I have spoken with Bellsouth. They have created an MX record link for my company domain name. They tell me that this will guarantee that port 25 will not be blocked. I'm not sure if this will help or not but it makes sense.

Bellsouth normally blocks port 25 when a username and password is not provided. I don't see anywhere in the SBS SMTP connector to enter a username and password or to enable SMTP authentication. In Exchange, the SMTP connector is set up separately from the POP3 connector where the username and pwd is stored.

I am still not quite sure how to configure the SMTP connector. Do I just enter the Bellsouth SMTP server name as the "smarthost" and enter an "*" under the address space?
Should "Delivery Options" specify "Always Run"?
What should my ETRN, TURN settings be?

Thanks again.






0
 
LVL 13

Accepted Solution

by:
itcoza earned 200 total points
ID: 16961880
Yip... that's it.  By entering in the "*" you indicate that the SMTP connector must fire for any domain.

Give it a go and let's see... don't forget to set you server as the bridgehead server.

Let me know how it goes.

Regards,
M
0
 

Author Comment

by:ArkAdmin
ID: 16962057
ok, enough for now, i'm not up yet but i will start a new related question.
Thanks for everyone's help.
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A lot of problems and solutions are available on the net for the error message "Source server does not meet minimum requirements for migration" while performing a migration from Small Business Server 2003 to SBS 2008. This error pops up just before …
This guide is intended for migrating Windows 2003 Standard with Exchange 2003 to Windows Small Business Server 2008. You will need the following: Exchange Best Practice Analyzer: http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now